aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>2008-10-08 19:50:24 +0000
committeraliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>2008-10-08 19:50:24 +0000
commit9e472e101f37233f4e32d181d2fee29014c1cf2f (patch)
tree11355529c87a6dce782b8500ce53236b4744600c /Makefile
parentCRIS: linux-user signals dont need ERP compensation after break anymore. (diff)
downloadqemu-kvm-9e472e101f37233f4e32d181d2fee29014c1cf2f.tar.gz
qemu-kvm-9e472e101f37233f4e32d181d2fee29014c1cf2f.tar.bz2
qemu-kvm-9e472e101f37233f4e32d181d2fee29014c1cf2f.zip
Fix IO performance regression in sparc
Replace signalfd with signal handler/pipe. There is no way to interrupt the CPU execution loop when a file descriptor becomes readable. This results in a large performance regression in sparc emulation during bootup. This patch switches us to signal handler/pipe which was originally suggested by Ian Jackson. The signal handler lets us interrupt the CPU emulation loop while the write to a pipe lets us avoid the select/signal race condition. Signed-off-by: Anthony Liguori <aliguori@us.ibm.com> git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@5451 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 35061a4b1..36b36cd26 100644
--- a/Makefile
+++ b/Makefile
@@ -59,10 +59,6 @@ else
BLOCK_OBJS += block-raw-posix.o
endif
-ifdef CONFIG_AIO
-BLOCK_OBJS += compatfd.o
-endif
-
######################################################################
# libqemu_common.a: Target independent part of system emulation. The
# long term path is to suppress *all* target specific code in case of