aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Capitulino <lcapitulino@redhat.com>2009-10-07 13:41:48 -0300
committerAnthony Liguori <aliguori@us.ibm.com>2009-10-08 21:17:18 -0500
commita6fd08eb625ae3c6a878f527270a9d384d1b04d2 (patch)
treea303e22cb3a27f584637acb7e7f33ddf66f7ac30 /Makefile
parentQObject: Accept NULL (diff)
downloadqemu-kvm-a6fd08eb625ae3c6a878f527270a9d384d1b04d2.tar.gz
qemu-kvm-a6fd08eb625ae3c6a878f527270a9d384d1b04d2.tar.bz2
qemu-kvm-a6fd08eb625ae3c6a878f527270a9d384d1b04d2.zip
Introduce QList
QList is a high-level data type that can be used to store QObjects in a singly-linked list. The following functions are available: - qlist_new() Create a new QList - qlist_append() Append a QObject to the list - qlist_iter() Iterate over stored QObjects Patchworks-ID: 35334 Signed-off-by: Luiz Capitulino <lcapitulino@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6036dfb1c..18319f81c 100644
--- a/Makefile
+++ b/Makefile
@@ -124,7 +124,7 @@ obj-y += buffered_file.o migration.o migration-tcp.o net.o qemu-sockets.o
obj-y += qemu-char.o aio.o net-checksum.o savevm.o
obj-y += msmouse.o ps2.o
obj-y += qdev.o qdev-properties.o
-obj-y += qint.o qstring.o qdict.o qemu-config.o
+obj-y += qint.o qstring.o qdict.o qlist.o qemu-config.o
obj-$(CONFIG_BRLAPI) += baum.o
obj-$(CONFIG_WIN32) += tap-win32.o