summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Capitulino <lcapitulino@redhat.com>2009-12-10 17:15:53 -0200
committerAnthony Liguori <aliguori@us.ibm.com>2009-12-12 08:17:31 -0600
commitdb830f26cbe996d1f9ea74c18ce558eedbf9bcab (patch)
tree3f651b8c3a9b2e1edf3a34ae70f98dabd6b75598 /Makefile
parentMakefile: move QObject objs to their own entry (diff)
downloadqemu-kvm-db830f26cbe996d1f9ea74c18ce558eedbf9bcab.tar.gz
qemu-kvm-db830f26cbe996d1f9ea74c18ce558eedbf9bcab.tar.bz2
qemu-kvm-db830f26cbe996d1f9ea74c18ce558eedbf9bcab.zip
QDict: Introduce qdict_get_qbool()
This is a helper function that does type checking before retrieving a QBool from the dictionary. Signed-off-by: Luiz Capitulino <lcapitulino@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com> (cherry picked from commit cd4dde36ae8e7bd8e02839533c5708011bf994cf)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ea90c235f..b4356ae52 100644
--- a/Makefile
+++ b/Makefile
@@ -246,7 +246,7 @@ qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx
check-qint: check-qint.o qint.o qemu-malloc.o
check-qstring: check-qstring.o qstring.o qemu-malloc.o
-check-qdict: check-qdict.o qdict.o qint.o qstring.o qemu-malloc.o
+check-qdict: check-qdict.o qdict.o qint.o qstring.o qbool.o qemu-malloc.o
check-qlist: check-qlist.o qlist.o qint.o qemu-malloc.o
check-qfloat: check-qfloat.o qfloat.o qemu-malloc.o
check-qjson: check-qjson.o qfloat.o qint.o qdict.o qstring.o qlist.o qbool.o qjson.o json-streamer.o json-lexer.o json-parser.o qemu-malloc.o