aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-08-11 12:59:29 +0300
committerAvi Kivity <avi@redhat.com>2009-08-11 12:59:29 +0300
commitef97066cd0ad10f5053274980fb8e0faaf079942 (patch)
tree286218eb4d5e7ef38eef8fc5d59d3d599c0ca04c /Makefile
parentMerge commit 'e18ea868d2d16640081a404d533a57e3372428a5' into upstream-merge (diff)
parentconvert gprof flags to style of rest of Makefile (diff)
downloadqemu-kvm-ef97066cd0ad10f5053274980fb8e0faaf079942.tar.gz
qemu-kvm-ef97066cd0ad10f5053274980fb8e0faaf079942.tar.bz2
qemu-kvm-ef97066cd0ad10f5053274980fb8e0faaf079942.zip
Merge commit 'f622d8a33dfbd83468d71e48624925c950b4010e' into upstream-merge
* commit 'f622d8a33dfbd83468d71e48624925c950b4010e': convert gprof flags to style of rest of Makefile Add cocoa libs at Darwin selection time CURL libs are used both by tools and softmmu VDE libs are used both by tools and softmmu Add libs_tools support Disable aio in mingw32 Conflicts: Makefile.target Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 66b3cf518..a9320e46c 100644
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,7 @@ endif
VPATH=$(SRC_PATH):$(SRC_PATH)/hw
-LIBS+=-lz
+LIBS+=-lz $(LIBS_TOOLS)
ifdef BUILD_DOCS
DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8
@@ -140,14 +140,11 @@ slirp-obj-y += slirp.o mbuf.o misc.o sbuf.o socket.o tcp_input.o tcp_output.o
slirp-obj-y += tcp_subr.o tcp_timer.o udp.o bootp.o tftp.o
obj-$(CONFIG_SLIRP) += $(addprefix slirp/, $(slirp-obj-y))
-LIBS+=$(VDE_LIBS)
-
# xen backend driver support
obj-$(CONFIG_XEN) += xen_backend.o xen_devconfig.o
obj-$(CONFIG_XEN) += xen_console.o xenfb.o xen_disk.o xen_nic.o
QEMU_CFLAGS+=$(CURL_CFLAGS)
-LIBS+=$(CURL_LIBS)
cocoa.o: cocoa.m