aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Capitulino <lcapitulino@redhat.com>2009-08-28 15:27:07 -0300
committerAnthony Liguori <aliguori@us.ibm.com>2009-09-04 09:37:29 -0500
commitfb08dde0988f920fed93d07745790e7ebc12af32 (patch)
tree0309f3eeb38a92d5d5c66c307dd3396ff27ed825 /Makefile
parentIntroduce QString (diff)
downloadqemu-kvm-fb08dde0988f920fed93d07745790e7ebc12af32.tar.gz
qemu-kvm-fb08dde0988f920fed93d07745790e7ebc12af32.tar.bz2
qemu-kvm-fb08dde0988f920fed93d07745790e7ebc12af32.zip
Introduce QDict
QDict is a high-level dictionary data type that can be used to store a collection of QObjects. A unique key is associated with only one QObject. The following functions are available: - qdict_new() Create a new QDict - qdict_put() Add a new 'key:object' pair - qdict_get() Get the QObject of a given key - qdict_del() Delete a 'key:object' pair - qdict_size() Return the size of the dictionary - qdict_haskey() Check if a given 'key' exists Some high-level helpers to operate on QStrings and QInts objects are also provided. Signed-off-by: Luiz Capitulino <lcapitulino@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d7618bad6..983fe39a9 100644
--- a/Makefile
+++ b/Makefile
@@ -91,7 +91,7 @@ obj-y += buffered_file.o migration.o migration-tcp.o net.o qemu-sockets.o
obj-y += qemu-char.o aio.o net-checksum.o savevm.o
obj-y += msmouse.o ps2.o
obj-y += qdev.o qdev-properties.o ssi.o
-obj-y += qint.o qstring.o
+obj-y += qint.o qstring.o qdict.o
obj-$(CONFIG_BRLAPI) += baum.o
obj-$(CONFIG_WIN32) += tap-win32.o