aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuan Quintela <quintela@redhat.com>2009-10-07 02:41:03 +0200
committerAnthony Liguori <aliguori@us.ibm.com>2009-10-08 21:17:10 -0500
commitfe0d4d3f7769d5b024e8166fc075148f9cf76ba9 (patch)
tree8bc20ffe4d312cb782b815f27ec64ba9efb6660d /Makefile
parentAdd new config-devices.mak for each target (diff)
downloadqemu-kvm-fe0d4d3f7769d5b024e8166fc075148f9cf76ba9.tar.gz
qemu-kvm-fe0d4d3f7769d5b024e8166fc075148f9cf76ba9.tar.bz2
qemu-kvm-fe0d4d3f7769d5b024e8166fc075148f9cf76ba9.zip
Generate config-devices.h
Generate config-devices.h for each target and config-all-devices.h for common library. We don't want to name both config-devices.h to avoid path problems Patchworks-ID: 35195 Signed-off-by: Juan Quintela <quintela@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 062c129cf..a5a17d198 100644
--- a/Makefile
+++ b/Makefile
@@ -40,15 +40,18 @@ config-all-devices.mak: $(SUBDIR_DEVICES_MAK)
-include config-all-devices.mak
-build-all: config-host.h
+build-all: config-host.h config-all-devices.h
$(call quiet-command, $(MAKE) $(SUBDIR_MAKEFLAGS) $(TOOLS) $(DOCS) recurse-all,)
config-host.h: config-host.h-timestamp
config-host.h-timestamp: config-host.mak
+config-all-devices.h: config-all-devices.h-timestamp
+config-all-devices.h-timestamp: config-all-devices.mak
+
SUBDIR_RULES=$(patsubst %,subdir-%, $(TARGET_DIRS))
-subdir-%: config-host.h
+subdir-%: config-host.h config-all-devices.h
$(call quiet-command,$(MAKE) $(SUBDIR_MAKEFLAGS) -C $* V="$(V)" TARGET_DIR="$*/" all,)
$(filter %-softmmu,$(SUBDIR_RULES)): libqemu_common.a