aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Liguori <aliguori@us.ibm.com>2009-09-04 10:13:29 -0500
committerAnthony Liguori <aliguori@us.ibm.com>2009-09-04 10:13:29 -0500
commitc34ebfdc8715f03d53e154758423c902324fee06 (patch)
treeba773bcd12f7c24519ce5ee804df27696a48a90e /configure
parentmips malta: Fix fdc regression and use qdev for i8042 setup (diff)
downloadqemu-kvm-c34ebfdc8715f03d53e154758423c902324fee06.tar.gz
qemu-kvm-c34ebfdc8715f03d53e154758423c902324fee06.tar.bz2
qemu-kvm-c34ebfdc8715f03d53e154758423c902324fee06.zip
Bring pcbios, seabios, and vgabios into the tree as git submodules. Right now,
they aren't integrated into the build but we can do that incrementally. Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure b/configure
index 64a039139..b78341ccc 100755
--- a/configure
+++ b/configure
@@ -2405,10 +2405,12 @@ done # for target in $targets
# build tree in object directory if source path is different from current one
if test "$source_path_used" = "yes" ; then
DIRS="tests tests/cris slirp audio block pc-bios/optionrom"
+ DIRS="$DIRS roms/pcbios roms/seabios roms/vgabios"
FILES="Makefile tests/Makefile"
FILES="$FILES tests/cris/Makefile tests/cris/.gdbinit"
FILES="$FILES tests/test-mmap.c"
FILES="$FILES pc-bios/optionrom/Makefile pc-bios/keymaps pc-bios/video.x"
+ FILES="$FILES roms/pcbios/Makefile roms/seabios/Makefile roms/vgabios/Makefile"
for bios_file in $source_path/pc-bios/*.bin $source_path/pc-bios/*.dtb $source_path/pc-bios/openbios-*; do
FILES="$FILES pc-bios/`basename $bios_file`"
done
@@ -2422,6 +2424,20 @@ if test "$source_path_used" = "yes" ; then
done
fi
+# temporary config to build submodules
+for rom in seabios vgabios pcbios; do
+ config_mak=roms/$rom/config.mak
+ echo "# Automatically generated by configure - do not modify" >> $config_mak
+ echo "SRC_PATH=$source_path/roms/$rom" >> $config_mak
+ echo "CC=$cc" >> $config_mak
+ echo "BCC=bcc" >> $config_mak
+ echo "CPP=${cross_prefix}cpp" >> $config_mak
+ echo "OBJCOPY=objcopy" >> $config_mak
+ echo "IASL=iasl" >> $config_mak
+ echo "HOST_CC=$host_cc" >> $config_mak
+ echo "LD=$ld" >> $config_mak
+done
+
for hwlib in 32 64; do
d=libhw$hwlib
mkdir -p $d