summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-03-08 18:05:47 +0200
committerAvi Kivity <avi@redhat.com>2009-03-08 18:05:47 +0200
commitb2348016dfafa932523c2d4ac842ba82ce90edf1 (patch)
treee087c868f49ce9ee370ed3c6657ac0075ad4ae47 /cpu-all.h
parentkvm: external module: add kvm-ia64.c to hack files list (diff)
parentUse firmware configuration instead of NVRAM (initial patch by Aurelien Jarno) (diff)
downloadqemu-kvm-b2348016dfafa932523c2d4ac842ba82ce90edf1.tar.gz
qemu-kvm-b2348016dfafa932523c2d4ac842ba82ce90edf1.tar.bz2
qemu-kvm-b2348016dfafa932523c2d4ac842ba82ce90edf1.zip
Merge branch 'qemu-cvs'
* qemu-cvs: (135 commits) Use firmware configuration instead of NVRAM (initial patch by Aurelien Jarno) Add new entries to firmware configuration device Rename _BSD to HOST_BSD so that it's more obvious that it's defined by configure target-mips: remove dead code target-mips: rename helpers from do_ to helper_ do not pretend to support low voltage operation Fix correct reset value for ARM CP15 c1 auxiliary control register Work around QEMU GDB stub suboptimality Fix off-by-one errors for Altivec and SPE registers Use C99 initializers for BlockDriver methods clean build: Fix remaining m68k warnings clean build: Fix arm build warnings arm: Fix gic_irq_state.level bitfield type target-ppc: move the CD-ROM drive to the second IDE ppc_oldworld: swap the MACIO and CMD646 IDE controllers Use a dedicated function to request exit from execution loop Fix texinfo syntax errors. Disable BAT for 970 Fix mfcr on ppc64-softmmu Keep SLB in-CPU ... Conflicts: qemu/configure qemu/cpu-defs.h qemu/exec.c qemu/hw/pci-hotplug.c qemu/monitor.c qemu/net.c qemu/pc-bios/Makefile qemu/pc-bios/bios.bin qemu/qemu-tool.c qemu/sysemu.h qemu/vl.c Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'cpu-all.h')
-rw-r--r--cpu-all.h3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpu-all.h b/cpu-all.h
index 3d01ee6b2..3c91d07a6 100644
--- a/cpu-all.h
+++ b/cpu-all.h
@@ -760,7 +760,6 @@ extern CPUState *cpu_single_env;
extern int64_t qemu_icount;
extern int use_icount;
-#define CPU_INTERRUPT_EXIT 0x01 /* wants exit from main loop */
#define CPU_INTERRUPT_HARD 0x02 /* hardware interrupt pending */
#define CPU_INTERRUPT_EXITTB 0x04 /* exit the current TB (use for x86 a20 case) */
#define CPU_INTERRUPT_TIMER 0x08 /* internal timer exception pending */
@@ -774,6 +773,8 @@ extern int use_icount;
void cpu_interrupt(CPUState *s, int mask);
void cpu_reset_interrupt(CPUState *env, int mask);
+void cpu_exit(CPUState *s);
+
/* Breakpoint/watchpoint flags */
#define BP_MEM_READ 0x01
#define BP_MEM_WRITE 0x02