summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2008-12-01 18:51:57 +0200
committerAvi Kivity <avi@redhat.com>2008-12-01 18:51:57 +0200
commit13856f17ce790737b928961b7fb5a3adddc95124 (patch)
tree8e41ccd64029c5e90e1493b76cd8b5cecacb0884 /cpu-defs.h
parentDevice-assignment: init_assigned_device() error handling (diff)
parentSpelling and grammar fixes (diff)
downloadqemu-kvm-13856f17ce790737b928961b7fb5a3adddc95124.tar.gz
qemu-kvm-13856f17ce790737b928961b7fb5a3adddc95124.tar.bz2
qemu-kvm-13856f17ce790737b928961b7fb5a3adddc95124.zip
Merge branch 'qemu-cvs'
Conflicts: qemu/Makefile qemu/block.c qemu/configure qemu/exec.c qemu/hw/cirrus_vga.c qemu/hw/ide.c qemu/hw/vga.c qemu/vl.c Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'cpu-defs.h')
-rw-r--r--cpu-defs.h11
1 files changed, 6 insertions, 5 deletions
diff --git a/cpu-defs.h b/cpu-defs.h
index 902d2b48e..6ca84b2ef 100644
--- a/cpu-defs.h
+++ b/cpu-defs.h
@@ -29,6 +29,7 @@
#include <inttypes.h>
#include <pthread.h>
#include "osdep.h"
+#include "sys-queue.h"
#ifndef TARGET_LONG_BITS
#error TARGET_LONG_BITS must be defined before including this header
@@ -115,7 +116,7 @@ typedef struct CPUTLBEntry {
target_ulong addr_write;
target_ulong addr_code;
/* Addend to virtual address to get physical address. IO accesses
- use the correcponding iotlb value. */
+ use the corresponding iotlb value. */
#if TARGET_PHYS_ADDR_BITS == 64
/* on i386 Linux make sure it is aligned */
target_phys_addr_t addend __attribute__((aligned(8)));
@@ -147,14 +148,14 @@ struct KVMState;
typedef struct CPUBreakpoint {
target_ulong pc;
int flags; /* BP_* */
- struct CPUBreakpoint *prev, *next;
+ TAILQ_ENTRY(CPUBreakpoint) entry;
} CPUBreakpoint;
typedef struct CPUWatchpoint {
target_ulong vaddr;
target_ulong len_mask;
int flags; /* BP_* */
- struct CPUWatchpoint *prev, *next;
+ TAILQ_ENTRY(CPUWatchpoint) entry;
} CPUWatchpoint;
/* forward decleration */
@@ -203,10 +204,10 @@ struct KVMCPUState {
\
/* from this point: preserved by CPU reset */ \
/* ice debug support */ \
- CPUBreakpoint *breakpoints; \
+ TAILQ_HEAD(breakpoints_head, CPUBreakpoint) breakpoints; \
int singlestep_enabled; \
\
- CPUWatchpoint *watchpoints; \
+ TAILQ_HEAD(watchpoints_head, CPUWatchpoint) watchpoints; \
CPUWatchpoint *watchpoint_hit; \
\
struct GDBRegisterState *gdb_regs; \