summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-03-08 18:05:47 +0200
committerAvi Kivity <avi@redhat.com>2009-03-08 18:05:47 +0200
commitb2348016dfafa932523c2d4ac842ba82ce90edf1 (patch)
treee087c868f49ce9ee370ed3c6657ac0075ad4ae47 /cpu-defs.h
parentkvm: external module: add kvm-ia64.c to hack files list (diff)
parentUse firmware configuration instead of NVRAM (initial patch by Aurelien Jarno) (diff)
downloadqemu-kvm-b2348016dfafa932523c2d4ac842ba82ce90edf1.tar.gz
qemu-kvm-b2348016dfafa932523c2d4ac842ba82ce90edf1.tar.bz2
qemu-kvm-b2348016dfafa932523c2d4ac842ba82ce90edf1.zip
Merge branch 'qemu-cvs'
* qemu-cvs: (135 commits) Use firmware configuration instead of NVRAM (initial patch by Aurelien Jarno) Add new entries to firmware configuration device Rename _BSD to HOST_BSD so that it's more obvious that it's defined by configure target-mips: remove dead code target-mips: rename helpers from do_ to helper_ do not pretend to support low voltage operation Fix correct reset value for ARM CP15 c1 auxiliary control register Work around QEMU GDB stub suboptimality Fix off-by-one errors for Altivec and SPE registers Use C99 initializers for BlockDriver methods clean build: Fix remaining m68k warnings clean build: Fix arm build warnings arm: Fix gic_irq_state.level bitfield type target-ppc: move the CD-ROM drive to the second IDE ppc_oldworld: swap the MACIO and CMD646 IDE controllers Use a dedicated function to request exit from execution loop Fix texinfo syntax errors. Disable BAT for 970 Fix mfcr on ppc64-softmmu Keep SLB in-CPU ... Conflicts: qemu/configure qemu/cpu-defs.h qemu/exec.c qemu/hw/pci-hotplug.c qemu/monitor.c qemu/net.c qemu/pc-bios/Makefile qemu/pc-bios/bios.bin qemu/qemu-tool.c qemu/sysemu.h qemu/vl.c Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'cpu-defs.h')
-rw-r--r--cpu-defs.h4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpu-defs.h b/cpu-defs.h
index 2021c6ea6..f439ac066 100644
--- a/cpu-defs.h
+++ b/cpu-defs.h
@@ -27,6 +27,7 @@
#include "config.h"
#include <setjmp.h>
#include <inttypes.h>
+#include <signal.h>
#include <pthread.h>
#include "osdep.h"
#include "sys-queue.h"
@@ -185,6 +186,7 @@ struct KVMCPUState {
memory was accessed */ \
uint32_t halted; /* Nonzero if the CPU is in suspend state */ \
uint32_t interrupt_request; \
+ volatile sig_atomic_t exit_request; \
/* The meaning of the MMU modes is defined in the target code. */ \
CPUTLBEntry tlb_table[NB_MMU_MODES][CPU_TLB_SIZE]; \
target_phys_addr_t iotlb[NB_MMU_MODES][CPU_TLB_SIZE]; \
@@ -216,7 +218,7 @@ struct KVMCPUState {
jmp_buf jmp_env; \
int exception_index; \
\
- void *next_cpu; /* next CPU sharing TB cache */ \
+ CPUState *next_cpu; /* next CPU sharing TB cache */ \
int cpu_index; /* CPU index (informative) */ \
int running; /* Nonzero if cpu is currently running(usermode). */ \
int thread_id; \