aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-08-11 12:08:44 +0300
committerAvi Kivity <avi@redhat.com>2009-08-11 12:08:44 +0300
commit8f9663787f57c8ed34865ab063f91354d7e46b98 (patch)
tree37d91d7b74e1225bb6357afc983177ae6764ff19 /pc-bios
parentMerge commit '0dbfc67558f6eb6be219fd2992b7d70e0e11f4ca' into upstream-merge (diff)
parentRename CPPFLAGS to QEMU_CFLAGS (diff)
downloadqemu-kvm-8f9663787f57c8ed34865ab063f91354d7e46b98.tar.gz
qemu-kvm-8f9663787f57c8ed34865ab063f91354d7e46b98.tar.bz2
qemu-kvm-8f9663787f57c8ed34865ab063f91354d7e46b98.zip
Merge commit 'a558ee17761c3c9ef22792bd5097880ab92f1bf5' into upstream-merge
* commit 'a558ee17761c3c9ef22792bd5097880ab92f1bf5': Rename CPPFLAGS to QEMU_CFLAGS We set -Werror through configure now Move to configure CONFIG_WIN32 libraries needed always Move to configure CONFIG_SOLARIS libraries needed always CLOCKLIBS was used for all binaries PTHREADLIBS was used for all binaries We want to pass LIB through configuration files now We use -lz for all binaries Conflicts: Makefile.target Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'pc-bios')
-rw-r--r--pc-bios/optionrom/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
index 41c0ad4fd..840c8954b 100644
--- a/pc-bios/optionrom/Makefile
+++ b/pc-bios/optionrom/Makefile
@@ -7,9 +7,9 @@ include $(SRC_PATH)/rules.mak
VPATH=$(SRC_PATH)/pc-bios/optionrom
-CPPFLAGS = -Wall -Wstrict-prototypes -Werror -fomit-frame-pointer -fno-builtin
-CPPFLAGS += -I$(SRC_PATH)
-CPPFLAGS += $(call cc-option, $(CFLAGS), -fno-stack-protector,"")
+CFLAGS = -Wall -Wstrict-prototypes -Werror -fomit-frame-pointer -fno-builtin
+CFLAGS += -I$(SRC_PATH)
+CFLAGS += $(call cc-option, $(CFLAGS), -fno-stack-protector,"")
build-all: multiboot.bin extboot.bin