summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2003-03-20 22:33:23 +0000
committerbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2003-03-20 22:33:23 +0000
commit04369ff2f525ea510b6ddeaa2e3ed6aedde8bbb4 (patch)
tree05bb7aeca8770e3299d0817a466bfe80b28d3927 /tests/Makefile
parentadded file (diff)
downloadqemu-kvm-04369ff2f525ea510b6ddeaa2e3ed6aedde8bbb4.tar.gz
qemu-kvm-04369ff2f525ea510b6ddeaa2e3ed6aedde8bbb4.tar.bz2
qemu-kvm-04369ff2f525ea510b6ddeaa2e3ed6aedde8bbb4.zip
ppc port
git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@36 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/tests/Makefile b/tests/Makefile
index c7d1154c0..72b559dfd 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -4,8 +4,9 @@ CFLAGS=-Wall -O2 -g
LDFLAGS=
ifeq ($(ARCH),i386)
-TESTS=hello test2 sha1 test-i386
+TESTS=test2 sha1-i386 test-i386
endif
+TESTS+=sha1
GEMU=../gemu
@@ -13,26 +14,32 @@ all: $(TESTS)
hello: hello.c
$(CC) -nostdlib $(CFLAGS) -static $(LDFLAGS) -o $@ $<
+ strip hello
test2: test2.c
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
-# i386 emulation test (dump various opcodes) */
+# i386 emulation test (test various opcodes) */
test-i386: test-i386.c test-i386.h test-i386-shift.h test-i386-muldiv.h
$(CC) $(CFLAGS) $(LDFLAGS) -static -o $@ $< -lm
test: test-i386
+ifeq ($(ARCH),i386)
./test-i386 > test-i386.ref
+endif
$(GEMU) test-i386 > test-i386.out
@if diff -u test-i386.ref test-i386.out ; then echo "Auto Test OK"; fi
# speed test
-sha1: sha1.c
+sha1-i386: sha1.c
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
-speed: sha1
+sha1: sha1.c
+ $(HOST_CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+speed: sha1 sha1-i386
time ./sha1
- time $(GEMU) sha1
+ time $(GEMU) ./sha1-i386
clean:
rm -f *~ *.o $(TESTS)