summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2005-03-02 22:19:12 +0000
committerbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2005-03-02 22:19:12 +0000
commit776f2227f6244003a5bcb20ea77c49427e6af023 (patch)
tree8949fa9ed46cd0fe2b7006f2249c50191532d400 /tests/Makefile
parentx86_64 support (diff)
downloadqemu-kvm-776f2227f6244003a5bcb20ea77c49427e6af023.tar.gz
qemu-kvm-776f2227f6244003a5bcb20ea77c49427e6af023.tar.bz2
qemu-kvm-776f2227f6244003a5bcb20ea77c49427e6af023.zip
x86_64 test program
git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@1321 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 4bd1dc6e3..de533f932 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -6,6 +6,9 @@ LDFLAGS=
ifeq ($(ARCH),i386)
TESTS=linux-test testthread sha1-i386 test-i386 runcom
endif
+ifeq ($(ARCH),x86_64)
+TESTS=test-x86_64
+endif
TESTS+=sha1# test_path
#TESTS+=test_path
@@ -24,11 +27,15 @@ test_path: test_path.c
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
./$@ || { rm $@; exit 1; }
-# i386 emulation test (test various opcodes) */
+# i386/x86_64 emulation test (test various opcodes) */
test-i386: test-i386.c test-i386-code16.S test-i386-vm86.S \
test-i386.h test-i386-shift.h test-i386-muldiv.h
- $(CC) $(CFLAGS) $(LDFLAGS) -static -o $@ test-i386.c \
- test-i386-code16.S test-i386-vm86.S -lm
+ $(CC) $(CFLAGS) $(LDFLAGS) -static -o $@ \
+ test-i386.c test-i386-code16.S test-i386-vm86.S -lm
+
+test-x86_64: test-i386.c \
+ test-i386.h test-i386-shift.h test-i386-muldiv.h
+ $(CC) $(CFLAGS) $(LDFLAGS) -static -o $@ test-i386.c -lm
ifeq ($(ARCH),i386)
test: test-i386