summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorths <ths@c046a42c-6fe2-441c-8c8c-71466251a162>2006-12-14 14:48:11 +0000
committerths <ths@c046a42c-6fe2-441c-8c8c-71466251a162>2006-12-14 14:48:11 +0000
commite4630047e161ac1b23bfd37b2c52785fce49400a (patch)
tree9a9ced3ffc77a7149a4c4565b3217609ab4b1b1f /tests/Makefile
parentReduce VNC resize traffic, thanks Eduardo Felipe. (diff)
downloadqemu-kvm-e4630047e161ac1b23bfd37b2c52785fce49400a.tar.gz
qemu-kvm-e4630047e161ac1b23bfd37b2c52785fce49400a.tar.bz2
qemu-kvm-e4630047e161ac1b23bfd37b2c52785fce49400a.zip
Simple test for mips/mipsel, based on a test by Alexander Voropay.
git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@2246 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile b/tests/Makefile
index d7abae69e..f803f6a65 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -82,6 +82,13 @@ hello-arm: hello-arm.o
hello-arm.o: hello-arm.c
arm-linux-gcc -Wall -g -O2 -c -o $@ $<
+# MIPS test
+hello-mips: hello-mips.c
+ mips-linux-gnu-gcc -nostdlib -static -mno-abicalls -fno-PIC -mabi=32 -Wall -Wextra -g -O2 -o $@ $<
+
+hello-mipsel: hello-mips.c
+ mipsel-linux-gnu-gcc -nostdlib -static -mno-abicalls -fno-PIC -mabi=32 -Wall -Wextra -g -O2 -o $@ $<
+
# XXX: find a way to compile easily a test for each arch
test2:
@for arch in i386 arm armeb sparc ppc mips mipsel; do \