aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--linux-user/syscall.c8
-rw-r--r--target-cris/cpu.h5
-rw-r--r--tests/cris/Makefile2
-rw-r--r--tests/cris/check_settls1.c39
4 files changed, 53 insertions, 1 deletions
diff --git a/linux-user/syscall.c b/linux-user/syscall.c
index 3cc14b8e3..18d008c1c 100644
--- a/linux-user/syscall.c
+++ b/linux-user/syscall.c
@@ -5912,6 +5912,14 @@ abi_long do_syscall(void *cpu_env, int num, abi_long arg1,
((CPUMIPSState *) cpu_env)->tls_value = arg1;
ret = 0;
break;
+#elif defined(TARGET_CRIS)
+ if (arg1 & 0xff)
+ ret = -TARGET_EINVAL;
+ else {
+ ((CPUCRISState *) cpu_env)->pregs[PR_PID] = arg1;
+ ret = 0;
+ }
+ break;
#elif defined(TARGET_I386) && defined(TARGET_ABI32)
ret = do_set_thread_area(cpu_env, arg1);
break;
diff --git a/target-cris/cpu.h b/target-cris/cpu.h
index 9e4faff30..dea4cc46c 100644
--- a/target-cris/cpu.h
+++ b/target-cris/cpu.h
@@ -225,6 +225,11 @@ static inline void cpu_clone_regs(CPUState *env, target_ulong newsp)
}
#endif
+static inline void cpu_set_tls(CPUCRISState *env, target_ulong newtls)
+{
+ env->pregs[PR_PID] = (env->pregs[PR_PID] & 0xff) | newtls;
+}
+
/* Support function regs. */
#define SFR_RW_GC_CFG 0][0
#define SFR_RW_MM_CFG env->pregs[PR_SRS]][0
diff --git a/tests/cris/Makefile b/tests/cris/Makefile
index cfe494c3a..b86bcadcc 100644
--- a/tests/cris/Makefile
+++ b/tests/cris/Makefile
@@ -117,7 +117,7 @@ TESTCASES += check_mmap3.ctst
TESTCASES += check_sigalrm.ctst
TESTCASES += check_time1.ctst
TESTCASES += check_time2.ctst
-
+TESTCASES += check_settls1.ctst
TESTCASES += check_gcctorture_pr28634-1.ctst
#TESTCASES += check_gcctorture_pr28634.ctst
diff --git a/tests/cris/check_settls1.c b/tests/cris/check_settls1.c
new file mode 100644
index 000000000..0ed99cf4c
--- /dev/null
+++ b/tests/cris/check_settls1.c
@@ -0,0 +1,39 @@
+#include <stdio.h>
+#include <stdlib.h>
+#include <errno.h>
+#include <unistd.h>
+
+#include <sys/syscall.h>
+
+#ifndef SYS_set_thread_area
+#define SYS_set_thread_area 243
+#endif
+
+int main (void)
+{
+ unsigned long tp;
+ int ret;
+
+ ret = syscall (SYS_set_thread_area, 0xf0);
+ if (ret != -1 || errno != EINVAL) {
+ perror ("Invalid thread area accepted:");
+ abort();
+ }
+
+ ret = syscall (SYS_set_thread_area, 0xeddeed00);
+ if (ret != 0) {
+ perror ("Valid thread area not accepted: ");
+ abort ();
+ }
+
+ asm ("move $pid,%0" : "=r" (tp));
+ tp &= ~0xff;
+
+ if (tp != 0xeddeed00) {
+ perror ("tls2");
+ abort ();
+ }
+
+ printf ("pass\n");
+ return EXIT_SUCCESS;
+}