aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-04-15 06:43:43 +0200
committerDavide Pesavento <pesa@gentoo.org>2017-04-15 06:43:43 +0200
commit10a25f1ef22400eb82a6514a3c23e8a472c90b45 (patch)
tree2fffcd0b5b71818c624b1fe06410f65f9ad0762c
parentdev-qt/qtquickcontrols2: sync keywords with main tree (diff)
parentdev-qt/qtwidgets: Stop passing -xrender to configure on {5,5.8}.9999 (diff)
downloadqt-10a25f1ef22400eb82a6514a3c23e8a472c90b45.tar.gz
qt-10a25f1ef22400eb82a6514a3c23e8a472c90b45.tar.bz2
qt-10a25f1ef22400eb82a6514a3c23e8a472c90b45.zip
Merge pull request #141 from Chiitoo
-rw-r--r--dev-qt/qtgui/qtgui-5.8.9999.ebuild6
-rw-r--r--dev-qt/qtgui/qtgui-5.9999.ebuild6
-rw-r--r--dev-qt/qtwidgets/qtwidgets-5.8.9999.ebuild4
-rw-r--r--dev-qt/qtwidgets/qtwidgets-5.9999.ebuild4
-rw-r--r--eclass/qt5-build.eclass4
5 files changed, 11 insertions, 13 deletions
diff --git a/dev-qt/qtgui/qtgui-5.8.9999.ebuild b/dev-qt/qtgui/qtgui-5.8.9999.ebuild
index 93dcfd12..b328d687 100644
--- a/dev-qt/qtgui/qtgui-5.8.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.8.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -55,7 +55,6 @@ RDEPEND="
x11-libs/libSM
x11-libs/libX11
>=x11-libs/libXi-1.7.4
- x11-libs/libXrender
>=x11-libs/libxcb-1.10:=[xkb]
>=x11-libs/libxkbcommon-0.4.1[X]
x11-libs/xcb-util-image
@@ -118,7 +117,6 @@ QT5_GENTOO_CONFIG=(
xcb:xcb-xlib:
xcb:xinput2:
xcb::XKB
- xcb:xrender
)
src_prepare() {
@@ -160,7 +158,7 @@ src_configure() {
$(qt_use udev libudev)
$(qt_use xcb xcb system)
$(qt_use xcb xkbcommon-x11 system)
- $(usex xcb '-xcb-xlib -xinput2 -xkb -xrender' '')
+ $(usex xcb '-xcb-xlib -xinput2 -xkb' '')
)
qt5-build_src_configure
}
diff --git a/dev-qt/qtgui/qtgui-5.9999.ebuild b/dev-qt/qtgui/qtgui-5.9999.ebuild
index 93dcfd12..b328d687 100644
--- a/dev-qt/qtgui/qtgui-5.9999.ebuild
+++ b/dev-qt/qtgui/qtgui-5.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -55,7 +55,6 @@ RDEPEND="
x11-libs/libSM
x11-libs/libX11
>=x11-libs/libXi-1.7.4
- x11-libs/libXrender
>=x11-libs/libxcb-1.10:=[xkb]
>=x11-libs/libxkbcommon-0.4.1[X]
x11-libs/xcb-util-image
@@ -118,7 +117,6 @@ QT5_GENTOO_CONFIG=(
xcb:xcb-xlib:
xcb:xinput2:
xcb::XKB
- xcb:xrender
)
src_prepare() {
@@ -160,7 +158,7 @@ src_configure() {
$(qt_use udev libudev)
$(qt_use xcb xcb system)
$(qt_use xcb xkbcommon-x11 system)
- $(usex xcb '-xcb-xlib -xinput2 -xkb -xrender' '')
+ $(usex xcb '-xcb-xlib -xinput2 -xkb' '')
)
qt5-build_src_configure
}
diff --git a/dev-qt/qtwidgets/qtwidgets-5.8.9999.ebuild b/dev-qt/qtwidgets/qtwidgets-5.8.9999.ebuild
index d17ef19c..ed7f16fb 100644
--- a/dev-qt/qtwidgets/qtwidgets-5.8.9999.ebuild
+++ b/dev-qt/qtwidgets/qtwidgets-5.8.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -43,7 +43,7 @@ src_configure() {
$(qt_use png libpng system)
$(qt_use xcb xcb system)
$(qt_use xcb xkbcommon system)
- $(usex xcb '-xcb-xlib -xinput2 -xkb -xrender' '')
+ $(usex xcb '-xcb-xlib -xinput2 -xkb' '')
)
qt5-build_src_configure
}
diff --git a/dev-qt/qtwidgets/qtwidgets-5.9999.ebuild b/dev-qt/qtwidgets/qtwidgets-5.9999.ebuild
index d17ef19c..ed7f16fb 100644
--- a/dev-qt/qtwidgets/qtwidgets-5.9999.ebuild
+++ b/dev-qt/qtwidgets/qtwidgets-5.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -43,7 +43,7 @@ src_configure() {
$(qt_use png libpng system)
$(qt_use xcb xcb system)
$(qt_use xcb xkbcommon system)
- $(usex xcb '-xcb-xlib -xinput2 -xkb -xrender' '')
+ $(usex xcb '-xcb-xlib -xinput2 -xkb' '')
)
qt5-build_src_configure
}
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index eea388d8..d679da40 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -654,7 +654,9 @@ qt5_base_configure() {
# disable undocumented X11-related flags, override in qtgui
# (not shown in ./configure -help output)
- -no-xkb -no-xrender
+ -no-xkb
+ $([[ ${QT5_MINOR_VERSION} -lt 8 || ${QT5_MINOR_VERSION} -eq 8
+ && ${QT5_PATCH_VERSION} -lt 1 ]] && echo -no-xrender)
# disable obsolete/unused X11-related flags
$([[ ${QT5_MINOR_VERSION} -lt 8 ]] && echo -no-mitshm -no-xcursor -no-xfixes -no-xrandr -no-xshape -no-xsync)