aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-06 13:18:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-06 20:49:19 +0100
commit4a3db05986f174c62de05719a87b1b47fd9220e7 (patch)
treee774be67bfd14bc7adbea628d407e0f2d0e002d6
parentqt5-build.eclass: Cleanup obsolete -gt/-ge conditionals (diff)
downloadqt-4a3db05986f174c62de05719a87b1b47fd9220e7.tar.gz
qt-4a3db05986f174c62de05719a87b1b47fd9220e7.tar.bz2
qt-4a3db05986f174c62de05719a87b1b47fd9220e7.zip
dev-qt: Drop 5.9 stable branch
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/assistant/assistant-5.9.9999.ebuild55
-rw-r--r--dev-qt/designer/designer-5.9.9999.ebuild57
-rw-r--r--dev-qt/linguist-tools/linguist-tools-5.9.9999.ebuild35
-rw-r--r--dev-qt/linguist/linguist-5.9.9999.ebuild48
-rw-r--r--dev-qt/pixeltool/pixeltool-5.9.9999.ebuild25
-rw-r--r--dev-qt/qdbus/qdbus-5.9.9999.ebuild25
-rw-r--r--dev-qt/qdbusviewer/qdbusviewer-5.9.9999.ebuild45
-rw-r--r--dev-qt/qdoc/qdoc-5.9.9999.ebuild31
-rw-r--r--dev-qt/qt3d/qt3d-5.9.9999.ebuild32
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild33
-rw-r--r--dev-qt/qtcanvas3d/qtcanvas3d-5.9.9999.ebuild21
-rw-r--r--dev-qt/qtcharts/qtcharts-5.9.9999.ebuild29
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.9.9999.ebuild23
-rw-r--r--dev-qt/qtcore/qtcore-5.9.9999.ebuild75
-rw-r--r--dev-qt/qtdatavis3d/qtdatavis3d-5.9.9999.ebuild31
-rw-r--r--dev-qt/qtdbus/qtdbus-5.9.9999.ebuild43
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild56
-rw-r--r--dev-qt/qtdiag/qtdiag-5.9.9999.ebuild36
-rw-r--r--dev-qt/qtgamepad/qtgamepad-5.9.9999.ebuild35
-rw-r--r--dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.9.9999.ebuild21
-rw-r--r--dev-qt/qtgui/files/qtgui-5.9.4-opengl.patch87
-rw-r--r--dev-qt/qtgui/qtgui-5.9.9999.ebuild169
-rw-r--r--dev-qt/qthelp/qthelp-5.9.9999.ebuild30
-rw-r--r--dev-qt/qtimageformats/qtimageformats-5.9.9999.ebuild29
-rw-r--r--dev-qt/qtlocation/qtlocation-5.9.9999.ebuild44
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-5.9.9999.ebuild68
-rw-r--r--dev-qt/qtnetwork/qtnetwork-5.9.9999.ebuild60
-rw-r--r--dev-qt/qtnetworkauth/qtnetworkauth-5.9.9999.ebuild20
-rw-r--r--dev-qt/qtopengl/qtopengl-5.9.9999.ebuild34
-rw-r--r--dev-qt/qtpaths/qtpaths-5.9.9999.ebuild23
-rw-r--r--dev-qt/qtplugininfo/qtplugininfo-5.9.9999.ebuild23
-rw-r--r--dev-qt/qtpositioning/qtpositioning-5.9.9999.ebuild37
-rw-r--r--dev-qt/qtprintsupport/qtprintsupport-5.9.9999.ebuild42
-rw-r--r--dev-qt/qtquickcontrols/qtquickcontrols-5.9.9999.ebuild32
-rw-r--r--dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.9999.ebuild30
-rw-r--r--dev-qt/qtscript/qtscript-5.9.9999.ebuild36
-rw-r--r--dev-qt/qtscxml/qtscxml-5.9.9999.ebuild19
-rw-r--r--dev-qt/qtsensors/qtsensors-5.9.9999.ebuild28
-rw-r--r--dev-qt/qtserialbus/qtserialbus-5.9.9999.ebuild20
-rw-r--r--dev-qt/qtserialport/qtserialport-5.9.9999.ebuild27
-rw-r--r--dev-qt/qtspeech/files/qtspeech-5.9.4-nogui.patch12
-rw-r--r--dev-qt/qtspeech/qtspeech-5.9.9999.ebuild22
-rw-r--r--dev-qt/qtsql/files/qtsql-5.9.5-mariadb-10.2.patch35
-rw-r--r--dev-qt/qtsql/qtsql-5.9.9999.ebuild63
-rw-r--r--dev-qt/qtsvg/qtsvg-5.9.9999.ebuild23
-rw-r--r--dev-qt/qttest/qttest-5.9.9999.ebuild33
-rw-r--r--dev-qt/qttranslations/qttranslations-5.9.9999.ebuild19
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.9.9999.ebuild38
-rw-r--r--dev-qt/qtwayland/qtwayland-5.9.9999.ebuild39
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-5.9.9999.ebuild26
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch41
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-1.patch70
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-2.patch46
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild128
-rw-r--r--dev-qt/qtwebsockets/qtwebsockets-5.9.9999.ebuild27
-rw-r--r--dev-qt/qtwebview/qtwebview-5.9.9999.ebuild21
-rw-r--r--dev-qt/qtwidgets/qtwidgets-5.9.9999.ebuild57
-rw-r--r--dev-qt/qtx11extras/qtx11extras-5.9.9999.ebuild21
-rw-r--r--dev-qt/qtxml/qtxml-5.9.9999.ebuild29
-rw-r--r--dev-qt/qtxmlpatterns/qtxmlpatterns-5.9.9999.ebuild19
60 files changed, 0 insertions, 2383 deletions
diff --git a/dev-qt/assistant/assistant-5.9.9999.ebuild b/dev-qt/assistant/assistant-5.9.9999.ebuild
deleted file mode 100644
index 0fe2bc14..00000000
--- a/dev-qt/assistant/assistant-5.9.9999.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit desktop gnome2-utils qt5-build
-
-DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-fi
-
-IUSE="webkit"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qthelp-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtprintsupport-${PV}
- ~dev-qt/qtsql-${PV}[sqlite]
- ~dev-qt/qtwidgets-${PV}
- webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/assistant/assistant
-)
-
-src_prepare() {
- qt_use_disable_mod webkit webkitwidgets \
- src/assistant/assistant/assistant.pro
-
- qt5-build_src_prepare
-}
-
-src_install() {
- qt5-build_src_install
-
- doicon -s 32 src/assistant/assistant/images/assistant.png
- newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
- make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
-}
-
-pkg_postinst() {
- qt5-build_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- qt5-build_pkg_postrm
- gnome2_icon_cache_update
-}
diff --git a/dev-qt/designer/designer-5.9.9999.ebuild b/dev-qt/designer/designer-5.9.9999.ebuild
deleted file mode 100644
index c561782d..00000000
--- a/dev-qt/designer/designer-5.9.9999.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit desktop gnome2-utils qt5-build
-
-DESCRIPTION="WYSIWYG tool for designing and building Qt-based GUIs"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="declarative webkit"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtprintsupport-${PV}
- ~dev-qt/qtwidgets-${PV}
- ~dev-qt/qtxml-${PV}
- declarative? ( ~dev-qt/qtdeclarative-${PV}[widgets] )
- webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/designer
-)
-
-src_prepare() {
- qt_use_disable_mod declarative quickwidgets \
- src/designer/src/plugins/plugins.pro
-
- qt_use_disable_mod webkit webkitwidgets \
- src/designer/src/plugins/plugins.pro
-
- qt5-build_src_prepare
-}
-
-src_install() {
- qt5-build_src_install
-
- doicon -s 128 src/designer/src/designer/images/designer.png
- make_desktop_entry "${QT5_BINDIR}"/designer 'Qt 5 Designer' designer 'Qt;Development;GUIDesigner'
-}
-
-pkg_postinst() {
- qt5-build_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- qt5-build_pkg_postrm
- gnome2_icon_cache_update
-}
diff --git a/dev-qt/linguist-tools/linguist-tools-5.9.9999.ebuild b/dev-qt/linguist-tools/linguist-tools-5.9.9999.ebuild
deleted file mode 100644
index 72c04bdc..00000000
--- a/dev-qt/linguist-tools/linguist-tools-5.9.9999.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Tools for working with Qt translation data files"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="qml"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtxml-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/linguist
-)
-
-src_prepare() {
- sed -i -e '/SUBDIRS += linguist/d' \
- src/linguist/linguist.pro || die
-
- qt_use_disable_mod qml qmldevtools-private \
- src/linguist/lupdate/lupdate.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/linguist/linguist-5.9.9999.ebuild b/dev-qt/linguist/linguist-5.9.9999.ebuild
deleted file mode 100644
index 38f06fe3..00000000
--- a/dev-qt/linguist/linguist-5.9.9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit desktop gnome2-utils qt5-build
-
-DESCRIPTION="Graphical tool for translating Qt applications"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/designer-${PV}
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtprintsupport-${PV}
- ~dev-qt/qtwidgets-${PV}
- ~dev-qt/qtxml-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/linguist/linguist
-)
-
-src_install() {
- qt5-build_src_install
-
- local size
- for size in 16 32 48 64 128; do
- newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
- done
- make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
-}
-
-pkg_postinst() {
- qt5-build_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- qt5-build_pkg_postrm
- gnome2_icon_cache_update
-}
diff --git a/dev-qt/pixeltool/pixeltool-5.9.9999.ebuild b/dev-qt/pixeltool/pixeltool-5.9.9999.ebuild
deleted file mode 100644
index 7bcdc97e..00000000
--- a/dev-qt/pixeltool/pixeltool-5.9.9999.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Qt screen magnifier"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwidgets-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/pixeltool
-)
diff --git a/dev-qt/qdbus/qdbus-5.9.9999.ebuild b/dev-qt/qdbus/qdbus-5.9.9999.ebuild
deleted file mode 100644
index 4736c7cd..00000000
--- a/dev-qt/qdbus/qdbus-5.9.9999.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Interface to Qt applications communicating over D-Bus"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdbus-${PV}
- ~dev-qt/qtxml-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/qdbus/qdbus
-)
diff --git a/dev-qt/qdbusviewer/qdbusviewer-5.9.9999.ebuild b/dev-qt/qdbusviewer/qdbusviewer-5.9.9999.ebuild
deleted file mode 100644
index ceb1e6f9..00000000
--- a/dev-qt/qdbusviewer/qdbusviewer-5.9.9999.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit desktop gnome2-utils qt5-build
-
-DESCRIPTION="Graphical tool that lets you introspect D-Bus objects and messages"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdbus-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwidgets-${PV}
- ~dev-qt/qtxml-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/qdbus/qdbusviewer
-)
-
-src_install() {
- qt5-build_src_install
-
- doicon -s 32 src/qdbus/qdbusviewer/images/qdbusviewer.png
- newicon -s 128 src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer.png
- make_desktop_entry "${QT5_BINDIR}"/qdbusviewer 'Qt 5 QDBusViewer' qdbusviewer 'Qt;Development'
-}
-
-pkg_postinst() {
- qt5-build_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- qt5-build_pkg_postrm
- gnome2_icon_cache_update
-}
diff --git a/dev-qt/qdoc/qdoc-5.9.9999.ebuild b/dev-qt/qdoc/qdoc-5.9.9999.ebuild
deleted file mode 100644
index 983d3432..00000000
--- a/dev-qt/qdoc/qdoc-5.9.9999.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Qt documentation generator"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE="qml"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/qdoc
-)
-
-src_prepare() {
- qt_use_disable_mod qml qmldevtools-private \
- src/qdoc/qdoc.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qt3d/qt3d-5.9.9999.ebuild b/dev-qt/qt3d/qt3d-5.9.9999.ebuild
deleted file mode 100644
index e6563090..00000000
--- a/dev-qt/qt3d/qt3d-5.9.9999.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="The 3D module for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-# TODO: gamepad, tools
-IUSE="gles2 qml"
-
-DEPEND="
- ~dev-qt/qtconcurrent-${PV}
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtnetwork-${PV}
- >=media-libs/assimp-4.0.0
- qml? ( ~dev-qt/qtdeclarative-${PV}[gles2=] )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- rm -r src/3rdparty/assimp/{code,contrib,include} || die
-
- qt_use_disable_mod qml quick src/src.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild
deleted file mode 100644
index 7f4a8b1b..00000000
--- a/dev-qt/qtbluetooth/qtbluetooth-5.9.9999.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtconnectivity"
-inherit qt5-build
-
-DESCRIPTION="Bluetooth support library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-IUSE="qml"
-
-RDEPEND="
- ~dev-qt/qtconcurrent-${PV}
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdbus-${PV}
- >=net-wireless/bluez-5:=
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-DEPEND="${RDEPEND}
- ~dev-qt/qtnetwork-${PV}
-"
-
-src_prepare() {
- sed -i -e 's/nfc//' src/src.pro || die
-
- qt_use_disable_mod qml quick src/src.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtcanvas3d/qtcanvas3d-5.9.9999.ebuild b/dev-qt/qtcanvas3d/qtcanvas3d-5.9.9999.ebuild
deleted file mode 100644
index ab9ec684..00000000
--- a/dev-qt/qtcanvas3d/qtcanvas3d-5.9.9999.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Qt module to make WebGL-like 3D drawing calls from Qt Quick JavaScript"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtnetwork-${PV}
-"
-RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtcharts/qtcharts-5.9.9999.ebuild b/dev-qt/qtcharts/qtcharts-5.9.9999.ebuild
deleted file mode 100644
index ff3df69c..00000000
--- a/dev-qt/qtcharts/qtcharts-5.9.9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Chart component library for the Qt5 framework"
-LICENSE="GPL-3"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-IUSE="qml"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwidgets-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- qt_use_disable_mod qml quick \
- src/src.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.9.9999.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.9.9999.ebuild
deleted file mode 100644
index 75e304af..00000000
--- a/dev-qt/qtconcurrent/qtconcurrent-5.9.9999.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/concurrent
-)
diff --git a/dev-qt/qtcore/qtcore-5.9.9999.ebuild b/dev-qt/qtcore/qtcore-5.9.9999.ebuild
deleted file mode 100644
index 25c17255..00000000
--- a/dev-qt/qtcore/qtcore-5.9.9999.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Cross-platform application development framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="icu systemd"
-
-DEPEND="
- dev-libs/double-conversion:=
- dev-libs/glib:2
- dev-libs/libpcre2[pcre16,unicode]
- sys-libs/zlib
- icu? ( dev-libs/icu:= )
- !icu? ( virtual/libiconv )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}
- !<dev-qt/qtcore-4.8.7-r4:4
-"
-
-QT5_TARGET_SUBDIRS=(
- src/tools/bootstrap
- src/tools/moc
- src/tools/rcc
- src/tools/qfloat16-tables
- src/corelib
- src/tools/qlalr
- doc
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- !:network
- !:sql
- !:testlib
- !:xml
-)
-
-src_configure() {
- local myconf=(
- $(qt_use icu)
- $(qt_use !icu iconv)
- $(qt_use systemd journald)
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
-
- local flags=(
- ALSA CUPS DBUS EGL EGLFS EGL_X11 EVDEV FONTCONFIG FREETYPE
- HARFBUZZ IMAGEFORMAT_JPEG IMAGEFORMAT_PNG LIBPROXY MITSHM
- OPENGL OPENSSL OPENVG PULSEAUDIO SHAPE SSL TSLIB WIDGETS
- XCURSOR XFIXES XKB XRANDR XSYNC ZLIB
- )
-
- for flag in ${flags[@]}; do
- cat >> "${D%/}"/${QT5_HEADERDIR}/QtCore/qconfig.h <<- _EOF_ || die
-
- #if defined(QT_NO_${flag}) && defined(QT_${flag})
- # undef QT_NO_${flag}
- #elif !defined(QT_NO_${flag}) && !defined(QT_${flag})
- # define QT_NO_${flag}
- #endif
- _EOF_
- done
-}
diff --git a/dev-qt/qtdatavis3d/qtdatavis3d-5.9.9999.ebuild b/dev-qt/qtdatavis3d/qtdatavis3d-5.9.9999.ebuild
deleted file mode 100644
index 64777049..00000000
--- a/dev-qt/qtdatavis3d/qtdatavis3d-5.9.9999.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="3D data visualization library for the Qt5 framework"
-LICENSE="GPL-3"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-IUSE="gles2 qml"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=]
- qml? ( ~dev-qt/qtdeclarative-${PV}[gles2=] )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # eliminate bogus dependency on qtwidgets
- sed -i -e '/requires.*widgets/d' qtdatavis3d.pro || die
-
- qt_use_disable_mod qml quick \
- src/src.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtdbus/qtdbus-5.9.9999.ebuild b/dev-qt/qtdbus/qtdbus-5.9.9999.ebuild
deleted file mode 100644
index b31a0a2f..00000000
--- a/dev-qt/qtdbus/qtdbus-5.9.9999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Qt5 module for inter-process communication over the D-Bus protocol"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- >=sys-apps/dbus-1.4.20
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/dbus
- src/tools/qdbusxml2cpp
- src/tools/qdbuscpp2xml
-)
-
-QT5_GENTOO_CONFIG=(
- :dbus
- :dbus-linked:
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :dbus
- :dbus-linked
-)
-
-src_configure() {
- local myconf=(
- -dbus-linked
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild
deleted file mode 100644
index d78cf07d..00000000
--- a/dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="The QML and Quick modules for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="gles2 +jit localstorage +widgets xml"
-
-# qtgui[gles2=] is needed because of bug 504322
-COMMON_DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=]
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qttest-${PV}
- localstorage? ( ~dev-qt/qtsql-${PV} )
- widgets? ( ~dev-qt/qtwidgets-${PV}[gles2=] )
- xml? (
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtxmlpatterns-${PV}
- )
-"
-DEPEND="${COMMON_DEPEND}
- ${PYTHON_DEPS}
-"
-RDEPEND="${COMMON_DEPEND}
- !<dev-qt/qtquickcontrols-5.7:5
-"
-
-src_prepare() {
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
-
- qt_use_disable_mod localstorage sql \
- src/imports/imports.pro
-
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/qmltest/qmltest.pro \
- tests/auto/auto.pro \
- tools/tools.pro \
- tools/qmlscene/qmlscene.pro \
- tools/qml/qml.pro
-
- qt_use_disable_mod xml xmlpatterns \
- src/imports/imports.pro \
- tests/auto/quick/quick.pro \
- tests/auto/quick/examples/examples.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtdiag/qtdiag-5.9.9999.ebuild b/dev-qt/qtdiag/qtdiag-5.9.9999.ebuild
deleted file mode 100644
index 85c0174e..00000000
--- a/dev-qt/qtdiag/qtdiag-5.9.9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Tool for reporting diagnostic information about Qt and its environment"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-fi
-
-IUSE="+network +widgets"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- network? ( ~dev-qt/qtnetwork-${PV}[ssl] )
- widgets? ( ~dev-qt/qtwidgets-${PV} )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/qtdiag
-)
-
-src_prepare() {
- qt_use_disable_mod network network \
- src/qtdiag/qtdiag.pro
-
- qt_use_disable_mod widgets widgets \
- src/qtdiag/qtdiag.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtgamepad/qtgamepad-5.9.9999.ebuild b/dev-qt/qtgamepad/qtgamepad-5.9.9999.ebuild
deleted file mode 100644
index a7c4b576..00000000
--- a/dev-qt/qtgamepad/qtgamepad-5.9.9999.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Qt module to support gamepad hardware"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-IUSE="evdev qml sdl"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[evdev?]
- evdev? ( virtual/libudev:= )
- sdl? ( media-libs/libsdl )
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- qt_use_disable_mod qml quick \
- src/src.pro
-
- qt_use_disable_config evdev evdev \
- src/plugins/gamepads/gamepads.pro
-
- qt_use_disable_config sdl sdl2 \
- src/plugins/gamepads/gamepads.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.9.9999.ebuild b/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.9.9999.ebuild
deleted file mode 100644
index 51a225a5..00000000
--- a/dev-qt/qtgraphicaleffects/qtgraphicaleffects-5.9.9999.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-VIRTUALX_REQUIRED="test"
-inherit qt5-build
-
-DESCRIPTION="Set of QML types for adding visual effects to user interfaces"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE=""
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-qt/qtgui/files/qtgui-5.9.4-opengl.patch b/dev-qt/qtgui/files/qtgui-5.9.4-opengl.patch
deleted file mode 100644
index 2a447414..00000000
--- a/dev-qt/qtgui/files/qtgui-5.9.4-opengl.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From b63aeba4a88088c7de61c1664a510c02d38ade84 Mon Sep 17 00:00:00 2001
-From: Antonio Larrosa <alarrosa@suse.com>
-Date: Fri, 16 Feb 2018 13:18:42 +0100
-Subject: [PATCH] opengl: Bail if cached shader fails to load
-
-QOpenGLProgramBinaryCache::setProgramBinary() should check
-GL_LINK_STATUS after glProgramBinary(), but doesn't.
-
-In practice, this means that SDDM is a white screen, and KDE is just
-a gray task bar.
-
-So far, Qt tries to check this using its internal ::link() function.
-But in case the cached binary fails to load, Qt currently attempts to
-link the inexistent program, resulting in a zero-length, fixed
-pipeline shader.
-
-Checking this already in ::setProgramBinary() makes the call to
-::link() superfluous, so we remove that as well.
-
-Done-with: Max Staudt <mstaudt@suse.com>
-Done-with: Michal Srb <msrb@suse.com>
-Done-with: Fabian Vogt <fvogt@suse.de>
-Task-number: QTBUG-66420
-Change-Id: Iabb51d0eb2c0c16bde696efff623e57d15f28d82
-Reviewed-by: Jesus Fernandez <Jesus.Fernandez@qt.io>
-Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
-(cherry picked from commit fa091640134b3ff99a9eb92df8286d15203122bf)
----
- src/gui/opengl/qopenglprogrambinarycache.cpp | 20 ++++++++++++++++++--
- src/gui/opengl/qopenglshaderprogram.cpp | 8 +-------
- 2 files changed, 19 insertions(+), 9 deletions(-)
-
-diff --git a/src/gui/opengl/qopenglprogrambinarycache.cpp b/src/gui/opengl/qopenglprogrambinarycache.cpp
-index 06373e1..d16173d 100644
---- a/src/gui/opengl/qopenglprogrambinarycache.cpp
-+++ b/src/gui/opengl/qopenglprogrambinarycache.cpp
-@@ -161,10 +161,26 @@ bool QOpenGLProgramBinaryCache::setProgramBinary(uint programId, uint blobFormat
- QOpenGLExtraFunctions *funcs = QOpenGLContext::currentContext()->extraFunctions();
- while (funcs->glGetError() != GL_NO_ERROR) { }
- funcs->glProgramBinary(programId, blobFormat, p, blobSize);
-- int err = funcs->glGetError();
-+
-+ GLenum err = funcs->glGetError();
-+ if (err != GL_NO_ERROR) {
-+ qCDebug(DBG_SHADER_CACHE, "Program binary failed to load for program %u, size %d, "
-+ "format 0x%x, err = 0x%x",
-+ programId, blobSize, blobFormat, err);
-+ return false;
-+ }
-+ GLint linkStatus = 0;
-+ funcs->glGetProgramiv(programId, GL_LINK_STATUS, &linkStatus);
-+ if (linkStatus != GL_TRUE) {
-+ qCDebug(DBG_SHADER_CACHE, "Program binary failed to load for program %u, size %d, "
-+ "format 0x%x, linkStatus = 0x%x, err = 0x%x",
-+ programId, blobSize, blobFormat, linkStatus, err);
-+ return false;
-+ }
-+
- qCDebug(DBG_SHADER_CACHE, "Program binary set for program %u, size %d, format 0x%x, err = 0x%x",
- programId, blobSize, blobFormat, err);
-- return err == 0;
-+ return true;
- }
-
- #ifdef Q_OS_UNIX
-diff --git a/src/gui/opengl/qopenglshaderprogram.cpp b/src/gui/opengl/qopenglshaderprogram.cpp
-index cc8af16..3b82bac 100644
---- a/src/gui/opengl/qopenglshaderprogram.cpp
-+++ b/src/gui/opengl/qopenglshaderprogram.cpp
-@@ -3824,13 +3824,7 @@ bool QOpenGLShaderProgramPrivate::linkBinary()
- bool needsCompile = true;
- if (binCache.load(cacheKey, q->programId())) {
- qCDebug(DBG_SHADER_CACHE, "Program binary received from cache");
-- linkBinaryRecursion = true;
-- bool ok = q->link();
-- linkBinaryRecursion = false;
-- if (ok)
-- needsCompile = false;
-- else
-- qCDebug(DBG_SHADER_CACHE, "Link failed after glProgramBinary");
-+ needsCompile = false;
- }
-
- bool needsSave = false;
---
-2.7.4
-
diff --git a/dev-qt/qtgui/qtgui-5.9.9999.ebuild b/dev-qt/qtgui/qtgui-5.9.9999.ebuild
deleted file mode 100644
index 3ea43589..00000000
--- a/dev-qt/qtgui/qtgui-5.9.9999.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="The GUI module and platform plugins for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-# TODO: linuxfb
-
-IUSE="accessibility dbus egl eglfs evdev +gif gles2 ibus
- jpeg +libinput +png tslib tuio +udev vnc +xcb"
-REQUIRED_USE="
- || ( eglfs xcb )
- accessibility? ( dbus xcb )
- eglfs? ( egl )
- ibus? ( dbus )
- libinput? ( udev )
- xcb? ( gles2? ( egl ) )
-"
-
-RDEPEND="
- dev-libs/glib:2
- ~dev-qt/qtcore-${PV}
- media-libs/fontconfig
- >=media-libs/freetype-2.6.1:2
- >=media-libs/harfbuzz-1.0.6:=
- >=sys-libs/zlib-1.2.5
- virtual/opengl
- dbus? ( ~dev-qt/qtdbus-${PV} )
- egl? ( media-libs/mesa[egl] )
- eglfs? (
- media-libs/mesa[gbm]
- x11-libs/libdrm
- )
- evdev? ( sys-libs/mtdev )
- gles2? ( media-libs/mesa[gles2] )
- jpeg? ( virtual/jpeg:0 )
- libinput? (
- dev-libs/libinput:=
- x11-libs/libxkbcommon
- )
- png? ( media-libs/libpng:0= )
- tslib? ( x11-libs/tslib )
- tuio? ( ~dev-qt/qtnetwork-${PV} )
- udev? ( virtual/libudev:= )
- vnc? ( ~dev-qt/qtnetwork-${PV} )
- xcb? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- >=x11-libs/libXi-1.7.5
- >=x11-libs/libxcb-1.10:=[xkb]
- >=x11-libs/libxkbcommon-0.4.1[X]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
-"
-DEPEND="${RDEPEND}
- evdev? ( sys-kernel/linux-headers )
- udev? ( sys-kernel/linux-headers )
-"
-PDEPEND="
- ibus? ( app-i18n/ibus )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/gui
- src/openglextensions
- src/platformheaders
- src/platformsupport
- src/plugins/generic
- src/plugins/imageformats
- src/plugins/platforms
- src/plugins/platforminputcontexts
-)
-
-QT5_GENTOO_CONFIG=(
- accessibility:accessibility-atspi-bridge
- egl
- eglfs
- eglfs:eglfs_egldevice:
- eglfs:eglfs_gbm:
- evdev
- evdev:mtdev:
- :fontconfig
- :system-freetype:FREETYPE
- !:no-freetype:
- !gif:no-gif:
- gles2::OPENGL_ES
- gles2:opengles2:OPENGL_ES_2
- !:no-gui:
- :system-harfbuzz:HARFBUZZ
- !:no-harfbuzz:
- jpeg:system-jpeg:IMAGEFORMAT_JPEG
- !jpeg:no-jpeg:
- libinput
- libinput:xkbcommon-evdev:
- :opengl
- png:png:
- png:system-png:IMAGEFORMAT_PNG
- !png:no-png:
- tslib
- udev:libudev:
- xcb:xcb:
- xcb:xcb-glx:
- xcb:xcb-plugin:
- xcb:xcb-render:
- xcb:xcb-sm:
- xcb:xcb-xlib:
- xcb:xinput2:
- xcb::XKB
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :gui
-)
-
-src_prepare() {
- # egl_x11 is activated when both egl and xcb are enabled
- use egl && QT5_GENTOO_CONFIG+=(xcb:egl_x11) || QT5_GENTOO_CONFIG+=(egl:egl_x11)
-
- qt_use_disable_config dbus dbus \
- src/platformsupport/themes/genericunix/genericunix.pri
-
- qt_use_disable_config tuio udpsocket src/plugins/generic/generic.pro
-
- qt_use_disable_mod ibus dbus \
- src/plugins/platforminputcontexts/platforminputcontexts.pro
-
- use vnc || sed -i -e '/SUBDIRS += vnc/d' \
- src/plugins/platforms/platforms.pro || die
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myconf=(
- $(usex dbus -dbus-linked '')
- $(qt_use egl)
- $(qt_use eglfs)
- $(usex eglfs '-gbm -kms' '')
- $(qt_use evdev)
- $(qt_use evdev mtdev)
- -fontconfig
- -system-freetype
- $(usex gif '' -no-gif)
- -gui
- -system-harfbuzz
- $(qt_use jpeg libjpeg system)
- $(qt_use libinput)
- $(qt_use libinput xkbcommon-evdev)
- -opengl $(usex gles2 es2 desktop)
- $(qt_use png libpng system)
- $(qt_use tslib)
- $(qt_use udev libudev)
- $(qt_use xcb xcb system)
- $(qt_use xcb xkbcommon-x11 system)
- $(usex xcb '-xcb-xlib -xinput2 -xkb' '')
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qthelp/qthelp-5.9.9999.ebuild b/dev-qt/qthelp/qthelp-5.9.9999.ebuild
deleted file mode 100644
index 1e0ee9ab..00000000
--- a/dev-qt/qthelp/qthelp-5.9.9999.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Qt5 module for integrating online documentation into applications"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtsql-${PV}[sqlite]
- ~dev-qt/qtwidgets-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/assistant/help
- src/assistant/qcollectiongenerator
- src/assistant/qhelpconverter
- src/assistant/qhelpgenerator
-)
diff --git a/dev-qt/qtimageformats/qtimageformats-5.9.9999.ebuild b/dev-qt/qtimageformats/qtimageformats-5.9.9999.ebuild
deleted file mode 100644
index 5b10805b..00000000
--- a/dev-qt/qtimageformats/qtimageformats-5.9.9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Additional format plugins for the Qt image I/O system"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-fi
-
-IUSE="jpeg2k mng"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- media-libs/libwebp:=
- media-libs/tiff:0
- jpeg2k? ( media-libs/jasper:= )
- mng? ( media-libs/libmng:= )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- qt_use_compile_test jpeg2k jasper
- qt_use_compile_test mng libmng
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtlocation/qtlocation-5.9.9999.ebuild b/dev-qt/qtlocation/qtlocation-5.9.9999.ebuild
deleted file mode 100644
index f791b5b3..00000000
--- a/dev-qt/qtlocation/qtlocation-5.9.9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="The Location module for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-IUSE=""
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtpositioning-${PV}
- ~dev-qt/qtsql-${PV}
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- ~dev-qt/qtconcurrent-${PV}
-"
-
-QT5_TARGET_SUBDIRS=(
- src/3rdparty/clipper
- src/3rdparty/poly2tri
- src/3rdparty/clip2tri
- src/3rdparty/mapbox-gl-native
- src/location
- src/imports/location
- src/plugins/geoservices
-)
-
-src_configure() {
- # src/plugins/geoservices requires files that are only generated when
- # qmake is run in the root directory. Bug 633776.
- mkdir -p "${QT5_BUILD_DIR}" || die
- qt5_qmake "${QT_BUILD_DIR}"
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtmultimedia/qtmultimedia-5.9.9999.ebuild b/dev-qt/qtmultimedia/qtmultimedia-5.9.9999.ebuild
deleted file mode 100644
index 04cc34da..00000000
--- a/dev-qt/qtmultimedia/qtmultimedia-5.9.9999.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Multimedia (audio, video, radio, camera) library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="alsa gles2 gstreamer openal pulseaudio qml widgets"
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=]
- ~dev-qt/qtnetwork-${PV}
- alsa? ( media-libs/alsa-lib )
- gstreamer? (
- dev-libs/glib:2
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-bad:1.0
- media-libs/gst-plugins-base:1.0
- )
- pulseaudio? ( media-sound/pulseaudio )
- qml? (
- ~dev-qt/qtdeclarative-${PV}
- gles2? ( ~dev-qt/qtgui-${PV}[egl] )
- openal? ( media-libs/openal )
- )
- widgets? (
- ~dev-qt/qtopengl-${PV}
- ~dev-qt/qtwidgets-${PV}[gles2=]
- )
-"
-DEPEND="${RDEPEND}
- gstreamer? ( x11-base/xorg-proto )
-"
-
-src_prepare() {
- sed -i -e '/CONFIG\s*+=/ s/optimize_full//' \
- src/multimedia/multimedia.pro || die
-
- qt_use_disable_config openal openal \
- src/imports/imports.pro
-
- qt_use_disable_mod qml quick \
- src/src.pro \
- src/plugins/plugins.pro
-
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/gsttools/gsttools.pro \
- src/plugins/gstreamer/common.pri
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myqmakeargs=(
- --
- $(qt_use alsa)
- $(qt_use gstreamer)
- $(qt_use pulseaudio)
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtnetwork/qtnetwork-5.9.9999.ebuild b/dev-qt/qtnetwork/qtnetwork-5.9.9999.ebuild
deleted file mode 100644
index f72faeec..00000000
--- a/dev-qt/qtnetwork/qtnetwork-5.9.9999.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Network abstraction library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="bindist connman libproxy libressl networkmanager +ssl"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- >=sys-libs/zlib-1.2.5
- connman? ( ~dev-qt/qtdbus-${PV} )
- libproxy? ( net-libs/libproxy )
- networkmanager? ( ~dev-qt/qtdbus-${PV} )
- ssl? (
- !libressl? ( dev-libs/openssl:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )
- )
-"
-RDEPEND="${DEPEND}
- connman? ( net-misc/connman )
- networkmanager? ( net-misc/networkmanager )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/network
- src/plugins/bearer/generic
-)
-
-QT5_GENTOO_CONFIG=(
- libproxy
- ssl::SSL
- ssl::OPENSSL
- ssl:openssl-linked:LINKED_OPENSSL
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :network
-)
-
-pkg_setup() {
- use connman && QT5_TARGET_SUBDIRS+=(src/plugins/bearer/connman)
- use networkmanager && QT5_TARGET_SUBDIRS+=(src/plugins/bearer/networkmanager)
-}
-
-src_configure() {
- local myconf=(
- $(use connman || use networkmanager && echo -dbus-linked)
- $(qt_use libproxy)
- $(usex ssl -openssl-linked '')
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtnetworkauth/qtnetworkauth-5.9.9999.ebuild b/dev-qt/qtnetworkauth/qtnetworkauth-5.9.9999.ebuild
deleted file mode 100644
index a1e6dc62..00000000
--- a/dev-qt/qtnetworkauth/qtnetworkauth-5.9.9999.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Network authorization library for the Qt5 framework"
-LICENSE="GPL-3"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtnetwork-${PV}
-"
-RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtopengl/qtopengl-5.9.9999.ebuild b/dev-qt/qtopengl/qtopengl-5.9.9999.ebuild
deleted file mode 100644
index 5dfd9694..00000000
--- a/dev-qt/qtopengl/qtopengl-5.9.9999.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-VIRTUALX_REQUIRED="test"
-inherit qt5-build
-
-DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="gles2"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=]
- ~dev-qt/qtwidgets-${PV}[gles2=]
- virtual/opengl
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/opengl
-)
-
-src_configure() {
- local myconf=(
- -opengl $(usex gles2 es2 desktop)
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtpaths/qtpaths-5.9.9999.ebuild b/dev-qt/qtpaths/qtpaths-5.9.9999.ebuild
deleted file mode 100644
index bc5bdee2..00000000
--- a/dev-qt/qtpaths/qtpaths-5.9.9999.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Command line client to QStandardPaths"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/qtpaths
-)
diff --git a/dev-qt/qtplugininfo/qtplugininfo-5.9.9999.ebuild b/dev-qt/qtplugininfo/qtplugininfo-5.9.9999.ebuild
deleted file mode 100644
index 43ae95d1..00000000
--- a/dev-qt/qtplugininfo/qtplugininfo-5.9.9999.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qttools"
-inherit qt5-build
-
-DESCRIPTION="Qt5 plugin metadata dumper"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/qtplugininfo
-)
diff --git a/dev-qt/qtpositioning/qtpositioning-5.9.9999.ebuild b/dev-qt/qtpositioning/qtpositioning-5.9.9999.ebuild
deleted file mode 100644
index c698a3ca..00000000
--- a/dev-qt/qtpositioning/qtpositioning-5.9.9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtlocation"
-inherit qt5-build
-
-DESCRIPTION="Physical position determination library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE="geoclue qml"
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- geoclue? ( ~dev-qt/qtdbus-${PV} )
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-DEPEND="${RDEPEND}"
-PDEPEND="
- geoclue? ( app-misc/geoclue:0 )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/3rdparty/clipper
- src/3rdparty/poly2tri
- src/3rdparty/clip2tri
- src/positioning
- src/plugins/position/positionpoll
-)
-
-pkg_setup() {
- use geoclue && QT5_TARGET_SUBDIRS+=(src/plugins/position/geoclue)
- use qml && QT5_TARGET_SUBDIRS+=(src/imports/positioning)
-}
diff --git a/dev-qt/qtprintsupport/qtprintsupport-5.9.9999.ebuild b/dev-qt/qtprintsupport/qtprintsupport-5.9.9999.ebuild
deleted file mode 100644
index b53ccddd..00000000
--- a/dev-qt/qtprintsupport/qtprintsupport-5.9.9999.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-VIRTUALX_REQUIRED="test"
-inherit qt5-build
-
-DESCRIPTION="Printing support library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="cups gles2"
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=]
- ~dev-qt/qtwidgets-${PV}[gles2=]
- cups? ( >=net-print/cups-1.4 )
-"
-DEPEND="${RDEPEND}
- test? ( ~dev-qt/qtnetwork-${PV} )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/printsupport
- src/plugins/printsupport
-)
-
-QT5_GENTOO_CONFIG=(
- cups
-)
-
-src_configure() {
- local myconf=(
- $(qt_use cups)
- -opengl $(usex gles2 es2 desktop)
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtquickcontrols/qtquickcontrols-5.9.9999.ebuild b/dev-qt/qtquickcontrols/qtquickcontrols-5.9.9999.ebuild
deleted file mode 100644
index e0dc9411..00000000
--- a/dev-qt/qtquickcontrols/qtquickcontrols-5.9.9999.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Set of controls used in conjunction with Qt Quick to build complete interfaces"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE="+widgets"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- widgets? ( ~dev-qt/qtwidgets-${PV} )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/controls/Private/private.pri \
- tests/auto/activeFocusOnTab/activeFocusOnTab.pro \
- tests/auto/controls/controls.pro \
- tests/auto/testplugin/testplugin.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.9999.ebuild b/dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.9999.ebuild
deleted file mode 100644
index aa6bccf5..00000000
--- a/dev-qt/qtquickcontrols2/qtquickcontrols2-5.9.9999.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Set of next generation Qt Quick controls for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-IUSE="widgets"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- widgets? ( ~dev-qt/qtwidgets-${PV} )
-"
-RDEPEND="${DEPEND}
- ~dev-qt/qtgraphicaleffects-${PV}
-"
-
-src_prepare() {
- qt_use_disable_mod widgets widgets \
- src/imports/platform/platform.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtscript/qtscript-5.9.9999.ebuild b/dev-qt/qtscript/qtscript-5.9.9999.ebuild
deleted file mode 100644
index 2644fc6e..00000000
--- a/dev-qt/qtscript/qtscript-5.9.9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Application scripting library for the Qt5 framework (deprecated)"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="+jit scripttools"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- scripttools? (
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwidgets-${PV}
- )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- qt_use_disable_mod scripttools widgets \
- src/src.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myqmakeargs=(
- JAVASCRIPTCORE_JIT=$(usex jit 'yes' 'no')
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtscxml/qtscxml-5.9.9999.ebuild b/dev-qt/qtscxml/qtscxml-5.9.9999.ebuild
deleted file mode 100644
index 59b06ef2..00000000
--- a/dev-qt/qtscxml/qtscxml-5.9.9999.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="State Chart XML (SCXML) support library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
-"
-RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtsensors/qtsensors-5.9.9999.ebuild b/dev-qt/qtsensors/qtsensors-5.9.9999.ebuild
deleted file mode 100644
index d0b0c5b6..00000000
--- a/dev-qt/qtsensors/qtsensors-5.9.9999.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Hardware sensor access library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-# TODO: simulator
-IUSE="qml"
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdbus-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- qt_use_disable_mod qml quick \
- src/src.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtserialbus/qtserialbus-5.9.9999.ebuild b/dev-qt/qtserialbus/qtserialbus-5.9.9999.ebuild
deleted file mode 100644
index c6a1fac1..00000000
--- a/dev-qt/qtserialbus/qtserialbus-5.9.9999.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Support for CAN and other serial buses"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtserialport-${PV}
-"
-RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtserialport/qtserialport-5.9.9999.ebuild b/dev-qt/qtserialport/qtserialport-5.9.9999.ebuild
deleted file mode 100644
index f29b276e..00000000
--- a/dev-qt/qtserialport/qtserialport-5.9.9999.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Serial port abstraction library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- virtual/libudev:=
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # make sure we link against libudev
- sed -i -e 's/:qtConfig(libudev)//' \
- src/serialport/serialport-lib.pri || die
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtspeech/files/qtspeech-5.9.4-nogui.patch b/dev-qt/qtspeech/files/qtspeech-5.9.4-nogui.patch
deleted file mode 100644
index fa5d900a..00000000
--- a/dev-qt/qtspeech/files/qtspeech-5.9.4-nogui.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Bug: https://bugs.gentoo.org/651012
-
---- a/src/plugins/tts/speechdispatcher/speechdispatcher.pro
-+++ b/src/plugins/tts/speechdispatcher/speechdispatcher.pro
-@@ -5,6 +5,7 @@
- load(qt_plugin)
-
- QT += core texttospeech
-+QT -= gui
-
- CONFIG += link_pkgconfig
- packagesExist(speech-dispatcher): PKGCONFIG = speech-dispatcher
diff --git a/dev-qt/qtspeech/qtspeech-5.9.9999.ebuild b/dev-qt/qtspeech/qtspeech-5.9.9999.ebuild
deleted file mode 100644
index 24627d2b..00000000
--- a/dev-qt/qtspeech/qtspeech-5.9.9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Text-to-speech library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~x86"
-fi
-
-# TODO: flite plugin - needs 2.0.0 (not yet in tree)
-IUSE=""
-
-RDEPEND="
- >=app-accessibility/speech-dispatcher-0.8.7
- ~dev-qt/qtcore-${PV}
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-5.9.4-nogui.patch" )
diff --git a/dev-qt/qtsql/files/qtsql-5.9.5-mariadb-10.2.patch b/dev-qt/qtsql/files/qtsql-5.9.5-mariadb-10.2.patch
deleted file mode 100644
index 79de44dc..00000000
--- a/dev-qt/qtsql/files/qtsql-5.9.5-mariadb-10.2.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 64588c9bae92ef79f9ca5e87653ffb0962691d0d Mon Sep 17 00:00:00 2001
-From: Andy Shaw <andy.shaw@qt.io>
-Date: Wed, 27 Sep 2017 09:23:10 +0200
-Subject: [PATCH] Extend the MariaDB define check to cover the later versions
- too
-
-Change-Id: Ide89b4e07feb116bf152cbf3f5630d313e8ba0f1
----
- src/plugins/sqldrivers/mysql/qsql_mysql.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
-index 6e428fb..b2d3e85 100644
---- a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
-+++ b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
-@@ -1159,14 +1159,14 @@ static void qLibraryInit()
- # endif // MYSQL_VERSION_ID
- #endif // Q_NO_MYSQL_EMBEDDED
-
--#ifdef MARIADB_BASE_VERSION
-+#if defined(MARIADB_BASE_VERSION) || defined(MARIADB_VERSION_ID)
- qAddPostRoutine([]() { mysql_server_end(); });
- #endif
- }
-
- static void qLibraryEnd()
- {
--#if !defined(MARIADB_BASE_VERSION)
-+#if !defined(MARIADB_BASE_VERSION) && !defined(MARIADB_VERSION_ID)
- # if !defined(Q_NO_MYSQL_EMBEDDED)
- # if MYSQL_VERSION_ID > 40000
- # if (MYSQL_VERSION_ID >= 40110 && MYSQL_VERSION_ID < 50000) || MYSQL_VERSION_ID >= 50003
---
-2.7.4
-
diff --git a/dev-qt/qtsql/qtsql-5.9.9999.ebuild b/dev-qt/qtsql/qtsql-5.9.9999.ebuild
deleted file mode 100644
index 325786e3..00000000
--- a/dev-qt/qtsql/qtsql-5.9.9999.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="SQL abstraction library for the Qt5 framework"
-SLOT=5/$(ver_cut 1-3) # bug 639140
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE="freetds mysql oci8 odbc postgres +sqlite"
-
-REQUIRED_USE="
- || ( freetds mysql oci8 odbc postgres sqlite )
-"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- freetds? ( dev-db/freetds )
- mysql? ( virtual/libmysqlclient:= )
- oci8? ( dev-db/oracle-instantclient-basic )
- odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( >=dev-db/sqlite-3.8.10.2:3 )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.9.5-mariadb-10.2.patch"
- # See also: https://codereview.qt-project.org/#/c/206850/
-)
-
-QT5_TARGET_SUBDIRS=(
- src/sql
- src/plugins/sqldrivers
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :sql
-)
-
-src_configure() {
- local myconf=(
- $(qt_use freetds sql-tds plugin)
- $(qt_use mysql sql-mysql plugin)
- $(qt_use oci8 sql-oci plugin)
- $(qt_use odbc sql-odbc plugin)
- $(qt_use postgres sql-psql plugin)
- $(qt_use sqlite sql-sqlite plugin)
- $(usex sqlite -system-sqlite '')
- )
-
- use mysql && myconf+=("-I${EPREFIX}/usr/include/mysql" "-L${EPREFIX}/usr/$(get_libdir)/mysql")
- use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
- use odbc && myconf+=("-I${EPREFIX}/usr/include/iodbc")
- use postgres && myconf+=("-I${EPREFIX}/usr/include/postgresql/pgsql")
-
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtsvg/qtsvg-5.9.9999.ebuild b/dev-qt/qtsvg/qtsvg-5.9.9999.ebuild
deleted file mode 100644
index 8afd46f0..00000000
--- a/dev-qt/qtsvg/qtsvg-5.9.9999.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="SVG rendering library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwidgets-${PV}
- >=sys-libs/zlib-1.2.5
-"
-DEPEND="${RDEPEND}
- test? ( ~dev-qt/qtxml-${PV} )
-"
diff --git a/dev-qt/qttest/qttest-5.9.9999.ebuild b/dev-qt/qttest/qttest-5.9.9999.ebuild
deleted file mode 100644
index a136469c..00000000
--- a/dev-qt/qttest/qttest-5.9.9999.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-VIRTUALX_REQUIRED="test"
-inherit qt5-build
-
-DESCRIPTION="Unit testing library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
-"
-DEPEND="${RDEPEND}
- test? (
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtxml-${PV}
- )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/testlib
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :testlib
-)
diff --git a/dev-qt/qttranslations/qttranslations-5.9.9999.ebuild b/dev-qt/qttranslations/qttranslations-5.9.9999.ebuild
deleted file mode 100644
index 02291152..00000000
--- a/dev-qt/qttranslations/qttranslations-5.9.9999.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Translation files for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/linguist-tools-${PV}
- ~dev-qt/qtcore-${PV}
-"
-RDEPEND=""
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.9.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.9.9999.ebuild
deleted file mode 100644
index 21fd992d..00000000
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.9.9999.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Virtual keyboard plugin for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-fbsd"
-fi
-
-# TODO: unbudle libraries for more layouts
-IUSE="handwriting +spell +xcb"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtsvg-${PV}
- spell? ( app-text/hunspell:= )
- xcb? ( x11-libs/libxcb:= )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local myqmakeargs=(
- $(usex handwriting CONFIG+=lipi-toolkit "")
- $(usex spell "" CONFIG+=disable-hunspell)
- $(usex xcb "" CONFIG+=disable-desktop)
- CONFIG+="lang-ar_AR lang-da_DK lang-de_DE lang-en_GB \
- lang-es_ES lang-fa_FA lang-fi_FI lang-fr_FR \
- lang-hi_IN lang-it_IT lang-nb_NO lang-pl_PL \
- lang-pt_PT lang-ro_RO lang-ru_RU lang-sv_SE"
- )
-
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtwayland/qtwayland-5.9.9999.ebuild b/dev-qt/qtwayland/qtwayland-5.9.9999.ebuild
deleted file mode 100644
index 1379e01e..00000000
--- a/dev-qt/qtwayland/qtwayland-5.9.9999.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE="+libinput xcomposite"
-
-DEPEND="
- >=dev-libs/wayland-1.6.0
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput=]
- media-libs/mesa[egl]
- >=x11-libs/libxkbcommon-0.2.0
- xcomposite? (
- x11-libs/libX11
- x11-libs/libXcomposite
- )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- qt_use_disable_config libinput xkbcommon-evdev \
- src/client/client.pro \
- src/compositor/wayland_wrapper/wayland_wrapper.pri \
- src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
- tests/auto/compositor/compositor/compositor.pro
-
- use xcomposite || rm -r config.tests/xcomposite || die
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtwebchannel/qtwebchannel-5.9.9999.ebuild b/dev-qt/qtwebchannel/qtwebchannel-5.9.9999.ebuild
deleted file mode 100644
index 7f4acf24..00000000
--- a/dev-qt/qtwebchannel/qtwebchannel-5.9.9999.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Qt5 module for integrating C++ and QML applications with HTML/JavaScript clients"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-fi
-
-IUSE="qml"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- qt_use_disable_mod qml quick src/src.pro
- qt_use_disable_mod qml qml src/webchannel/webchannel.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch b/dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch
deleted file mode 100644
index ecedaf62..00000000
--- a/dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Bug: https://bugs.gentoo.org/634220
-
---- a/src/3rdparty/chromium/v8/BUILD.gn
-+++ b/src/3rdparty/chromium/v8/BUILD.gn
-@@ -661,6 +661,7 @@ action("run_mksnapshot") {
-
- deps = [
- ":mksnapshot($v8_snapshot_toolchain)",
-+ ":run_paxmark",
- ]
-
- script = "tools/run.py"
-@@ -706,6 +707,28 @@ action("run_mksnapshot") {
- args += [ rebase_path(v8_embed_script, root_build_dir) ]
- }
- }
-+action("run_paxmark") {
-+ visibility = [ ":*" ] # Only targets in this file can depend on this.
-+
-+ deps = [
-+ ":mksnapshot($v8_snapshot_toolchain)",
-+ ]
-+
-+ script = "/usr/sbin/pypaxctl"
-+
-+ sources = []
-+
-+ outputs = [
-+ "$target_out_dir/mksnapshot",
-+ ]
-+
-+ args = [
-+ "-sm",
-+ "./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
-+ "root_out_dir") + "/mksnapshot",
-+ root_build_dir),
-+ ]
-+}
-
- action("run_mkpeephole") {
- visibility = [ ":*" ] # Only targets in this file can depend on this.
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-1.patch b/dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-1.patch
deleted file mode 100644
index 8b739680..00000000
--- a/dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-1.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 560a4a616f2a1307385e5e7a7d2e99b0b41775c8 Mon Sep 17 00:00:00 2001
-From: Viktor Engelmann <viktor.engelmann@qt.io>
-Date: Fri, 18 Aug 2017 14:50:20 +0200
-Subject: [PATCH] Fix improper boolean values
-
-jpeg_codec.cc contained some implicit conversions to boolean, which
-is apparently problematic for some versions of libjpeg. Patch
-taken from https://bugs.chromium.org/p/chromium/issues/detail?id=686191
-but not backported, since it has not been accepted into chromium yet.
-
-Task-Number: QTBUG-58482
-
-Change-Id: I2c5d5894493d6a7d0698a4e5a7191288a2fdfeb4
-Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
----
- src/3rdparty/chromium/ui/gfx/codec/jpeg_codec.cc | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/3rdparty/chromium/ui/gfx/codec/jpeg_codec.cc b/src/3rdparty/chromium/ui/gfx/codec/jpeg_codec.cc
-index 6d92637..85c7bec 100644
---- a/src/3rdparty/chromium/ui/gfx/codec/jpeg_codec.cc
-+++ b/src/3rdparty/chromium/ui/gfx/codec/jpeg_codec.cc
-@@ -121,7 +121,7 @@ boolean EmptyOutputBuffer(jpeg_compress_struct* cinfo) {
- // tell libjpeg where to write the next data
- cinfo->dest->next_output_byte = &(*state->out)[state->image_buffer_used];
- cinfo->dest->free_in_buffer = state->out->size() - state->image_buffer_used;
-- return 1;
-+ return TRUE;
- }
-
- // Cleans up the JpegEncoderState to prepare for returning in the final form.
-@@ -262,7 +262,7 @@ bool JPEGCodec::Encode(const unsigned char* input, ColorFormat format,
- cinfo.data_precision = 8;
-
- jpeg_set_defaults(&cinfo);
-- jpeg_set_quality(&cinfo, quality, 1); // quality here is 0-100
-+ jpeg_set_quality(&cinfo, quality, TRUE); // quality here is 0-100
-
- // set up the destination manager
- jpeg_destination_mgr destmgr;
-@@ -274,7 +274,7 @@ bool JPEGCodec::Encode(const unsigned char* input, ColorFormat format,
- JpegEncoderState state(output);
- cinfo.client_data = &state;
-
-- jpeg_start_compress(&cinfo, 1);
-+ jpeg_start_compress(&cinfo, TRUE);
-
- // feed it the rows, doing necessary conversions for the color format
- #ifdef JCS_EXTENSIONS
-@@ -360,7 +360,7 @@ void InitSource(j_decompress_ptr cinfo) {
- // set to a positive value if TRUE is returned. A FALSE return should only
- // be used when I/O suspension is desired."
- boolean FillInputBuffer(j_decompress_ptr cinfo) {
-- return false;
-+ return FALSE;
- }
-
- // Skip data in the buffer. Since we have all the data at once, this operation
-@@ -488,7 +488,7 @@ bool JPEGCodec::Decode(const unsigned char* input, size_t input_size,
- cinfo.client_data = &state;
-
- // fill the file metadata into our buffer
-- if (jpeg_read_header(&cinfo, true) != JPEG_HEADER_OK)
-+ if (jpeg_read_header(&cinfo, TRUE) != JPEG_HEADER_OK)
- return false;
-
- // we want to always get RGB data out
---
-2.7.4
-
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-2.patch b/dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-2.patch
deleted file mode 100644
index ef5f44ef..00000000
--- a/dev-qt/qtwebengine/files/qtwebengine-5.9.4-jpeg-9-2.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Fix build with jpeg-9. Bug #646456
-
---- a/src/3rdparty/chromium/third_party/pdfium/core/fxcodec/codec/fx_codec_jpeg.cpp 2018-01-15 12:39:43.000000000 +0100
-+++ b/src/3rdparty/chromium/third_party/pdfium/core/fxcodec/codec/fx_codec_jpeg.cpp 2018-02-06 20:55:37.455912163 +0100
-@@ -57,12 +57,12 @@
- };
- extern "C" {
- static boolean _src_fill_buffer(j_decompress_ptr cinfo) {
-- return 0;
-+ return FALSE;
- }
- };
- extern "C" {
- static boolean _src_resync(j_decompress_ptr cinfo, int desired) {
-- return 0;
-+ return FALSE;
- }
- };
- extern "C" {
-@@ -126,7 +126,7 @@
- jpeg_destroy_decompress(&cinfo);
- return false;
- }
-- int ret = jpeg_read_header(&cinfo, true);
-+ int ret = jpeg_read_header(&cinfo, TRUE);
- if (ret != JPEG_HEADER_OK) {
- jpeg_destroy_decompress(&cinfo);
- return false;
-@@ -210,7 +210,7 @@
- }
- cinfo.image_width = m_OrigWidth;
- cinfo.image_height = m_OrigHeight;
-- int ret = jpeg_read_header(&cinfo, true);
-+ int ret = jpeg_read_header(&cinfo, TRUE);
- if (ret != JPEG_HEADER_OK)
- return false;
-
-@@ -433,7 +433,7 @@
- if (setjmp(ctx->m_JumpMark) == -1)
- return 1;
-
-- int ret = jpeg_read_header(&ctx->m_Info, true);
-+ int ret = jpeg_read_header(&ctx->m_Info, TRUE);
- if (ret == JPEG_SUSPENDED)
- return 2;
- if (ret != JPEG_HEADER_OK)
diff --git a/dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild
deleted file mode 100644
index 2b521acd..00000000
--- a/dev-qt/qtwebengine/qtwebengine-5.9.9999.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-inherit multiprocessing pax-utils python-any-r1 qt5-build
-
-DESCRIPTION="Library for rendering dynamic web content in Qt5 C++ and QML applications"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-IUSE="alsa bindist designer geolocation pax_kernel pulseaudio +system-ffmpeg +system-icu widgets"
-REQUIRED_USE="designer? ( widgets )"
-
-RDEPEND="
- app-arch/snappy:=
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtprintsupport-${PV}
- ~dev-qt/qtwebchannel-${PV}[qml]
- dev-libs/expat
- dev-libs/libevent:=
- dev-libs/libxml2[icu]
- dev-libs/libxslt
- dev-libs/re2:=
- media-libs/fontconfig
- media-libs/freetype
- media-libs/harfbuzz:=
- media-libs/libpng:0=
- >=media-libs/libvpx-1.5:=[svc]
- media-libs/libwebp:=
- media-libs/mesa[egl]
- media-libs/opus
- sys-apps/dbus
- sys-apps/pciutils
- sys-libs/libcap
- sys-libs/zlib[minizip]
- virtual/jpeg:0
- virtual/libudev
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXScrnSaver
- x11-libs/libXtst
- alsa? ( media-libs/alsa-lib )
- designer? ( ~dev-qt/designer-${PV} )
- geolocation? ( ~dev-qt/qtpositioning-${PV} )
- pulseaudio? ( media-sound/pulseaudio:= )
- system-ffmpeg? ( media-video/ffmpeg:0= )
- system-icu? ( dev-libs/icu:= )
- widgets? (
- ~dev-qt/qtdeclarative-${PV}[widgets]
- ~dev-qt/qtwidgets-${PV}
- )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- >=app-arch/gzip-1.7
- dev-util/gperf
- dev-util/ninja
- dev-util/re2c
- sys-devel/bison
- pax_kernel? ( sys-apps/elfix )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.9.4-jpeg-9-1.patch"
- "${FILESDIR}/${PN}-5.9.4-jpeg-9-2.patch"
- "${FILESDIR}/${PN}-5.9.6-gcc8.patch" # bug 657124
-)
-
-src_prepare() {
- use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
-
- # bug 620444 - ensure local headers are used
- find "${S}" -type f -name "*.pr[fio]" | xargs sed -i -e 's|INCLUDEPATH += |&$$QTWEBENGINE_ROOT/include |' || die
-
- qt_use_disable_config alsa alsa src/core/config/linux.pri
- qt_use_disable_config pulseaudio pulseaudio src/core/config/linux.pri
-
- qt_use_disable_mod designer webenginewidgets src/plugins/plugins.pro
-
- qt_use_disable_mod geolocation positioning \
- mkspecs/features/configure.prf \
- src/core/core_chromium.pri \
- src/core/core_common.pri
-
- qt_use_disable_mod widgets widgets src/src.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- export NINJA_PATH=/usr/bin/ninja
- export NINJAFLAGS="${NINJAFLAGS:--j$(makeopts_jobs) -l$(makeopts_loadavg "${MAKEOPTS}" 0) -v}"
-
- local myqmakeargs=(
- $(usex bindist '' 'WEBENGINE_CONFIG+=use_proprietary_codecs')
- $(usex system-ffmpeg 'WEBENGINE_CONFIG+=use_system_ffmpeg' '')
- $(usex system-icu 'WEBENGINE_CONFIG+=use_system_icu' '')
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
-
- # bug 601472
- if [[ ! -f ${D%/}${QT5_LIBDIR}/libQt5WebEngine.so ]]; then
- die "${CATEGORY}/${PF} failed to build anything. Please report to https://bugs.gentoo.org/"
- fi
-
- pax-mark m "${D%/}${QT5_LIBEXECDIR}"/QtWebEngineProcess
-}
diff --git a/dev-qt/qtwebsockets/qtwebsockets-5.9.9999.ebuild b/dev-qt/qtwebsockets/qtwebsockets-5.9.9999.ebuild
deleted file mode 100644
index 362a0a81..00000000
--- a/dev-qt/qtwebsockets/qtwebsockets-5.9.9999.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Implementation of the WebSocket protocol for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-fi
-
-IUSE="qml +ssl"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtnetwork-${PV}[ssl=]
- qml? ( ~dev-qt/qtdeclarative-${PV} )
-
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- qt_use_disable_mod qml quick src/src.pro
-
- qt5-build_src_prepare
-}
diff --git a/dev-qt/qtwebview/qtwebview-5.9.9999.ebuild b/dev-qt/qtwebview/qtwebview-5.9.9999.ebuild
deleted file mode 100644
index 43288fc1..00000000
--- a/dev-qt/qtwebview/qtwebview-5.9.9999.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Module for displaying web content in a QML application using the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtwebengine-${PV}
-"
-RDEPEND="${DEPEND}"
diff --git a/dev-qt/qtwidgets/qtwidgets-5.9.9999.ebuild b/dev-qt/qtwidgets/qtwidgets-5.9.9999.ebuild
deleted file mode 100644
index caf1f79a..00000000
--- a/dev-qt/qtwidgets/qtwidgets-5.9.9999.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Set of components for creating classic desktop-style UIs for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-# keep IUSE defaults in sync with qtgui
-IUSE="gles2 gtk +png +xcb"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=,png=,xcb?]
- gtk? (
- ~dev-qt/qtgui-${PV}[dbus]
- x11-libs/gtk+:3
- x11-libs/libX11
- x11-libs/pango
- )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/tools/uic
- src/widgets
- src/plugins/platformthemes
-)
-
-QT5_GENTOO_CONFIG=(
- gtk:gtk3:
- ::widgets
- !:no-widgets:
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :widgets
-)
-
-src_configure() {
- local myconf=(
- -opengl $(usex gles2 es2 desktop)
- $(qt_use gtk)
- -gui
- $(qt_use png libpng system)
- -widgets
- $(qt_use xcb xcb system)
- $(qt_use xcb xkbcommon system)
- $(usex xcb '-xcb-xlib -xinput2 -xkb' '')
- )
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtx11extras/qtx11extras-5.9.9999.ebuild b/dev-qt/qtx11extras/qtx11extras-5.9.9999.ebuild
deleted file mode 100644
index b029cc42..00000000
--- a/dev-qt/qtx11extras/qtx11extras-5.9.9999.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="Linux/X11-specific support library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[xcb]
-"
-DEPEND="${RDEPEND}
- test? ( ~dev-qt/qtwidgets-${PV} )
-"
diff --git a/dev-qt/qtxml/qtxml-5.9.9999.ebuild b/dev-qt/qtxml/qtxml-5.9.9999.ebuild
deleted file mode 100644
index b8568f5e..00000000
--- a/dev-qt/qtxml/qtxml-5.9.9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-RDEPEND="
- ~dev-qt/qtcore-${PV}
-"
-DEPEND="${RDEPEND}
- test? ( ~dev-qt/qtnetwork-${PV} )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/xml
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :xml
-)
diff --git a/dev-qt/qtxmlpatterns/qtxmlpatterns-5.9.9999.ebuild b/dev-qt/qtxmlpatterns/qtxmlpatterns-5.9.9999.ebuild
deleted file mode 100644
index 8e0054f7..00000000
--- a/dev-qt/qtxmlpatterns/qtxmlpatterns-5.9.9999.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="XPath, XQuery, XSLT, and XML Schema validation library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-IUSE=""
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtnetwork-${PV}
-"
-RDEPEND="${DEPEND}"