aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-20 18:00:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-06 20:44:08 +0100
commitcda396ca2d422a89785b7abe1ac924339ff59d55 (patch)
tree5603d16ae1d5cdd79851f1c0fc9e2863ce15e179
parentdev-qt/qtlocation: Add USE-DEPEND on dev-qt/qtpositioning[qml] (diff)
downloadqt-cda396ca2d422a89785b7abe1ac924339ff59d55.tar.gz
qt-cda396ca2d422a89785b7abe1ac924339ff59d55.tar.bz2
qt-cda396ca2d422a89785b7abe1ac924339ff59d55.zip
dev-qt/qtwebkit: Drop live ebuilds
Upstream repositories appear dead. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.4.2-system-leveldb.patch25
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.5.1-disable-jit.patch15
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.8.0-disable-gstreamer.patch15
-rw-r--r--dev-qt/qtwebkit/metadata.xml28
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.12.9999.ebuild120
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.9.9999.ebuild120
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.9999.ebuild120
7 files changed, 0 insertions, 443 deletions
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.4.2-system-leveldb.patch b/dev-qt/qtwebkit/files/qtwebkit-5.4.2-system-leveldb.patch
deleted file mode 100644
index 265d5075..00000000
--- a/dev-qt/qtwebkit/files/qtwebkit-5.4.2-system-leveldb.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Correct header location so system dev-libs/leveldb can be detected.
-
---- a/Tools/qmake/config.tests/leveldb/leveldb.cpp
-+++ b/Tools/qmake/config.tests/leveldb/leveldb.cpp
-@@ -19,7 +19,7 @@
-
- #include <leveldb/db.h>
- #include <leveldb/env.h>
--#include <helpers/memenv/memenv.h>
-+#include <leveldb/helpers/memenv.h>
-
- int main(int, char**)
- {
-
---- a/Source/WebCore/platform/leveldb/LevelDBDatabase.cpp
-+++ b/Source/WebCore/platform/leveldb/LevelDBDatabase.cpp
-@@ -38,7 +38,7 @@
- #include <leveldb/comparator.h>
- #include <leveldb/db.h>
- #include <leveldb/env.h>
--#include <helpers/memenv/memenv.h>
-+#include <leveldb/helpers/memenv.h>
- #include <leveldb/slice.h>
- #include <string>
- #include <wtf/PassOwnPtr.h>
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.5.1-disable-jit.patch b/dev-qt/qtwebkit/files/qtwebkit-5.5.1-disable-jit.patch
deleted file mode 100644
index 40e58f0d..00000000
--- a/dev-qt/qtwebkit/files/qtwebkit-5.5.1-disable-jit.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Allow disabling JIT for hardened.
-
-Author: Magnus Granberg <zorry@gentoo.org>
-Gentoo-bug: 562396
-
---- a/Tools/qmake/mkspecs/features/features.pri
-+++ b/Tools/qmake/mkspecs/features/features.pri
-@@ -70,6 +70,7 @@ FEATURE_DEFAULTS = \
- ENABLE_INPUT_TYPE_WEEK=0 \
- ENABLE_INSPECTOR=1 \
- ENABLE_INSPECTOR_SERVER=1 \
-+ ENABLE_JIT=0 \
- ENABLE_JAVASCRIPT_DEBUGGER=1 \
- ENABLE_LEGACY_CSS_VENDOR_PREFIXES=0 \
- ENABLE_LEGACY_NOTIFICATIONS=1 \
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.8.0-disable-gstreamer.patch b/dev-qt/qtwebkit/files/qtwebkit-5.8.0-disable-gstreamer.patch
deleted file mode 100644
index 867e8dcb..00000000
--- a/dev-qt/qtwebkit/files/qtwebkit-5.8.0-disable-gstreamer.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Tools/qmake/mkspecs/features/features.prf
-+++ b/Tools/qmake/mkspecs/features/features.prf
-@@ -101,12 +101,6 @@ defineTest(detectFeatures) {
-
- # HTML5 Media Support for builds with GStreamer
- unix:!mac:qtConfig(pkg-config) {
-- packagesExist("glib-2.0 gio-2.0 gstreamer-1.0 gstreamer-plugins-base-1.0") {
-- WEBKIT_CONFIG += video use_gstreamer
-- } else: packagesExist("glib-2.0 gio-2.0 \'gstreamer-0.10 >= 0.10.30\' \'gstreamer-plugins-base-0.10 >= 0.10.30\'") {
-- WEBKIT_CONFIG += video use_gstreamer use_gstreamer010
-- }
-- use?(gstreamer): WEBKIT_CONFIG += use_native_fullscreen_video
- }
-
- !enable?(video):qtHaveModule(multimediawidgets) {
diff --git a/dev-qt/qtwebkit/metadata.xml b/dev-qt/qtwebkit/metadata.xml
deleted file mode 100644
index a0aa5e42..00000000
--- a/dev-qt/qtwebkit/metadata.xml
+++ /dev/null
@@ -1,28 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
- <use>
- <flag name="geolocation">Enable physical position determination via <pkg>dev-qt/qtpositioning</pkg></flag>
- <flag name="gles2">Use GLES 2.0 or later instead of full OpenGL</flag>
- <flag name="gstreamer">Enable HTML5 audio/video support via <pkg>media-libs/gstreamer</pkg></flag>
- <flag name="multimedia">Enable HTML5 audio/video support via <pkg>dev-qt/qtmultimedia</pkg></flag>
- <flag name="orientation">Enable device orientation detection via <pkg>dev-qt/qtsensors</pkg></flag>
- <flag name="printsupport">Enable printing via <pkg>dev-qt/qtprintsupport</pkg></flag>
- <flag name="qml">Build QML/QtQuick bindings</flag>
- <flag name="webchannel">Enable integration with <pkg>dev-qt/qtwebchannel</pkg></flag>
- <flag name="webp">Add support for WebP image format</flag>
- </use>
- <upstream>
- <bugs-to>https://bugreports.qt.io/</bugs-to>
- <doc>https://doc.qt.io/</doc>
- </upstream>
- <slots>
- <subslots>
- Must only be used by packages that are known to use private parts of the Qt API.
- </subslots>
- </slots>
-</pkgmetadata>
diff --git a/dev-qt/qtwebkit/qtwebkit-5.12.9999.ebuild b/dev-qt/qtwebkit/qtwebkit-5.12.9999.ebuild
deleted file mode 100644
index 8af05a19..00000000
--- a/dev-qt/qtwebkit/qtwebkit-5.12.9999.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-QT_MIN_VER="5.9.1:5"
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-fi
-
-# TODO: qttestlib
-
-IUSE="geolocation gstreamer gles2 +jit multimedia opengl orientation printsupport qml test webchannel webp"
-REQUIRED_USE="?? ( gstreamer multimedia )"
-
-RDEPEND="
- dev-db/sqlite:3
- dev-libs/icu:=
- >=dev-libs/leveldb-1.18-r1
- dev-libs/libxml2:2
- dev-libs/libxslt
- >=dev-qt/qtcore-${QT_MIN_VER}[icu]
- >=dev-qt/qtgui-${QT_MIN_VER}
- >=dev-qt/qtnetwork-${QT_MIN_VER}
- >=dev-qt/qtsql-${QT_MIN_VER}
- >=dev-qt/qtwidgets-${QT_MIN_VER}
- media-libs/fontconfig:1.0
- media-libs/libpng:0=
- >=sys-libs/zlib-1.2.5
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXrender
- geolocation? ( >=dev-qt/qtpositioning-${QT_MIN_VER} )
- gstreamer? (
- dev-libs/glib:2
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_MIN_VER}[widgets] )
- opengl? (
- >=dev-qt/qtgui-${QT_MIN_VER}[gles2=]
- >=dev-qt/qtopengl-${QT_MIN_VER}
- )
- orientation? ( >=dev-qt/qtsensors-${QT_MIN_VER} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_MIN_VER} )
- qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_MIN_VER} )
- webp? ( media-libs/libwebp:0= )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- dev-lang/ruby
- dev-util/gperf
- sys-devel/bison
- sys-devel/flex
- virtual/rubygems
- test? ( >=dev-qt/qttest-${QT_MIN_VER} )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.4.2-system-leveldb.patch"
-)
-
-src_prepare() {
- # ensure bundled library cannot be used
- rm -r Source/ThirdParty/leveldb || die
-
- # force using system library
- sed -i -e 's/qtConfig(system-jpeg)/true/' \
- -e 's/qtConfig(system-png)/true/' \
- Tools/qmake/mkspecs/features/features.prf || die
-
- # bug 466216
- sed -i -e '/CONFIG +=/s/rpath//' \
- Source/WebKit/qt/declarative/{experimental/experimental,public}.pri \
- Tools/qmake/mkspecs/features/{force_static_libs_as_shared,unix/default_post}.prf \
- || die
-
- qt_use_disable_config opengl opengl Tools/qmake/mkspecs/features/features.prf
-
- qt_use_disable_mod geolocation positioning Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod multimedia multimediawidgets Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod orientation sensors Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod printsupport printsupport Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod qml quick Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod webchannel webchannel \
- Source/WebKit2/Target.pri \
- Source/WebKit2/WebKit2.pri
-
- if ! use gstreamer; then
- PATCHES+=("${FILESDIR}/${PN}-5.8.0-disable-gstreamer.patch")
- fi
-
- # bug 562396
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.5.1-disable-jit.patch")
-
- use webp || sed -i -e '/config_libwebp: WEBKIT_CONFIG += use_webp/d' \
- Tools/qmake/mkspecs/features/features.prf || die
-
- # bug 458222
- sed -i -e '/SUBDIRS += examples/d' Source/QtWebKit.pro || die
-
- qt5-build_src_prepare
-}
-
-src_install() {
- qt5-build_src_install
-
- # bug 572056
- if [[ ! -f ${D%/}${QT5_LIBDIR}/libQt5WebKit.so ]]; then
- eerror "${CATEGORY}/${PF} could not build due to a broken ruby environment."
- die 'Check "eselect ruby" and ensure you have a working ruby in your $PATH'
- fi
-}
diff --git a/dev-qt/qtwebkit/qtwebkit-5.9.9999.ebuild b/dev-qt/qtwebkit/qtwebkit-5.9.9999.ebuild
deleted file mode 100644
index 0123ea81..00000000
--- a/dev-qt/qtwebkit/qtwebkit-5.9.9999.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-QT_MIN_VER="5.9.1:5"
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-fi
-
-# TODO: qttestlib
-
-IUSE="geolocation gstreamer gles2 +jit multimedia opengl orientation printsupport qml test webchannel webp"
-REQUIRED_USE="?? ( gstreamer multimedia )"
-
-RDEPEND="
- dev-db/sqlite:3
- dev-libs/icu:=
- >=dev-libs/leveldb-1.18-r1:=
- dev-libs/libxml2:2
- dev-libs/libxslt
- >=dev-qt/qtcore-${QT_MIN_VER}[icu]
- >=dev-qt/qtgui-${QT_MIN_VER}
- >=dev-qt/qtnetwork-${QT_MIN_VER}
- >=dev-qt/qtsql-${QT_MIN_VER}
- >=dev-qt/qtwidgets-${QT_MIN_VER}
- media-libs/fontconfig:1.0
- media-libs/libpng:0=
- >=sys-libs/zlib-1.2.5
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXrender
- geolocation? ( >=dev-qt/qtpositioning-${QT_MIN_VER} )
- gstreamer? (
- dev-libs/glib:2
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_MIN_VER}[widgets] )
- opengl? (
- >=dev-qt/qtgui-${QT_MIN_VER}[gles2=]
- >=dev-qt/qtopengl-${QT_MIN_VER}
- )
- orientation? ( >=dev-qt/qtsensors-${QT_MIN_VER} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_MIN_VER} )
- qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_MIN_VER} )
- webp? ( media-libs/libwebp:0= )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- dev-lang/ruby
- dev-util/gperf
- sys-devel/bison
- sys-devel/flex
- virtual/rubygems
- test? ( >=dev-qt/qttest-${QT_MIN_VER} )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.4.2-system-leveldb.patch"
-)
-
-src_prepare() {
- # ensure bundled library cannot be used
- rm -r Source/ThirdParty/leveldb || die
-
- # force using system library
- sed -i -e 's/qtConfig(system-jpeg)/true/' \
- -e 's/qtConfig(system-png)/true/' \
- Tools/qmake/mkspecs/features/features.prf || die
-
- # bug 466216
- sed -i -e '/CONFIG +=/s/rpath//' \
- Source/WebKit/qt/declarative/{experimental/experimental,public}.pri \
- Tools/qmake/mkspecs/features/{force_static_libs_as_shared,unix/default_post}.prf \
- || die
-
- qt_use_disable_config opengl opengl Tools/qmake/mkspecs/features/features.prf
-
- qt_use_disable_mod geolocation positioning Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod multimedia multimediawidgets Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod orientation sensors Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod printsupport printsupport Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod qml quick Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod webchannel webchannel \
- Source/WebKit2/Target.pri \
- Source/WebKit2/WebKit2.pri
-
- if ! use gstreamer; then
- PATCHES+=("${FILESDIR}/${PN}-5.8.0-disable-gstreamer.patch")
- fi
-
- # bug 562396
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.5.1-disable-jit.patch")
-
- use webp || sed -i -e '/config_libwebp: WEBKIT_CONFIG += use_webp/d' \
- Tools/qmake/mkspecs/features/features.prf || die
-
- # bug 458222
- sed -i -e '/SUBDIRS += examples/d' Source/QtWebKit.pro || die
-
- qt5-build_src_prepare
-}
-
-src_install() {
- qt5-build_src_install
-
- # bug 572056
- if [[ ! -f ${D%/}${QT5_LIBDIR}/libQt5WebKit.so ]]; then
- eerror "${CATEGORY}/${PF} could not build due to a broken ruby environment."
- die 'Check "eselect ruby" and ensure you have a working ruby in your $PATH'
- fi
-}
diff --git a/dev-qt/qtwebkit/qtwebkit-5.9999.ebuild b/dev-qt/qtwebkit/qtwebkit-5.9999.ebuild
deleted file mode 100644
index 8af05a19..00000000
--- a/dev-qt/qtwebkit/qtwebkit-5.9999.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-QT_MIN_VER="5.9.1:5"
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-fi
-
-# TODO: qttestlib
-
-IUSE="geolocation gstreamer gles2 +jit multimedia opengl orientation printsupport qml test webchannel webp"
-REQUIRED_USE="?? ( gstreamer multimedia )"
-
-RDEPEND="
- dev-db/sqlite:3
- dev-libs/icu:=
- >=dev-libs/leveldb-1.18-r1
- dev-libs/libxml2:2
- dev-libs/libxslt
- >=dev-qt/qtcore-${QT_MIN_VER}[icu]
- >=dev-qt/qtgui-${QT_MIN_VER}
- >=dev-qt/qtnetwork-${QT_MIN_VER}
- >=dev-qt/qtsql-${QT_MIN_VER}
- >=dev-qt/qtwidgets-${QT_MIN_VER}
- media-libs/fontconfig:1.0
- media-libs/libpng:0=
- >=sys-libs/zlib-1.2.5
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXrender
- geolocation? ( >=dev-qt/qtpositioning-${QT_MIN_VER} )
- gstreamer? (
- dev-libs/glib:2
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_MIN_VER}[widgets] )
- opengl? (
- >=dev-qt/qtgui-${QT_MIN_VER}[gles2=]
- >=dev-qt/qtopengl-${QT_MIN_VER}
- )
- orientation? ( >=dev-qt/qtsensors-${QT_MIN_VER} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_MIN_VER} )
- qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_MIN_VER} )
- webp? ( media-libs/libwebp:0= )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- dev-lang/ruby
- dev-util/gperf
- sys-devel/bison
- sys-devel/flex
- virtual/rubygems
- test? ( >=dev-qt/qttest-${QT_MIN_VER} )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.4.2-system-leveldb.patch"
-)
-
-src_prepare() {
- # ensure bundled library cannot be used
- rm -r Source/ThirdParty/leveldb || die
-
- # force using system library
- sed -i -e 's/qtConfig(system-jpeg)/true/' \
- -e 's/qtConfig(system-png)/true/' \
- Tools/qmake/mkspecs/features/features.prf || die
-
- # bug 466216
- sed -i -e '/CONFIG +=/s/rpath//' \
- Source/WebKit/qt/declarative/{experimental/experimental,public}.pri \
- Tools/qmake/mkspecs/features/{force_static_libs_as_shared,unix/default_post}.prf \
- || die
-
- qt_use_disable_config opengl opengl Tools/qmake/mkspecs/features/features.prf
-
- qt_use_disable_mod geolocation positioning Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod multimedia multimediawidgets Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod orientation sensors Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod printsupport printsupport Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod qml quick Tools/qmake/mkspecs/features/features.prf
- qt_use_disable_mod webchannel webchannel \
- Source/WebKit2/Target.pri \
- Source/WebKit2/WebKit2.pri
-
- if ! use gstreamer; then
- PATCHES+=("${FILESDIR}/${PN}-5.8.0-disable-gstreamer.patch")
- fi
-
- # bug 562396
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.5.1-disable-jit.patch")
-
- use webp || sed -i -e '/config_libwebp: WEBKIT_CONFIG += use_webp/d' \
- Tools/qmake/mkspecs/features/features.prf || die
-
- # bug 458222
- sed -i -e '/SUBDIRS += examples/d' Source/QtWebKit.pro || die
-
- qt5-build_src_prepare
-}
-
-src_install() {
- qt5-build_src_install
-
- # bug 572056
- if [[ ! -f ${D%/}${QT5_LIBDIR}/libQt5WebKit.so ]]; then
- eerror "${CATEGORY}/${PF} could not build due to a broken ruby environment."
- die 'Check "eselect ruby" and ensure you have a working ruby in your $PATH'
- fi
-}