aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-01-10 00:51:23 +0200
committerJimi Huotari <chiitoo@gentoo.org>2019-01-10 00:51:23 +0200
commitd02583b11829e18ffbba099b2a6d805ce70a0e49 (patch)
tree1b88bd3abe8d8df0e124b9904cf5c0c457bc92fc
parentdev-qt/qtsql: switch to dev-db/oracle-instantclient (diff)
downloadqt-d02583b11829e18ffbba099b2a6d805ce70a0e49.tar.gz
qt-d02583b11829e18ffbba099b2a6d805ce70a0e49.tar.bz2
qt-d02583b11829e18ffbba099b2a6d805ce70a0e49.zip
lxqt-base/liblxqt: add 'ewarn' and make USE="policykit" the default
This is to stress the fact that upstream indeed doesn't support such a build at this time. Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/liblxqt/liblxqt-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/lxqt-base/liblxqt/liblxqt-9999.ebuild b/lxqt-base/liblxqt/liblxqt-9999.ebuild
index 589d9054..ed0e5b98 100644
--- a/lxqt-base/liblxqt/liblxqt-9999.ebuild
+++ b/lxqt-base/liblxqt/liblxqt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ fi
LICENSE="LGPL-2.1+ BSD"
SLOT="0/$(ver_cut 1-2)"
-IUSE="policykit"
+IUSE="+policykit"
RDEPEND="
>=dev-libs/libqtxdg-3.0.0
@@ -48,3 +48,10 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ if ! use policykit; then
+ ewarn "Please do not report issues caused by USE=\"-policykit\" to upstream,"
+ ewarn "as they do not support such a build at this time."
+ fi
+}