aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-10-29 02:47:42 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-29 03:12:44 +1100
commit3e8f92f3984df2929fb4595cf7680c60693c7ac8 (patch)
tree72212a2dec8b2c2fc2d1bc1b3da2663ae496b8ce /dev-python
parentdev-qt/qtchooser: EAPI 6 (diff)
downloadqt-3e8f92f3984df2929fb4595cf7680c60693c7ac8.tar.gz
qt-3e8f92f3984df2929fb4595cf7680c60693c7ac8.tar.bz2
qt-3e8f92f3984df2929fb4595cf7680c60693c7ac8.zip
dev-python/shiboken: follow upstream changes
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shiboken/shiboken-9999.ebuild37
1 files changed, 15 insertions, 22 deletions
diff --git a/dev-python/shiboken/shiboken-9999.ebuild b/dev-python/shiboken/shiboken-9999.ebuild
index fd339bdf..d04a967b 100644
--- a/dev-python/shiboken/shiboken-9999.ebuild
+++ b/dev-python/shiboken/shiboken-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit cmake-utils multilib python-r1 git-r3
+inherit cmake-utils python-r1 git-r3
DESCRIPTION="A tool for creating Python bindings for C++ libraries"
HOMEPAGE="https://wiki.qt.io/Pyside"
@@ -18,31 +18,28 @@ EGIT_REPO_URI=(
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-
IUSE="test"
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
dev-libs/libxml2
dev-libs/libxslt
- dev-qt/qtcore:4
- dev-qt/qtxmlpatterns:4
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+ dev-qt/qtxmlpatterns:5
"
DEPEND="${RDEPEND}
test? (
- dev-qt/qtgui:4
- dev-qt/qttest:4
- )"
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ )
+"
-DOCS=( AUTHORS ChangeLog )
+DOCS=( AUTHORS )
src_prepare() {
- # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
- # caused by the usage of a different version suffix with python >= 3.2
- sed -i -e "/get_config_var('SOABI')/d" \
- cmake/Modules/FindPython3InterpWithDebug.cmake || die
-
if use prefix; then
cp "${FILESDIR}"/rpath.cmake . || die
sed -i -e '1iinclude(rpath.cmake)' CMakeLists.txt || die
@@ -54,18 +51,14 @@ src_prepare() {
src_configure() {
configuration() {
local mycmakeargs=(
- $(cmake-utils_use_build test TESTS)
+ -DBUILD_TESTS=$(usex test)
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
- -DPYTHON_SUFFIX="-${EPYTHON}"
)
if [[ ${EPYTHON} == python3* ]]; then
mycmakeargs+=(
- -DUSE_PYTHON3=ON
- -DPYTHON3_EXECUTABLE="${PYTHON}"
- -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON3_LIBRARY="$(python_get_library_path)"
+ -DUSE_PYTHON_VERSION=3
)
fi
@@ -85,7 +78,7 @@ src_test() {
src_install() {
installation() {
cmake-utils_src_install
- mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}2{,-${EPYTHON}}.pc || die
}
python_foreach_impl installation
}