aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-09-16 08:23:26 -0700
committerMatt Turner <mattst88@gentoo.org>2018-09-16 08:23:26 -0700
commitf2398d0b731cfbfddacdf90ce62a57b81f8607ec (patch)
treef54dd446e759cfcd7b8a74184b40dc07b978028b
parentcatalyst-auto: Build ppc64 stages from stage{1,3}.spec (diff)
downloadreleng-f2398d0b731cfbfddacdf90ce62a57b81f8607ec.tar.gz
releng-f2398d0b731cfbfddacdf90ce62a57b81f8607ec.tar.bz2
releng-f2398d0b731cfbfddacdf90ce62a57b81f8607ec.zip
catalyst-auto: Build ppc and ppc64 stages from catalyst-auto-ppc.conf
-rw-r--r--tools/catalyst-auto-ppc.conf20
1 files changed, 15 insertions, 5 deletions
diff --git a/tools/catalyst-auto-ppc.conf b/tools/catalyst-auto-ppc.conf
index c5d09d09..656ee88d 100644
--- a/tools/catalyst-auto-ppc.conf
+++ b/tools/catalyst-auto-ppc.conf
@@ -1,14 +1,14 @@
# This is the config file for the catalyst-auto script. It should be pretty
# self-explanatory.
-SPECS_DIR=${REPO_DIR}/releases/weekly/specs/ppc/ppc32
+SPECS_DIR=${REPO_DIR}/releases/weekly/specs/ppc
-SPECS="stage1.spec stage3.spec"
+SPECS="ppc32/stage1.spec ppc32/stage3.spec ppc64/stage1.spec ppc64/stage3.spec"
#SPECS="${SPECS} installcd-stage1.spec installcd-stage2-minimal.spec"
#SPECS="${SPECS} stage2-desktop.spec stage3-desktop.spec"
#SPECS="${SPECS} livecd-stage1.spec livecd-stage2.spec"
-OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
+OPTIONAL_SPECS="ppc/installcd-stage1.spec ppc/installcd-stage2-minimal.spec"
KCONFIG_DIR=${REPO_DIR}/releases/weekly/kconfig/powerpc
@@ -36,12 +36,16 @@ convert_filename() {
update_symlinks() {
# Symlink the latest stages3 to build from
local d f
- for d in "${BUILD_SRCDIR_BASE}/builds/default/ppc" ; do
+ for d in "${BUILD_SRCDIR_BASE}/builds/default" ; do
pushd "${d}" >/dev/null
for f in $(ls stage3-ppc-*xz | grep -v latest | give_latest_from_dates) ; do
local of=$(echo "${f}" | convert_filename)
ln -sf "${f}" "${of}"
done
+ for f in $(ls stage3-ppc64-*xz | grep -v latest | give_latest_from_dates) ; do
+ local of=$(echo "${f}" | convert_filename)
+ ln -sf "${f}" "${of}"
+ done
popd >/dev/null
done
}
@@ -56,9 +60,15 @@ post_build() {
pushd "${BUILD_SRCDIR_BASE}/builds/default" >/dev/null
case ${spec} in
- stage3.spec)
+ ppc/installcd-stage2-minimal.spec)
+ upload *${TIMESTAMP}*.iso*
+ ;;
+ ppc/stage3.spec)
upload stage3-ppc-*${TIMESTAMP}*.xz*
;;
+ ppc64/stage3.spec)
+ upload stage3-ppc64-*${TIMESTAMP}*.xz*
+ ;;
esac
popd >/dev/null