aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-04-29 11:20:28 -0700
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-05-29 20:04:01 +0000
commit395488a78769ecd976a9f5fca0660e79745772be (patch)
treef9940ed2b5958a08106649352e014dc08b130234
parenttools: Add a config that filters to stage4 only. (diff)
downloadreleng-395488a78769ecd976a9f5fca0660e79745772be.tar.gz
releng-395488a78769ecd976a9f5fca0660e79745772be.tar.bz2
releng-395488a78769ecd976a9f5fca0660e79745772be.zip
catalyst-auto: Record how long the catalyst runs take.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rwxr-xr-xtools/catalyst-auto6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/catalyst-auto b/tools/catalyst-auto
index 823b9f2c..b928ac98 100755
--- a/tools/catalyst-auto
+++ b/tools/catalyst-auto
@@ -306,7 +306,7 @@ for a in "" ${SETS}; do
for i in ${!specs_var}; do
LOGFILE="${TMPDIR}/log/$(echo "${i}" | sed -e 's:/:_:' -e 's:\.spec$::').log"
- run_cmd "catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
+ run_cmd "time catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
if [ $? != 0 ]; then
build_failure=1
send_email "Catalyst fatal build error - ${i}" "" "${LOGFILE}"
@@ -316,7 +316,7 @@ for a in "" ${SETS}; do
for i in ${!optional_specs_var}; do
LOGFILE="${TMPDIR}/log/$(echo "${i}" | sed -e 's:/:_:' -e 's:\.spec$::').log"
- run_cmd "catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
+ run_cmd "time catalyst -a -p -c ${CATALYST_CONFIG} -f ${i}" ${LOGFILE}
if [ $? != 0 ]; then
build_failure=1
send_email "Catalyst non-fatal build error - ${i}" "" "${LOGFILE}"
@@ -326,7 +326,7 @@ for a in "" ${SETS}; do
for i in ${!specs_var} ${!optional_specs_var}; do
LOGFILE="${TMPDIR}/log/$(echo "${i}" | sed -e 's:/:_:' -e 's:\.spec$::')_purge.log"
- run_cmd "catalyst -P -c ${CATALYST_CONFIG} -f ${i}" "${LOGFILE}"
+ run_cmd "time catalyst -P -c ${CATALYST_CONFIG} -f ${i}" "${LOGFILE}"
done
done