summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-01-22 20:58:14 +0000
committerJim Ramsay <lack@gentoo.org>2008-01-22 20:58:14 +0000
commit03c3e80ad20c6495d84349d0b181e14d75d1e7b3 (patch)
tree69f355303628384b4c8465a739bc2d330afc29e1 /dev-python/gnome-python-desktop
parentUpdated rox-all with all current software (diff)
downloadrox-03c3e80ad20c6495d84349d0b181e14d75d1e7b3.tar.gz
rox-03c3e80ad20c6495d84349d0b181e14d75d1e7b3.tar.bz2
rox-03c3e80ad20c6495d84349d0b181e14d75d1e7b3.zip
Adding all the individual bindings for dev-python/gnome-python-desktop as their own packages
svn path=/trunk/overlay/; revision=23
Diffstat (limited to 'dev-python/gnome-python-desktop')
-rw-r--r--dev-python/gnome-python-desktop/Manifest3
-rw-r--r--dev-python/gnome-python-desktop/files/gnome-python-desktop-2.20.0-split.patch355
-rw-r--r--dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0-r1.ebuild35
-rw-r--r--dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild62
4 files changed, 455 insertions, 0 deletions
diff --git a/dev-python/gnome-python-desktop/Manifest b/dev-python/gnome-python-desktop/Manifest
new file mode 100644
index 0000000..321ad90
--- /dev/null
+++ b/dev-python/gnome-python-desktop/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-python-desktop-2.20.0.tar.bz2 440199 RMD160 729d9af9107c799843d396708690d89fd821b474 SHA1 9de5c7fb6d08752fbea7cb5fca51f1b709616f75 SHA256 32e2f5f4d3e79157a83cb7a1c6c409bc2fef75178f9626b2d83a1fd1c2ee4a8d
+EBUILD gnome-python-desktop-2.20.0-r1.ebuild 1586 RMD160 e818b467974be33ad8c3743bf558906f457c40df SHA1 a994b611887174ec6ba24166113ca16ae61af88c SHA256 592055e7692bf1692e39af59eb92f90e7b9b6df9b57a18bb248fea718b922c9d
+EBUILD gnome-python-desktop-2.20.0.ebuild 1586 RMD160 e818b467974be33ad8c3743bf558906f457c40df SHA1 a994b611887174ec6ba24166113ca16ae61af88c SHA256 592055e7692bf1692e39af59eb92f90e7b9b6df9b57a18bb248fea718b922c9d
diff --git a/dev-python/gnome-python-desktop/files/gnome-python-desktop-2.20.0-split.patch b/dev-python/gnome-python-desktop/files/gnome-python-desktop-2.20.0-split.patch
new file mode 100644
index 0000000..004d4e6
--- /dev/null
+++ b/dev-python/gnome-python-desktop/files/gnome-python-desktop-2.20.0-split.patch
@@ -0,0 +1,355 @@
+diff -ru gnome-python-desktop-2.20.0.orig/configure.ac gnome-python-desktop-2.20.0/configure.ac
+--- gnome-python-desktop-2.20.0.orig/configure.ac 2007-09-16 08:35:54.000000000 -0400
++++ gnome-python-desktop-2.20.0/configure.ac 2008-01-16 13:18:33.000000000 -0500
+@@ -45,6 +45,18 @@
+ AC_DEFINE(GNOME_PYTHON_DESKTOP_MICRO_VERSION, gnome_python_desktop_micro_version,
+ [Gnome-Python-Desktop macro version])
+
++dnl AC_ARG_BINDING(NAME, DEFAULT [, MODULENAME])
++AC_DEFUN(AC_ARG_BINDING,
++[AC_ARG_ENABLE([$1],
++ AC_HELP_STRING([--ifelse([$2], [YES], dis, en)able-[$1]],
++ [build ifelse([$3], , [$1], [$3]) bindings (default is [$2])]),
++ [if test "$enable_[$1]" = "yes"; then
++ build_[$1]=true
++ else
++ build_[$1]=false
++ fi])
++])
++
+ GNOME_COMMON_INIT
+
+ AC_DISABLE_STATIC
+@@ -104,29 +116,60 @@
+ GTK_LIBS=`echo $GTK_LIBS | sed -e "s/$export_dynamic//"`
+ fi
+
++AC_ARG_ENABLE([gtk-doc],
++ AC_HELP_STRING([--disable-gtk-doc],
++ [Disables gtk-doc documentation generation]),,
++ [enable_gtk_doc="yes"])
++AM_CONDITIONAL(BUILD_DOCS, [test "$enable_gtk_doc" = "yes"])
++
++dnl default bindings to build:
++default_bindings_on="applet gnomeprint gnomeprintui gtksourceview wnck totem_plparser gtop nautilusburn mediaprofiles rsvg gnomekeyring gnomedesktop bugbuddy metacity"
++default_bindings_off="metacity"
++default_bindings_all="$default_bindings_on $default_bindings_off"
++
++AC_ARG_ENABLE([allbindings],
++ AC_HELP_STRING([--disable-allbindings],
++ [Changes all the bindings default values to be either enabled or disabled, overridden by any explicit bindings on the commandline.]),
++ [if test "$enable_allbindings" = "no"; then
++ default_bindings_off="$default_bindings_all"
++ default_bindings_on=""
++ else
++ default_bindings_off=""
++ default_bindings_on="$default_bindings_all"
++ fi])
++for binding in $default_bindings_on; do
++ eval build_$binding=true
++done
++for binding in $default_bindings_off; do
++ eval build_$binding=false
++done
+
+ dnl should we build the gnome.applet module?
+-build_applet=false
+-PKG_CHECK_MODULES(LIBPANELAPPLET, [libpanelapplet-2.0 >= libpanelapplet_required_version
+- gnome-python-2.0 >= gnome_python_required_version],
+- build_applet=true,
+- build_applet=false)
++AC_ARG_BINDING([applet],[YES],[gnome.applet])
++if $build_applet; then
++ PKG_CHECK_MODULES(LIBPANELAPPLET, [libpanelapplet-2.0 >= libpanelapplet_required_version
++ gnome-python-2.0 >= gnome_python_required_version],
++ build_applet=true,
++ build_applet=false)
++fi
+ AC_SUBST(LIBPANELAPPLET_CFLAGS)
+ AC_SUBST(LIBPANELAPPLET_LIBS)
+-AM_CONDITIONAL(BUILD_APPLET, $build_applet)
+ if test -n "$export_dynamic"; then
+ LIBPANELAPPLET_LIBS=`echo $LIBPANELAPPLET_LIBS | sed -e "s/$export_dynamic//"`
+ fi
++AM_CONDITIONAL(BUILD_APPLET, $build_applet)
+
+
+
+
+ dnl should we build the gnomeprint module?
+-build_gnomeprint=false
+-PKG_CHECK_MODULES(LIBGNOMEPRINT, [libgnomeprint-2.2 >= libgnomeprint_required_version
+- gnome-python-2.0 >= gnome_python_required_version],
+- build_gnomeprint=true,
+- build_gnomeprint=false)
++AC_ARG_BINDING([gnomeprint],[YES])
++if $build_gnomeprint; then
++ PKG_CHECK_MODULES(LIBGNOMEPRINT, [libgnomeprint-2.2 >= libgnomeprint_required_version
++ gnome-python-2.0 >= gnome_python_required_version],
++ build_gnomeprint=true,
++ build_gnomeprint=false)
++fi
+ AC_SUBST(LIBGNOMEPRINT_CFLAGS)
+ AC_SUBST(LIBGNOMEPRINT_LIBS)
+ AM_CONDITIONAL(BUILD_GNOMEPRINT, $build_gnomeprint)
+@@ -146,11 +189,13 @@
+ AC_SUBST(PYGNOMEPRINT_DEFS)
+
+ dnl should we build the gnomeprint.ui module?
+-build_gnomeprintui=false
+-PKG_CHECK_MODULES(LIBGNOMEPRINTUI, [libgnomeprintui-2.2 >= libgnomeprintui_required_version,
+- gnome-python-2.0 >= gnome_python_required_version],
+- build_gnomeprintui=true,
+- build_gnomeprintui=false)
++AC_ARG_BINDING([gnomeprintui],[YES],[gnomeprint.ui])
++if $build_gnomeprintui; then
++ PKG_CHECK_MODULES(LIBGNOMEPRINTUI, [libgnomeprintui-2.2 >= libgnomeprintui_required_version,
++ gnome-python-2.0 >= gnome_python_required_version],
++ build_gnomeprintui=true,
++ build_gnomeprintui=false)
++fi
+ AC_SUBST(LIBGNOMEPRINTUI_CFLAGS)
+ AC_SUBST(LIBGNOMEPRINTUI_LIBS)
+ AM_CONDITIONAL(BUILD_GNOMEPRINTUI, $build_gnomeprintui)
+@@ -159,10 +204,12 @@
+ fi
+
+ dnl should we build the gtksourceview module?
+-build_gtksourceview=false
+-PKG_CHECK_MODULES(GTKSOURCEVIEW, gtksourceview-1.0 >= gtksourceview_required_version,
+- build_gtksourceview=true,
+- build_gtksourceview=false)
++AC_ARG_BINDING([gtksourceview],[YES])
++if $build_gtksourceview; then
++ PKG_CHECK_MODULES(GTKSOURCEVIEW, gtksourceview-1.0 >= gtksourceview_required_version,
++ build_gtksourceview=true,
++ build_gtksourceview=false)
++fi
+ AM_CONDITIONAL(BUILD_GTKSOURCEVIEW, $build_gtksourceview)
+ if test -n "$export_dynamic"; then
+ GTKSOURCEVIEW_LIBS=`echo $GTKSOURCEVIEW_LIBS | sed -e "s/$export_dynamic//"`
+@@ -170,43 +217,50 @@
+
+
+ dnl should we build the wnck module
+-build_wnck=false
+-PKG_CHECK_MODULES(WNCK, libwnck-1.0 >= wnck_required_version,
+- build_wnck=true,
+- build_wnck=false)
+-AM_CONDITIONAL(BUILD_WNCK, $build_wnck)
++AC_ARG_BINDING([wnck],[YES])
++if $build_wnck; then
++ PKG_CHECK_MODULES(WNCK, libwnck-1.0 >= wnck_required_version,
++ build_wnck=true,
++ build_wnck=false)
++fi
+ if test -n "$export_dynamic"; then
+ WNCK_LIBS=`echo $WNCK_LIBS | sed -e "s/$export_dynamic//"`
+ fi
+-
++AM_CONDITIONAL(BUILD_WNCK, $build_wnck)
+
+
+ dnl should we build the totem.plparser module?
+-build_totem_plparser=false
+-PKG_CHECK_MODULES(TOTEM_PLPARSER, [totem-plparser >= totem_required_version pygtk-2.0 >= pygtk_required_version],
+- build_totem_plparser=true,
+- build_totem_plparser=false)
++AC_ARG_BINDING([totem_plparser],[YES],[totem.plparser])
++if $build_totem_plparser; then
++ PKG_CHECK_MODULES(TOTEM_PLPARSER, [totem-plparser >= totem_required_version pygtk-2.0 >= pygtk_required_version],
++ build_totem_plparser=true,
++ build_totem_plparser=false)
++fi
+ AM_CONDITIONAL(BUILD_TOTEM_PLPARSER, $build_totem_plparser)
+ if test -n "$export_dynamic"; then
+ TOTEM_PLPARSER_LIBS=`echo $TOTEM_PLPARSER_LIBS | sed -e "s/$export_dynamic//"`
+ fi
+
+ dnl should we build the gtop module?
+-build_gtop=false
+-PKG_CHECK_MODULES(GTOP, [libgtop-2.0 >= libgtop_required_version pygtk-2.0 >= pygtk_required_version],
+- build_gtop=true,
+- build_gtop=false)
++AC_ARG_BINDING([gtop],[YES])
++if $build_gtop; then
++ PKG_CHECK_MODULES(GTOP, [libgtop-2.0 >= libgtop_required_version pygtk-2.0 >= pygtk_required_version],
++ build_gtop=true,
++ build_gtop=false)
++fi
+ AM_CONDITIONAL(BUILD_GTOP, $build_gtop)
+ if test -n "$export_dynamic"; then
+ GTOP_LIBS=`echo $GTOP_LIBS | sed -e "s/$export_dynamic//"`
+ fi
+
+ dnl should we build the nautilusburn module?
+-build_nautilusburn=false
+-PKG_CHECK_MODULES(NAUTILUSBURN, [libnautilus-burn >= libnautilus_burn_required_version
+- pygtk-2.0 >= pygtk_required_version],
+- build_nautilusburn=true,
+- build_nautilusburn=false)
++AC_ARG_BINDING([nautilusburn],[YES])
++if $build_nautilusburn; then
++ PKG_CHECK_MODULES(NAUTILUSBURN, [libnautilus-burn >= libnautilus_burn_required_version
++ pygtk-2.0 >= pygtk_required_version],
++ build_nautilusburn=true,
++ build_nautilusburn=false)
++fi
+ AM_CONDITIONAL(BUILD_NAUTILUSBURN, $build_nautilusburn)
+ if test -n "$export_dynamic"; then
+ NAUTILUSBURN_LIBS=`echo $NAUTILUSBURN_LIBS | sed -e "s/$export_dynamic//"`
+@@ -214,24 +268,28 @@
+
+
+ dnl should we build the mediaprofiles module?
+-build_mediaprofiles=false
+-PKG_CHECK_MODULES(MEDIAPROFILES, [gnome-media-profiles >= mediaprofiles_required_version
+- pygtk-2.0 >= pygtk_required_version
+- gconf-2.0 >= gconf_required_version],
+- build_mediaprofiles=true,
+- build_mediaprofiles=false)
++AC_ARG_BINDING([mediaprofiles],[YES])
++if $build_mediaprofiles; then
++ PKG_CHECK_MODULES(MEDIAPROFILES, [gnome-media-profiles >= mediaprofiles_required_version
++ pygtk-2.0 >= pygtk_required_version
++ gconf-2.0 >= gconf_required_version],
++ build_mediaprofiles=true,
++ build_mediaprofiles=false)
++fi
+ AM_CONDITIONAL(BUILD_MEDIAPROFILES, $build_mediaprofiles)
+ if test -n "$export_dynamic"; then
+ MEDIAPROFILES_LIBS=`echo $MEDIAPROFILES_LIBS | sed -e "s/$export_dynamic//"`
+ fi
+
+ dnl should we build the rsvg module?
+-build_rsvg=false
+-PKG_CHECK_MODULES(RSVG, [librsvg-2.0 >= rsvg_required_version
+- pycairo
+- pygtk-2.0 >= pygtk_required_version],
+- build_rsvg=true,
+- build_rsvg=false)
++AC_ARG_BINDING([rsvg],[YES])
++if $build_rsvg; then
++ PKG_CHECK_MODULES(RSVG, [librsvg-2.0 >= rsvg_required_version
++ pycairo
++ pygtk-2.0 >= pygtk_required_version],
++ build_rsvg=true,
++ build_rsvg=false)
++fi
+ AM_CONDITIONAL(BUILD_RSVG, $build_rsvg)
+ if test -n "$export_dynamic"; then
+ RSVG_LIBS=`echo $RSVG_LIBS | sed -e "s/$export_dynamic//"`
+@@ -239,10 +297,7 @@
+
+
+ dnl should we build the metacity module
+-AC_ARG_ENABLE([metacity],
+- AC_HELP_STRING([--enable-metacity],
+- [build metacity bindings (default is NO)]),
+- [build_metacity=true], [build_metacity=false])
++AC_ARG_BINDING([metacity],[NO])
+ if $build_metacity; then
+ PKG_CHECK_MODULES(METACITY, libmetacity-private >= metacity_required_version,
+ build_metacity=true,
+@@ -254,39 +309,45 @@
+ AM_CONDITIONAL(BUILD_METACITY, $build_metacity)
+
+ dnl should we build the gnomekeyring module
+-build_gnomekeyring=false
+-PKG_CHECK_MODULES(GNOMEKEYRING, [gnome-keyring-1 >= gnomekeyring_required_version
+- gobject-2.0 >= glib_required_version],
+- build_gnomekeyring=true,
+- build_gnomekeyring=false)
++AC_ARG_BINDING([gnomekeyring],[YES])
++if $build_gnomekeyring; then
++ PKG_CHECK_MODULES(GNOMEKEYRING, [gnome-keyring-1 >= gnomekeyring_required_version
++ gobject-2.0 >= glib_required_version],
++ build_gnomekeyring=true,
++ build_gnomekeyring=false)
++fi
+ AM_CONDITIONAL(BUILD_GNOMEKEYRING, $build_gnomekeyring)
+ if test -n "$export_dynamic"; then
+ GNOMEKEYRING_LIBS=`echo $GNOMEKEYRING_LIBS | sed -e "s/$export_dynamic//"`
+ fi
+
+ dnl should we build the gnomekeyring module
+-build_gnomedesktop=false
+-PKG_CHECK_MODULES(GNOMEDESKTOP, [gnome-desktop-2.0 >= gnomedesktop_required_version
+- pygobject-2.0],
+- build_gnomedesktop=true,
+- build_gnomedesktop=false)
++AC_ARG_BINDING([gnomedesktop],[YES])
++if $build_gnomedesktop; then
++ PKG_CHECK_MODULES(GNOMEDESKTOP, [gnome-desktop-2.0 >= gnomedesktop_required_version
++ pygobject-2.0],
++ build_gnomedesktop=true,
++ build_gnomedesktop=false)
++fi
+ AM_CONDITIONAL(BUILD_GNOMEDESKTOP, $build_gnomedesktop)
+ if test -n "$export_dynamic"; then
+ GNOMEDESKTOP_LIBS=`echo $GNOMEDESKTOP_LIBS | sed -e "s/$export_dynamic//"`
+ fi
+
+ dnl Check for bug-buddy
+-build_bugbuddy=false
+-AC_PATH_PROG(BUG_BUDDY, bug-buddy)
+-if test "x$BUG_BUDDY" != "x"; then
+- AC_MSG_CHECKING([whether bug-buddy >= 2.16])
+- if $BUG_BUDDY --version | $PYTHON -c ["import sys; sys.exit([int(s) for s in sys.stdin.read().split()[2].split('.')] < [2,16])"]; then
+- AC_MSG_RESULT([yes])
+- build_bugbuddy=true
+- else
+- AC_MSG_RESULT([no])
+- build_bugbuddy=false
+- fi
++AC_ARG_BINDING([bugbuddy],[YES])
++if $build_bugbuddy; then
++ AC_PATH_PROG(BUG_BUDDY, bug-buddy)
++ if test "x$BUG_BUDDY" != "x"; then
++ AC_MSG_CHECKING([whether bug-buddy >= 2.16])
++ if $BUG_BUDDY --version | $PYTHON -c ["import sys; sys.exit([int(s) for s in sys.stdin.read().split()[2].split('.')] < [2,16])"]; then
++ AC_MSG_RESULT([yes])
++ build_bugbuddy=true
++ else
++ AC_MSG_RESULT([no])
++ build_bugbuddy=false
++ fi
++ fi
+ fi
+ AM_CONDITIONAL(BUILD_BUGBUDDY, $build_bugbuddy)
+
+diff -ru gnome-python-desktop-2.20.0.orig/docs/Makefile.am gnome-python-desktop-2.20.0/docs/Makefile.am
+--- gnome-python-desktop-2.20.0.orig/docs/Makefile.am 2007-09-15 16:44:56.000000000 -0400
++++ gnome-python-desktop-2.20.0/docs/Makefile.am 2008-01-16 12:54:38.000000000 -0500
+@@ -1,5 +1,16 @@
+ EXTRA_DIST = common.xsl html.xsl ref-html-style.xsl tut-html-style.xsl \
+ pdf-style.xsl pdf.xsl devhelp.xsl pygtk-ref-docs.make
+
+-SUBDIRS = gtksourceview gnomeprint gnomeprintui
++SUBDIRS=
+
++if BUILD_GTKSOURCEVIEW
++ SUBDIRS += gtksourceview
++endif
++
++if BUILD_GNOMEPRINT
++ SUBDIRS += gnomeprint
++endif
++
++if BUILD_GNOMEPRINTUI
++ SUBDIRS += gnomeprintui
++endif
+diff -ru gnome-python-desktop-2.20.0.orig/Makefile.am gnome-python-desktop-2.20.0/Makefile.am
+--- gnome-python-desktop-2.20.0.orig/Makefile.am 2007-09-15 16:44:57.000000000 -0400
++++ gnome-python-desktop-2.20.0/Makefile.am 2008-01-16 12:56:51.000000000 -0500
+@@ -1,5 +1,9 @@
+
+-SUBDIRS = docs
++SUBDIRS=
++
++if BUILD_DOCS
++ SUBDIRS += docs
++endif
+
+ if BUILD_GNOMEPRINT
+ SUBDIRS += gnomeprint
diff --git a/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0-r1.ebuild b/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0-r1.ebuild
new file mode 100644
index 0000000..ff5988c
--- /dev/null
+++ b/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome-python-desktop
+
+MY_BINDING="gnomedesktop"
+DESCRIPTION="META build which provides python interfacing modules for some GNOME desktop libraries"
+HOMEPAGE="http://pygtk.org/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="metacity"
+
+RDEPEND="=dev-python/gnome-desktop-applet-${PV}*
+ =dev-python/gnome-desktop-gnomeprint-${PV}*
+ =dev-python/gnome-desktop-gnomeprintui-${PV}*
+ =dev-python/gnome-desktop-gtksourceview-${PV}*
+ =dev-python/gnome-desktop-wnck-${PV}*
+ =dev-python/gnome-desktop-totem_plparser-${PV}*
+ =dev-python/gnome-desktop-gtop-${PV}*
+ =dev-python/gnome-desktop-nautilusburn-${PV}*
+ =dev-python/gnome-desktop-mediaprofiles-${PV}*
+ =dev-python/gnome-desktop-rsvg-${PV}*
+ metacity? ( =dev-python/gnome-desktop-metacity-${PV}* )
+ =dev-python/gnome-desktop-gnomekeyring-${PV}*
+ =dev-python/gnome-desktop-bugbuddy-${PV}*"
+
+DEPEND=">=gnome-base/gnome-desktop-2.10.0"
+
+src_install() {
+ KEEP_PKGCONFIG="yes"
+ gnome-python-desktop_src_install
+}
diff --git a/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild b/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild
new file mode 100644
index 0000000..b609dec
--- /dev/null
+++ b/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild,v 1.8 2008/01/10 09:45:23 vapier Exp $
+
+inherit gnome2 python virtualx
+
+DESCRIPTION="provides python interfacing modules for some GNOME desktop libraries"
+HOMEPAGE="http://pygtk.org/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10.3
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.4.0
+ >=dev-python/gnome-python-2.10.0
+ >=gnome-base/gnome-panel-2.13.4
+ >=gnome-base/libgnomeprint-2.2.0
+ >=gnome-base/libgnomeprintui-2.2.0
+ =x11-libs/gtksourceview-1*
+ >=x11-libs/libwnck-2.19.3
+ >=gnome-base/libgtop-2.13.0
+ >=gnome-extra/nautilus-cd-burner-2.15.3
+ >=gnome-extra/gnome-media-2.10.0
+ >=gnome-base/gconf-2.10.0
+ >=x11-wm/metacity-2.19.8
+ dev-python/pycairo
+ >=gnome-base/librsvg-2.13.93
+ >=gnome-base/gnome-keyring-0.5.0
+ >=gnome-base/gnome-desktop-2.10.0
+ >=media-video/totem-1.4.0
+ !<dev-python/gnome-python-extras-2.13"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+DOCS="AUTHORS ChangeLog INSTALL MAINTAINERS NEWS README"
+
+src_test() {
+ Xmake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize "${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}