summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-01-22 21:14:25 +0000
committerJim Ramsay <lack@gentoo.org>2008-01-22 21:14:25 +0000
commit58f2d41f8f6416b6f92788cd9b92b77cad319408 (patch)
tree2db04e63fbd1a33bde7db57acd2f4a0688a93491 /rox-base
parentAdding all the individual bindings for dev-python/gnome-python-desktop as the... (diff)
downloadrox-58f2d41f8f6416b6f92788cd9b92b77cad319408.tar.gz
rox-58f2d41f8f6416b6f92788cd9b92b77cad319408.tar.bz2
rox-58f2d41f8f6416b6f92788cd9b92b77cad319408.zip
Adding some new rox-utilities... Perhaps some day these will make the real tree?
svn path=/trunk/overlay/; revision=24
Diffstat (limited to 'rox-base')
-rw-r--r--rox-base/rox-appearance/Manifest2
-rw-r--r--rox-base/rox-appearance/rox-appearance-0.8.0.ebuild28
-rw-r--r--rox-base/rox-font/Manifest2
-rw-r--r--rox-base/rox-font/rox-font-0.9.1.ebuild19
-rw-r--r--rox-base/rox-keyboard/Manifest2
-rw-r--r--rox-base/rox-keyboard/rox-keyboard-0.11.ebuild28
-rw-r--r--rox-base/rox-mouse/Manifest2
-rw-r--r--rox-base/rox-mouse/rox-mouse-0.10.ebuild28
-rw-r--r--rox-base/rox-time/Manifest2
-rw-r--r--rox-base/rox-time/rox-time-0.0.3.ebuild21
10 files changed, 134 insertions, 0 deletions
diff --git a/rox-base/rox-appearance/Manifest b/rox-base/rox-appearance/Manifest
new file mode 100644
index 0000000..9a0bd72
--- /dev/null
+++ b/rox-base/rox-appearance/Manifest
@@ -0,0 +1,2 @@
+DIST appearance-0.8.0.tar.bz2 25012 RMD160 bce99fbbbb2ec3578eb463ad507c7a04dde958de SHA1 e441013736748a88ba5254622ce3ca0be306a410 SHA256 0d5f166a395c8d0376c39ec83511734bb95ca0cc6a75c74f043905967dfbbe5b
+EBUILD rox-appearance-0.8.0.ebuild 587 RMD160 6ba8045e1f5e4bd5b697163431d09557a8b0466b SHA1 6e41fcf5cc9b43ad4fd84585d130bbf1198f65d4 SHA256 f5b0f84c9df295182060837d584aff50d66a6c860e4c56ffe2972a3944db2106
diff --git a/rox-base/rox-appearance/rox-appearance-0.8.0.ebuild b/rox-base/rox-appearance/rox-appearance-0.8.0.ebuild
new file mode 100644
index 0000000..7528442
--- /dev/null
+++ b/rox-base/rox-appearance/rox-appearance-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/mime-editor/mime-editor-0.5-r2.ebuild,v 1.3 2008/01/01 14:36:42 josejx Exp $
+
+ROX_LIB_VER="2.0.4-r1"
+inherit rox-0install
+
+MY_PN="appearance"
+DESCRIPTION="Appearance is a GTK and Icon theme configuration tool for ROX Desktop"
+HOMEPAGE="http://rox.sourceforge.net/desktop/"
+SRC_URI="mirror://sourceforge/rox/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APPNAME="Appearance"
+APPCATEGORY="System;Core"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ # This forces us to use 'python2.4' but we can trust that the 'python'
+ # executable is at least 2.4, and may even be 2.5 or later!
+ sed -i -e 's/python2.4/python/' "${S}/${APPNAME}/AppRun" || die "Could not patch python version"
+}
diff --git a/rox-base/rox-font/Manifest b/rox-base/rox-font/Manifest
new file mode 100644
index 0000000..441a91b
--- /dev/null
+++ b/rox-base/rox-font/Manifest
@@ -0,0 +1,2 @@
+DIST Font-0.9.1.tgz 14061 RMD160 8c37434fa5eab45f6618c822c4aa5865624e67e6 SHA1 703a8b78250eb1278a6f4dfe7fb5c7c6a08805ab SHA256 c4460a37fe4f9688114fdd86ab9c34826ce131c7ba04411eb4813d94608b2e11
+EBUILD rox-font-0.9.1.ebuild 577 RMD160 91699ce3d92c0dbcbbae31dcfba80eae7627fe70 SHA1 bedc8f80fb89b857c20ddcd3bda0ab2ed20186e0 SHA256 c9b8ce5a5b243f5e26c1a5e5539232177fac9fe8123c59a116de2452e7436850
diff --git a/rox-base/rox-font/rox-font-0.9.1.ebuild b/rox-base/rox-font/rox-font-0.9.1.ebuild
new file mode 100644
index 0000000..5b6c1b8
--- /dev/null
+++ b/rox-base/rox-font/rox-font-0.9.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/mime-editor/mime-editor-0.5-r2.ebuild,v 1.3 2008/01/01 14:36:42 josejx Exp $
+
+ROX_LIB_VER="2.0.4-r1"
+inherit rox-0install
+
+MY_PN="Font"
+DESCRIPTION="Font is a font selection and smoothing configuration tool for ROX Desktop"
+HOMEPAGE="http://rox.sourceforge.net/desktop/"
+SRC_URI="mirror://sourceforge/rox/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APPNAME=${MY_PN}
+APPCATEGORY="System;Core"
diff --git a/rox-base/rox-keyboard/Manifest b/rox-base/rox-keyboard/Manifest
new file mode 100644
index 0000000..0fd071b
--- /dev/null
+++ b/rox-base/rox-keyboard/Manifest
@@ -0,0 +1,2 @@
+DIST keyboard-0.11.tar.bz2 29945 RMD160 2a96b5086d91e9e8e46f150e189f0487d4cafc33 SHA1 7468b9fa343145ac96021c29bacba5f47be37ad8 SHA256 83caf93c47a17973aca4fb3eafbcab6472e0af9ac6c80b1905cd5d74e7a3db5d
+EBUILD rox-keyboard-0.11.ebuild 864 RMD160 0d740be68eef4ac5312f6fba01f1a78b1de7a12a SHA1 ab8e0dcf96ea3a0e203d211a2367ae53ee59fe22 SHA256 7df32d59388858c4392330d5b538a40884b9db68e4f9c3326ff7e2d63597718f
diff --git a/rox-base/rox-keyboard/rox-keyboard-0.11.ebuild b/rox-base/rox-keyboard/rox-keyboard-0.11.ebuild
new file mode 100644
index 0000000..8e26c00
--- /dev/null
+++ b/rox-base/rox-keyboard/rox-keyboard-0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/mime-editor/mime-editor-0.5-r2.ebuild,v 1.3 2008/01/01 14:36:42 josejx Exp $
+
+ROX_LIB_VER="2.0.4-r1"
+inherit rox-0install
+
+MY_PN="keyboard"
+DESCRIPTION="Mouse is a rodent configuration tool for ROX Desktop"
+HOMEPAGE="http://rox.sourceforge.net/desktop/Mouse"
+SRC_URI="mirror://sourceforge/rox/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APPNAME="Keyboard"
+APPCATEGORY="System;Core"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ # This forces us to use 'python2.4' but we can trust that the 'python'
+ # executable is at least 2.4, and may even be 2.5 or later!
+ sed -i -e 's/python2.4/python/' "${S}/${APPNAME}/AppRun" || die "Could not patch python version"
+}
diff --git a/rox-base/rox-mouse/Manifest b/rox-base/rox-mouse/Manifest
new file mode 100644
index 0000000..6fa140a
--- /dev/null
+++ b/rox-base/rox-mouse/Manifest
@@ -0,0 +1,2 @@
+DIST mouse-0.10.tar.bz2 27470 RMD160 7e699913ee2a35285df215db0791a7b030070220 SHA1 76e160664644d45c37ac12f3a79f62264f752f42 SHA256 96d7e4061e0ae482937d5d109adae1536649bb49dc980724744f852fa330d9ab
+EBUILD rox-mouse-0.10.ebuild 596 RMD160 e93bd1308694f005e7956fc2276ac769c7664ee6 SHA1 117c2164b5a2ffa38b3b90dd70e7848f4419d1c6 SHA256 123a318982b478ed33f242933779f6f8bb77b5f2e0457662023bb7a4a252c37e
diff --git a/rox-base/rox-mouse/rox-mouse-0.10.ebuild b/rox-base/rox-mouse/rox-mouse-0.10.ebuild
new file mode 100644
index 0000000..636563e
--- /dev/null
+++ b/rox-base/rox-mouse/rox-mouse-0.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/mime-editor/mime-editor-0.5-r2.ebuild,v 1.3 2008/01/01 14:36:42 josejx Exp $
+
+ROX_LIB_VER="2.0.4-r1"
+inherit rox-0install
+
+MY_PN="mouse"
+DESCRIPTION="Mouse is a rodent configuration tool for ROX Desktop"
+HOMEPAGE="http://rox.sourceforge.net/desktop/Mouse"
+SRC_URI="mirror://sourceforge/rox/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APPNAME="Mouse"
+APPCATEGORY="System;Core"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ # This forces us to use 'python2.4' but we can trust that the 'python'
+ # executable is at least 2.4, and may even be 2.5 or later!
+ sed -i -e 's/python2.4/python/' "${S}/${APPNAME}/AppRun" || die "Could not patch python version"
+}
diff --git a/rox-base/rox-time/Manifest b/rox-base/rox-time/Manifest
new file mode 100644
index 0000000..86965e0
--- /dev/null
+++ b/rox-base/rox-time/Manifest
@@ -0,0 +1,2 @@
+DIST Time-0.0.3.tgz 15975 RMD160 0ef6ac56f8ed9bc3d5b3bf4d0e1b56c206a55d0c SHA1 1069febf405323f7790eb10889a0a834f25e4846 SHA256 9c4236ba3df6acdcacff01966546927d73c265c3e0dc1d5fb9cb3d6aa34d9dc7
+EBUILD rox-time-0.0.3.ebuild 582 RMD160 f68bc53efc1bfe64270537d668e0cf2c73f6d0b9 SHA1 a428490bfd62f69baa63287b053f8d4ce293a82e SHA256 105e9a1ec2dca591b04a809ceeb11972b8fd4b3744c86b564c3e2aef0bd11c8f
diff --git a/rox-base/rox-time/rox-time-0.0.3.ebuild b/rox-base/rox-time/rox-time-0.0.3.ebuild
new file mode 100644
index 0000000..38de825
--- /dev/null
+++ b/rox-base/rox-time/rox-time-0.0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/devtray/devtray-0.3.2-r1.ebuild,v 1.1 2007/11/28 20:04:52 lack Exp $
+
+ROX_LIB_VER="2.0.4-r1"
+inherit rox-0install
+
+MY_PN="Time"
+DESCRIPTION="Time is a utility to set the date and time."
+HOMEPAGE="http://rox4debian.berlios.de"
+SRC_URI="ftp://ftp.berlios.de/pub/rox4debian/apps/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/system-tools-backends"
+
+APPNAME="${MY_PN}"
+S="${WORKDIR}"