summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--rox-extra/edit/edit-2.0-r2.ebuild29
-rw-r--r--rox-extra/edit/files/Edit-2.0.xml19
2 files changed, 48 insertions, 0 deletions
diff --git a/rox-extra/edit/edit-2.0-r2.ebuild b/rox-extra/edit/edit-2.0-r2.ebuild
new file mode 100644
index 0000000..faa7b9b
--- /dev/null
+++ b/rox-extra/edit/edit-2.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/edit/edit-2.0-r1.ebuild,v 1.1 2007/01/30 22:16:46 lack Exp $
+
+ROX_LIB_VER=1.9.14
+inherit rox
+
+APPNAME=Edit
+APPCATEGORY="Utility;TextEditor"
+
+DESCRIPTION="Edit is a simple text editor for ROX Desktop"
+HOMEPAGE="http://rox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rox/${P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86"
+IUSE="spell"
+
+LOCAL_FEED_SRC="${FILESDIR}/Edit-${PV}.xml"
+
+RDEPEND="spell? ( dev-python/gnome-python-extras )"
+
+# do some cleanup. Edit 2.0 has CVS dirs included
+pkg_preinst() {
+ find ${D}/usr/lib/rox/${APPNAME} -name 'CVS' | xargs rm -fr
+ rm -f ${D}/usr/lib/rox/${APPNAME}/.cvsignore
+ rm -fr ${D}/usr/lib/rox/${APPNAME}/tests
+}
diff --git a/rox-extra/edit/files/Edit-2.0.xml b/rox-extra/edit/files/Edit-2.0.xml
new file mode 100644
index 0000000..6e3d74b
--- /dev/null
+++ b/rox-extra/edit/files/Edit-2.0.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" ?>
+<interface main="AppRun" xmlns="http://zero-install.sourceforge.net/2004/injector/interface">
+ <name>Edit</name>
+ <summary>simple text editor</summary>
+ <description>
+Edit is a simple text editor, with a ROX-style user interface. It has drag-and-
+drop saving, search-and-replace and multi-level undo.</description>
+ <icon href="http://rox.sourceforge.net/Icons/Edit.png" type="image/png"/>
+ <homepage>http://rox.sourceforge.net/desktop/Edit</homepage>
+ <category>Utility</category>
+ <feed-for interface="http://rox.sourceforge.net/2005/interfaces/Edit"/>
+
+ <group main="AppRun">
+ <requires interface="http://rox.sourceforge.net/2005/interfaces/ROX-Lib">
+ <environment insert="ROX-Lib2/python" name="PYTHONPATH"/>
+ </requires>
+ <implementation id="." stabilitiy="packaged" version="2.0" released="2005-09-21"/>
+ </group>
+</interface>