aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2016-05-22 08:32:10 +0200
committerHans de Graaff <hans@degraaff.org>2016-05-22 08:32:10 +0200
commit9b0a1fa0d2600f3e64ea830cba1436c0589e22f0 (patch)
tree11f4914e23611c3769869a9eb3b7a2f345c3e263 /dev-ruby/pmap/pmap-1.1.1.ebuild
parent.travis.yml: Update. (diff)
downloadruby-overlay-9b0a1fa0d2600f3e64ea830cba1436c0589e22f0.tar.gz
ruby-overlay-9b0a1fa0d2600f3e64ea830cba1436c0589e22f0.tar.bz2
ruby-overlay-9b0a1fa0d2600f3e64ea830cba1436c0589e22f0.zip
dev-ruby/pmap: initial import for ruby-tinderbox
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/pmap/pmap-1.1.1.ebuild')
-rw-r--r--dev-ruby/pmap/pmap-1.1.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/pmap/pmap-1.1.1.ebuild b/dev-ruby/pmap/pmap-1.1.1.ebuild
new file mode 100644
index 0000000..039cfcc
--- /dev/null
+++ b/dev-ruby/pmap/pmap-1.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add parallel methods into Enumerable: pmap and peach"
+HOMEPAGE="https://github.com/bruceadams/pmap"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"