aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-ruby/gems: add ruby24HEADmasterHans de Graaff2018-05-061-2/+2
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-ruby/docker-api: add 1.34.2Hans de Graaff2018-04-292-0/+28
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-ruby/excon: add ruby24Hans de Graaff2018-04-291-3/+2
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-ruby/pmap: add ruby24, ruby25Hans de Graaff2018-04-291-3/+2
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-ruby/gems: cleanupHans de Graaff2017-08-282-29/+0
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2
* dev-ruby/gems: add 1.0.0Hans de Graaff2017-08-282-0/+29
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2
* app-admin/pwstore: update ruby targetsHans de Graaff2017-05-302-4/+3
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.1
* dev-ruby/gems: initial import for ruby-tinderboxHans de Graaff2016-05-223-0/+40
| | | | Package-Manager: portage-2.2.28
* dev-ruby/docker-api: initial import for ruby-tinderboxHans de Graaff2016-05-223-0/+40
| | | | Package-Manager: portage-2.2.28
* dev-ruby/excon: initial import for ruby-tinderboxHans de Graaff2016-05-223-0/+35
| | | | Package-Manager: portage-2.2.28
* dev-ruby/pmap: initial import for ruby-tinderboxHans de Graaff2016-05-223-0/+34
| | | | Package-Manager: portage-2.2.28
* .travis.yml: Update.Manuel Rüger2016-01-191-1/+1
|
* Typo fixDaniel Quinn2015-11-251-2/+1
|
* .travis.yml: Update portage versionManuel Rüger2015-11-251-1/+1
|
* .travis.yml: Use new gentoo mirror.Manuel Rüger2015-08-161-1/+1
|
* [.travis.yml] Update to new portage version.Manuel Rüger2015-08-151-1/+1
|
* Migrate to new header.Manuel Rüger2015-08-1519-19/+19
|
* [skel.metadata.xml] Use https.Manuel Rüger2015-06-271-2/+2
|
* [dev-ruby/sequel] Drop deprecated targetManuel Rüger2015-06-272-4/+6
| | | | Package-Manager: portage-2.2.20
* [dev-java/jaffl] Cleanup old broken versions.Manuel Rüger2015-06-278-206/+0
|
* [travis] Update. Reports now to #gentoo-ruby.Manuel Rüger2015-06-271-1/+10
|
* Moved to gentoo repository.Hans de Graaff2015-05-313-892/+0
|
* [travis.yml] Sync.Manuel Rüger2015-05-231-1/+1
|
* Fix syntax error.Hans de Graaff2015-05-162-1/+2
|
* Update RUBY_TARGETS_PREFERENCES to currently active targets.Hans de Graaff2015-05-111-1/+1
|
* Add a _RUBY_SINGLE guard to avoid multiple inclusion.Hans de Graaff2015-05-111-0/+6
|
* Sync with ruby-ng.eclass in the gentoo repository.Hans de Graaff2015-05-112-2/+19
|
* [travis] Update travis.ymlManuel Rüger2015-02-051-5/+5
|
* [.travis.yml] UpdateManuel Rüger2014-12-041-6/+9
|
* Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/ruby-overlayHans de Graaff2014-11-1813-148/+2
|\
| * [dev-ruby/github_api] In tree.Manuel Rüger2014-09-174-54/+0
| |
| * [dev-ruby/parser] In tree.Manuel Rüger2014-09-174-46/+0
| |
| * [dev-ruby/ast] In tree.Manuel Rüger2014-09-174-46/+0
| |
| * Update .travis.yml.Manuel Rüger2014-09-171-2/+2
| |
* | Move ruby-utils include to be before EXPORT_FUNCTIONS.Hans de Graaff2014-09-071-3/+1
|/ | | | | | | Fixes: * QA Notice: EXPORT_FUNCTIONS is called before inherit in * ruby-ng.eclass. For compatibility with <=portage-2.1.6.7, only call * EXPORT_FUNCTIONS after inherit(s).
* Update .travis.yml.Manuel Rüger2014-08-251-1/+1
|
* [dev-ruby/hanna] Remove unmaintained gem.Manuel Rüger2014-08-255-59/+0
|
* [dev-ruby/subcommand] Remove unmaintained gem.Manuel Rüger2014-08-254-66/+0
|
* [app-admin/pwstore] Add DESC and HOMEPAGE.Manuel Rüger2014-08-252-3/+5
| | | | Package-Manager: portage-2.2.12
* [dev-ruby/facebooker] Remove unmaintained gem.Manuel Rüger2014-08-254-109/+0
|
* [dev-ruby/templater] Remove unmaintained gem.Manuel Rüger2014-08-254-67/+0
|
* Initial import. Used as test ebuild for the new ruby-single.eclass.Hans de Graaff2014-08-224-0/+49
| | | | Package-Manager: portage-2.2.8-r1
* Add ruby-single.eclassHans de Graaff2014-08-223-0/+870
| | | | | | This eclass supports the case where a single RUBY interpreter is sufficient. Code in common with ruby-ng.eclass has been refactored into a common ruby-utils.eclass.
* Update .travis.ymlManuel Rüger2014-08-031-1/+1
|
* Update .travis.ymlManuel Rüger2014-07-161-4/+5
|
* Remove: the most recent jruby 1.7 version is in the main tree, currently masked.Hans de Graaff2014-06-167-4230/+0
|
* Remove: ruby18/jruby only, no license. New versions require additional ↵Hans de Graaff2014-06-163-69/+0
| | | | unpackages dependencies. No open bug for inclusion.
* Fix manifestHans de Graaff2014-06-161-14/+1
| | | | Package-Manager: portage-2.2.8-r1
* Remove: ruby18-only, not updated in a long time.Hans de Graaff2014-06-164-101/+0
|
* Update README.md for github.Hans de Graaff2014-06-161-0/+7
|