aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-06 05:02:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-06 05:02:51 +0000
commit1d4e4af4db18077a555492cf8b4348e115844f0a (patch)
tree597c8872d4161edce405ded4f715cbe5391213d6
parentforce people to use -n if they want to generate stuff (diff)
downloadsandbox-1d4e4af4db18077a555492cf8b4348e115844f0a.tar.gz
sandbox-1d4e4af4db18077a555492cf8b4348e115844f0a.tar.bz2
sandbox-1d4e4af4db18077a555492cf8b4348e115844f0a.zip
add static/shared library checks to prevent anyone else wasting our time
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0a92da..4dfbdc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,20 @@ AC_CHECK_FUNCS([ \
strtok_r \
])
+dnl Verify people aren't doing stupid shit
+if test x"$enable_static" != xno ; then
+ AC_MSG_ERROR([dont be a Kumba, building a libsandbox.a is stupid])
+fi
+if test x"$enable_shared" != xyes ; then
+ AC_MSG_ERROR([dont be a Kumba, omitting a libsandbox.so is stupid])
+fi
+if echo $CFLAGS | $EGREP -e -static >/dev/null 2>&1; then
+ AC_MSG_ERROR([dont be a Kumba, using -static in CFLAGS is stupid])
+fi
+if echo $LDFLAGS | $EGREP -e -static >/dev/null 2>&1; then
+ AC_MSG_ERROR([dont be a Kumba, using -static in LDFLAGS is stupid])
+fi
+
dnl Some libc's like those on bsd have dlopen() in libc, and not libdl
AC_CHECK_LIB([dl], [dlopen],
[have_libdl="yes"],