aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-15 23:11:33 -0400
committerMike Frysinger <vapier@gentoo.org>2010-08-15 23:11:33 -0400
commit813c4826925a7c0dadb93471491f92e876a61eaa (patch)
treef3d8fd52047bf196ca103901f3b12d586620a5b3
parent00default: fix duplicate dist target (diff)
downloadsandbox-813c4826925a7c0dadb93471491f92e876a61eaa.tar.gz
sandbox-813c4826925a7c0dadb93471491f92e876a61eaa.tar.bz2
sandbox-813c4826925a7c0dadb93471491f92e876a61eaa.zip
tests: fix dist target for out-of-tree builds
Building out-of-tree and then running `make dist` would miss a lot of important test files. Make sure globs are relative to the source tree and not the build tree. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9a6432d..46728ba 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,4 @@
-AT_FILES = $(wildcard *.at)
+AT_FILES = $(wildcard $(srcdir)/*.at)
TESTSUITE = $(srcdir)/testsuite
DISTCLEANFILES = atconfig
EXTRA_DIST = atlocal.in package.m4.in $(AT_FILES) $(TESTSUITE) \
@@ -66,7 +66,7 @@ check_PROGRAMS = \
sigsuspend-zsh_static_tst
dist_check_SCRIPTS = \
- $(wildcard *-?.sh) \
+ $(wildcard $(srcdir)/*-?.sh) \
script-0 \
trace-0