aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-12-05 09:02:46 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-12-05 09:02:46 +0000
commite51e9cb0062f295f42335e5c75a5f8b83ca0f135 (patch)
tree9116497438096e344ab6df7d3a7854553971fef4
parentAlso add weak symbols. (diff)
downloadsandbox-e51e9cb0062f295f42335e5c75a5f8b83ca0f135.tar.gz
sandbox-e51e9cb0062f295f42335e5c75a5f8b83ca0f135.tar.bz2
sandbox-e51e9cb0062f295f42335e5c75a5f8b83ca0f135.zip
Make sure the aquired libc is readable.
Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8e76746..661bade 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,7 @@ $CC -Wall -o libctest libctest.c
LIBC_PATH=`$CC $CFLAGS -Wl,-verbose -o libctest libctest.c 2>&1 | \
$AWK '/attempt to open/ { if (($4 ~ /libc\.so/) && ($5 == "succeeded")) LIBC = $4; }; END {print LIBC}'`
rm -f libctest.c
-if test "$LIBC_PATH"x = x ; then
+if test "$LIBC_PATH"x = x || ! test -r "$LIBC_PATH"; then
AC_MSG_ERROR([Unable to determine LIBC PATH])
fi
AC_MSG_RESULT([$LIBC_PATH])