aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2004-11-20 13:21:37 +0000
committerBrian Harring <ferringb@gentoo.org>2004-11-20 13:21:37 +0000
commitdfb9a2160ea1eb7016362e4a6bd146445a85b270 (patch)
tree957617a5d3e3fe63754ee55bcacd6f5e0cb19cf7 /Makefile.am
parentnore should these. (diff)
downloadsandbox-dfb9a2160ea1eb7016362e4a6bd146445a85b270.tar.gz
sandbox-dfb9a2160ea1eb7016362e4a6bd146445a85b270.tar.bz2
sandbox-dfb9a2160ea1eb7016362e4a6bd146445a85b270.zip
corrections to remove hardcoded paths.
Signed-off-by: Brian Harring <ferringb@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 606f67e..3460530 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,11 +4,15 @@ datadir = @datadir@
AM_CFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT
libsandbox_la_SOURCES = libsandbox.c sandbox_futils.c localdecls.h
-libsandbox_la_LDFLAGS = -Wc,-nostdlib
-libsandbox_la_CFLAGS = -Wc,-nostdlib -D_REENTRANT -D_GNU_SOURCE -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\"
+libsandbox_la_LDFLAGS = -Wc,-nostdlib -lc -ldl
+libsandbox_la_CFLAGS = -Wc,-nostdlib -D_REENTRANT -D_GNU_SOURCE \
+ -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\" \
+ -DLIBSANDBOX_PATH=\"$(libdir)\"
+
sandbox_SOURCES = sandbox.c sandbox.h sandbox_futils.c getcwd.c
-sandbox_CFLAGS = -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\"
+sandbox_CFLAGS = -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\" \
+ -DLIBSANDBOX_PATH=\"$(libdir)\"
BUILT_SOURCES = localdecls.h