aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2004-11-19 22:03:42 +0000
committerBrian Harring <ferringb@gentoo.org>2004-11-19 22:03:42 +0000
commit79cb18ddd2ab2ea4ee108f21dd80a29548faefba (patch)
treea09963730e8edaf08ecc4557d340ccb100f99560 /Makefile.am
downloadsandbox-79cb18ddd2ab2ea4ee108f21dd80a29548faefba.tar.gz
sandbox-79cb18ddd2ab2ea4ee108f21dd80a29548faefba.tar.bz2
sandbox-79cb18ddd2ab2ea4ee108f21dd80a29548faefba.zip
Initial revision
Signed-off-by: Brian Harring <ferringb@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5fed368
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,16 @@
+bin_PROGRAMS = sandbox
+lib_LTLIBRARIES = libsandbox.la
+
+AM_CFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT
+
+libsandbox_la_SOURCES = libsandbox.c sandbox_futils.c localdecls.h
+libsandbox_la_LDFLAGS = -Wc,-nostdlib
+libsandbox_la_CFLAGS = -Wc,-nostdlib -D_REENTRANT -D_GNU_SOURCE
+
+sandbox_SOURCES = sandbox.c sandbox.h sandbox_futils.c getcwd.c
+
+BUILT_SOURCES = localdecls.h
+
+
+localdecls.h: Makefile
+ ./create-localdecls