aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-20 03:03:30 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-20 03:03:30 -0400
commit105b7e047e98e8f9211a30133d0cc1cb97aef9b0 (patch)
treeab4a0a6384e0bca7efac377ba107d634589c1345 /configure.ac
parentgitignore: ignore .dirstamp files (diff)
downloadsandbox-105b7e047e98e8f9211a30133d0cc1cb97aef9b0.tar.gz
sandbox-105b7e047e98e8f9211a30133d0cc1cb97aef9b0.tar.bz2
sandbox-105b7e047e98e8f9211a30133d0cc1cb97aef9b0.zip
libsbutil: gnulib: import modules for canonicalize_filename_mode
This lays the groundwork for fixing handling of broken symlinks. The gnulib code is hand imported because using the gnulib tool imports a ton of code we do not want. Only the bare minimum is imported so we can use the canonicalize_filename_mode function. This function is needed to canonicalize symlinks that are ultimately broken. The current sandbox/C library code only supports two modes: (1) dereference a single symlink (2) dereference *all* symlinks, but only if all links are valid For sandbox, we need to know the final path a symlink points to even if that path doesn't (yet) exist. Note: This commit doesn't actually fix the bug, just brings in the functions we need to do so. URL: https://bugs.gentoo.org/540828 Reported-by: Rick Farina <zerochaos@gentoo.org> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 73227db..e705d41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.61])
AC_INIT([sandbox], [2.8], [sandbox@gentoo.org])
-AM_INIT_AUTOMAKE([1.12 dist-xz no-dist-gzip silent-rules -Wall])
+AM_INIT_AUTOMAKE([1.12 dist-xz no-dist-gzip silent-rules subdir-objects -Wall])
AM_SILENT_RULES([yes]) # AM_INIT_AUTOMAKE([silent-rules]) is broken atm
AC_CONFIG_HEADER([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -417,6 +417,9 @@ if test "x${LDFLAG_VER}" = "x" ; then
fi
AC_SUBST([LDFLAG_VER])
+dnl Add some glue for gnulib modules that include config.h directly.
+AH_BOTTOM([#include "headers.h"])
+
AC_CONFIG_TESTDIR([tests])
AC_CONFIG_FILES([src/sandbox.sh], [chmod +x src/sandbox.sh])