aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-12-05 09:28:34 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-12-05 09:28:34 +0000
commit78c94147bc5c6e985e69211c192b91b7ad57021c (patch)
tree6a65f8f0743cdc357dda0c1f1d229e83b465a88c /configure.ac
parentMake sure the aquired libc is readable. (diff)
downloadsandbox-78c94147bc5c6e985e69211c192b91b7ad57021c.tar.gz
sandbox-78c94147bc5c6e985e69211c192b91b7ad57021c.tar.bz2
sandbox-78c94147bc5c6e985e69211c192b91b7ad57021c.zip
Rename sandbox_futils.c to sandbox_utils.c. Add gstrndup() and gbasename()
to sandbox_utils.c. Add check for glibc, and fixup things to not need glibc only extensions if not needed for versioned symbols. Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 661bade..40cdabc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,27 @@ else
AC_DEFINE([TRUNCATE_T], [off_t], [truncate arg type])
fi
+dnl Check if we have glibc or clone
+AC_MSG_CHECKING([for glibc])
+AC_TRY_COMPILE([
+#include <features.h>
+], [
+#if !defined(__GLIBC__)
+# error no glibc
+#endif
+
+int main (void)
+{
+ return 0;
+}
+], [have_glibc="yes"], [have_glibc="no"])
+if test x"$have_glibc" = xyes ; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+AM_CONDITIONAL([HAVE_GLIBC], [test x"$have_glibc" = xyes])
+
dnl we need to handle symbols differently based upon their version,
dnl but we have to know which symbols the libc supports first
AC_MSG_CHECKING([libc path])
@@ -109,7 +130,7 @@ AC_ARG_ENABLE([multilib],
[enable_multilib="no"]
)
-if test "$enable_multilib"x != xno ; then
+if test x"$enable_multilib" != xno ; then
AC_DEFINE_UNQUOTED([SB_HAVE_MULTILIB], [1], [have multilib enabled system])
fi