aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-22 19:48:46 -0700
committerMike Frysinger <vapier@gentoo.org>2012-06-23 19:07:27 -0400
commitbb49765c205f9c383efd147d20a977b6982d5b4d (patch)
tree49e20ea021a3ef95137c9a2b596954fb6cb1d767 /libsandbox/Makefile.am
parentlibsandbox: handle broken kernel headers (diff)
downloadsandbox-bb49765c205f9c383efd147d20a977b6982d5b4d.tar.gz
sandbox-bb49765c205f9c383efd147d20a977b6982d5b4d.tar.bz2
sandbox-bb49765c205f9c383efd147d20a977b6982d5b4d.zip
libsandbox: regenerate trace headers when autotools change
If you re-run configure with different settings, the trace headers might be out of date. Have the generated headers depend on the Makefile so that when this situation does come up, we force sanity. This step is fairly quick, so shouldn't be a big deal. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'libsandbox/Makefile.am')
-rw-r--r--libsandbox/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libsandbox/Makefile.am b/libsandbox/Makefile.am
index b25e4b3..dc45618 100644
--- a/libsandbox/Makefile.am
+++ b/libsandbox/Makefile.am
@@ -70,7 +70,7 @@ TRACE_MAKE_HEADER = \
$(SB_AWK) $(GEN_TRACE_SCRIPT) -v MODE=gen | \
$(COMPILE) -E -include $(top_srcdir)/headers.h - $$f | \
$(SB_AWK) $(GEN_TRACE_SCRIPT) -v syscall_prefix=$$t > $$header
-trace_syscalls.h: $(GEN_TRACE_SCRIPT)
+trace_syscalls.h: $(GEN_TRACE_SCRIPT) Makefile
if SB_SCHIZO
$(AM_V_GEN)for pers in $(SB_SCHIZO_SETTINGS) ; do \
t=_$${pers%:*}; \