aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-15 01:08:00 -0500
committerMike Frysinger <vapier@gentoo.org>2009-02-15 01:08:00 -0500
commitc2eee93088aad4876c2f25fcb78d67ad18ffa425 (patch)
tree992578dace40f636257459f16bfcc09194896daa /libsandbox/Makefile.am
parentlibsandbox: make sure all mknod symbols are wrapped (diff)
downloadsandbox-c2eee93088aad4876c2f25fcb78d67ad18ffa425.tar.gz
sandbox-c2eee93088aad4876c2f25fcb78d67ad18ffa425.tar.bz2
sandbox-c2eee93088aad4876c2f25fcb78d67ad18ffa425.zip
libsandbox: calculate longest symbol name dynamically
The longest wrapped symbol name has hit the hard limit of 10 chars, so rather than manually bump it up, calculate it on the fly with the awk scripts. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'libsandbox/Makefile.am')
-rw-r--r--libsandbox/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libsandbox/Makefile.am b/libsandbox/Makefile.am
index e38cc29..97d8864 100644
--- a/libsandbox/Makefile.am
+++ b/libsandbox/Makefile.am
@@ -53,7 +53,7 @@ symbols.h: $(SYMBOLS_FILE) $(SYMBOLS_WRAPPERS) $(GEN_HEADER_SCRIPT)
SB_NR_FILE = $(srcdir)/sb_nr.h.in
sb_nr.h: symbols.h $(SB_NR_FILE)
- $(EGREP) -h '^\#define SB_NR_' $^ > $@
+ $(EGREP) -h '^\#define SB_' $^ > $@
EXTRA_DIST = $(SYMBOLS_FILE) $(SYMBOLS_WRAPPERS) $(SB_NR_FILE)