aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-29 04:06:05 -0500
committerMike Frysinger <vapier@gentoo.org>2008-11-29 04:39:43 -0500
commitce962a81797d455e4160f379c53d3432bbec36d4 (patch)
tree9c961a0fa763c21ca1e568941ecffe168f7679d2 /libsandbox/Makefile.am
parentlibsandbox: push STRING_NAME into libsandbox.h (diff)
downloadsandbox-ce962a81797d455e4160f379c53d3432bbec36d4.tar.gz
sandbox-ce962a81797d455e4160f379c53d3432bbec36d4.tar.bz2
sandbox-ce962a81797d455e4160f379c53d3432bbec36d4.zip
libsandbox: use integers rather than strings for functions
Rather than doing a buttload of strcmp's on function names, use integers. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'libsandbox/Makefile.am')
-rw-r--r--libsandbox/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/libsandbox/Makefile.am b/libsandbox/Makefile.am
index 6757524..3f70086 100644
--- a/libsandbox/Makefile.am
+++ b/libsandbox/Makefile.am
@@ -34,7 +34,7 @@ libsandbox_la_SOURCES = \
wrappers.c \
canonicalize.c
-libsandbox.c: libsandbox.map
+libsandbox.c: libsandbox.map sb_nr.h
wrappers.c: symbols.h
SYMBOLS_FILE = $(srcdir)/symbols.h.in
@@ -51,7 +51,11 @@ symbols.h: $(SYMBOLS_FILE) $(SYMBOLS_WRAPPERS) $(GEN_HEADER_SCRIPT)
$(READELF) -h -s $(LIBC_PATH) | \
$(AWK) -v SYMBOLS_LIST="$(SYMBOLS_LIST)" -f $(GEN_HEADER_SCRIPT) > $@
-EXTRA_DIST = $(SYMBOLS_FILE) $(SYMBOLS_WRAPPERS)
+SB_NR_FILE = $(srcdir)/sb_nr.h.in
+sb_nr.h: symbols.h $(SB_NR_FILE)
+ $(EGREP) -h '^\#define SB_NR_' $^ > $@
-CLEANFILES = libsandbox.map symbols.h
+EXTRA_DIST = $(SYMBOLS_FILE) $(SYMBOLS_WRAPPERS) $(SB_NR_FILE)
+
+CLEANFILES = libsandbox.map sb_nr.h symbols.h
DISTCLEANFILES = $(CLEANFILES)