aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-23 17:11:46 -0400
committerMike Frysinger <vapier@gentoo.org>2012-06-23 17:12:36 -0400
commit75910f59e718caa079644dadd6e663fc68994239 (patch)
treef38f10ba29fa2279ba69a10f83b290bc0aa41efd /libsandbox
parentlibsandbox: add missing close to logfile fd (diff)
downloadsandbox-75910f59e718caa079644dadd6e663fc68994239.tar.gz
sandbox-75910f59e718caa079644dadd6e663fc68994239.tar.bz2
sandbox-75910f59e718caa079644dadd6e663fc68994239.zip
libsandbox: add uninstall target to fix distcheck
Newer distcheck runs uninstall which is apparently broken. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'libsandbox')
-rw-r--r--libsandbox/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/libsandbox/Makefile.am b/libsandbox/Makefile.am
index 9edd466..0856aa4 100644
--- a/libsandbox/Makefile.am
+++ b/libsandbox/Makefile.am
@@ -36,6 +36,10 @@ libsandbox_la_SOURCES = \
install-exec-hook:
rm -f $(DESTDIR)$(libdir)/libsandbox.la
+# Since we removed the .la file, libtool uninstall doesn't work,
+# so we have to manually uninstall libsandbox.so ourselves.
+uninstall-hook:
+ rm -f $(DESTDIR)$(libdir)/libsandbox.so
libsandbox.c: libsandbox.map sb_nr.h
trace.c: trace_syscalls.h sb_nr.h $(TRACE_FILES)