aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-22 14:31:34 -0700
committerMike Frysinger <vapier@gentoo.org>2012-07-03 00:38:40 -0400
commitb9cfa0a10decdbe659447a221a0634f2b78943b0 (patch)
tree47aa5b2a61934e7f85100e43515e6e889e436995 /libsandbox
parentsb_printf: expand feature set slightly and fix testing (diff)
downloadsandbox-b9cfa0a10decdbe659447a221a0634f2b78943b0.tar.gz
sandbox-b9cfa0a10decdbe659447a221a0634f2b78943b0.tar.bz2
sandbox-b9cfa0a10decdbe659447a221a0634f2b78943b0.zip
precompile headers.h to speed up build slightly
Since all system headers are included by way of headers.h, we can pre-compile this to speed up the build up a bit. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'libsandbox')
-rw-r--r--libsandbox/Makefile.am2
-rw-r--r--libsandbox/headers.h1
-rw-r--r--libsandbox/libsandbox.c7
3 files changed, 2 insertions, 8 deletions
diff --git a/libsandbox/Makefile.am b/libsandbox/Makefile.am
index dc45618..2eb8da1 100644
--- a/libsandbox/Makefile.am
+++ b/libsandbox/Makefile.am
@@ -83,7 +83,7 @@ else
$(AM_V_GEN)t= f= header=$@; $(TRACE_MAKE_HEADER)
endif
-EXTRA_DIST = $(SYMBOLS_FILE) $(SYMBOLS_WRAPPERS) $(SB_NR_FILE) $(TRACE_FILES)
+EXTRA_DIST = $(SYMBOLS_FILE) $(SYMBOLS_WRAPPERS) $(SB_NR_FILE) $(TRACE_FILES) headers.h
CLEANFILES = libsandbox.map sb_nr.h symbols.h trace_syscalls*.h
DISTCLEANFILES = $(CLEANFILES)
diff --git a/libsandbox/headers.h b/libsandbox/headers.h
new file mode 100644
index 0000000..7fcc3b2
--- /dev/null
+++ b/libsandbox/headers.h
@@ -0,0 +1 @@
+#include "../headers.h"
diff --git a/libsandbox/libsandbox.c b/libsandbox/libsandbox.c
index 60d4614..2096b06 100644
--- a/libsandbox/libsandbox.c
+++ b/libsandbox/libsandbox.c
@@ -10,14 +10,7 @@
* as some of the InstallWatch code was used.
*/
-#define open xxx_open
-#define open64 xxx_open64
-
#include "headers.h"
-
-#undef open
-#undef open64
-
#include "sbutil.h"
#include "libsandbox.h"
#include "wrappers.h"