aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-12-01 09:46:17 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-12-01 09:46:17 +0000
commit58aaec27050c17f90289181151f0f67648ff8392 (patch)
tree005fc54f310ec722c025d16667ae02ed4774b8f8 /src/Makefile.am
parentFixup comments related to strong aliases. (diff)
downloadsandbox-58aaec27050c17f90289181151f0f67648ff8392.tar.gz
sandbox-58aaec27050c17f90289181151f0f67648ff8392.tar.bz2
sandbox-58aaec27050c17f90289181151f0f67648ff8392.zip
Remove the SB_STATIC and including of getcwd.c, etc voodoo, as we new use a
symbol map, and all non-exported symbols are local. Cleanup getcwd.c, as the generic getcwd for older 2.4 kernels do not work properly anyhow, and just makes things slower. Some other warning fixes. Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e2a4be0..590f8e9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,7 +7,7 @@ AM_CPPFLAGS = \
-D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT \
-DLIBSANDBOX_PATH=\"$(libdir)\" \
-DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\" \
- -I$(top_srcdir)
+ -I$(top_srcdir) -Wall
LOCAL_INCLUDES = $(top_srcdir)/localdecls.h
@@ -21,7 +21,10 @@ libsandbox_la_LDFLAGS = \
-nodefaultlibs \
-Wl,--version-script,libsandbox.map
libsandbox_la_SOURCES = \
- libsandbox.c \
+ libsandbox.c \
+ getcwd.c \
+ canonicalize.c \
+ sandbox_futils.c \
$(LOCAL_INCLUDES)
sandbox_CFLAGS = -DOUTSIDE_LIBSANDBOX
@@ -67,7 +70,7 @@ symbols.h: $(SYMBOLS_FILE) $(GEN_HEADER_SCRIPT)
exit 1; \
fi
-EXTRA_DIST = canonicalize.c $(SYMBOLS_FILE)
+EXTRA_DIST = $(SYMBOLS_FILE)
CLEANFILES = libsandbox.map symbols.h
DISTCLEANFILES = $(CLEANFILES)