aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rwxr-xr-xautogen.sh18
-rwxr-xr-xscripts/svn2cl (renamed from scripts/svn2cl.sh)0
3 files changed, 8 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index d6f56da..627e64d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,3 +12,7 @@ libsandbox: libsbutil
src: libsbutil
EXTRA_DIST = localdecls.h ChangeLog.0
+
+dist-hook:
+ PATH="$${PATH}:./scripts" svn2cl
+ cp ChangeLog $(distdir)
diff --git a/autogen.sh b/autogen.sh
index 50dfcf8..776c115 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -1,19 +1,9 @@
-#!/bin/bash
+#!/bin/bash -e
-# Generate Changelog by default if we in svn repository
-if [[ -d .svn && $1 != -n ]] ; then
- # For some reason svn do not give the full log if we do not
- # update first ...
- svn update
- ./scripts/svn2cl.sh
-fi
+# we'll generate ChangeLog when doing `make dist`
+touch ChangeLog
-aclocal-1.9 || exit 1
-libtoolize --automake -c -f || exit 1
-aclocal-1.9 || exit 1
-autoconf || exit 1
-autoheader || exit 1
-automake-1.9 -a -c || exit 1
+autoreconf -i -f
if [[ -x ./test.sh ]] ; then
exec ./test.sh "$@"
diff --git a/scripts/svn2cl.sh b/scripts/svn2cl
index 06eba0e..06eba0e 100755
--- a/scripts/svn2cl.sh
+++ b/scripts/svn2cl