aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7673ebd..508edac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,7 @@ symbols.h: symbols.in
sym=`readelf -s "$(LIBC_PATH)" 2>/dev/null | \
awk '{ print $$8 }' | \
grep "^$${x}@@" | \
+ sort -u | \
cut -d'@' -f3`; \
echo "#define symname_$${x} \"$${x}\"" >> $@; \
if [ -n "$${sym}" ]; then \