aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
index 776c115..7bd1251 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -3,6 +3,13 @@
# we'll generate ChangeLog when doing `make dist`
touch ChangeLog
+# not everyone has sys-devel/autoconf-archive installed
+for macro in $(grep -o '\<AX[A-Z_]*\>' configure.ac | sort -u) ; do
+ m4=$(grep -rl "\[${macro}\]" /usr/share/aclocal/)
+ [[ -z $m4 ]] && continue
+ cp -v $m4 m4/
+done
+
autoreconf -i -f
if [[ -x ./test.sh ]] ; then