aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-26 14:52:38 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-26 14:52:38 +0100
commit26242100ae861907ae58864ffac9163bf9be51ed (patch)
tree940727b22e9652ec03820509faf085d880cf2d02
parentDrop more ancient CVS Header (diff)
downloadsci-26242100ae861907ae58864ffac9163bf9be51ed.tar.gz
sci-26242100ae861907ae58864ffac9163bf9be51ed.tar.bz2
sci-26242100ae861907ae58864ffac9163bf9be51ed.zip
sci-biology/flexbar: version bump
https://github.com/seqan/flexbar/issues/8 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-biology/flexbar/Manifest2
-rw-r--r--sci-biology/flexbar/flexbar-2.4.ebuild23
-rw-r--r--sci-biology/flexbar/flexbar-2.7.0.ebuild33
3 files changed, 34 insertions, 24 deletions
diff --git a/sci-biology/flexbar/Manifest b/sci-biology/flexbar/Manifest
index 2114576cf..4493b8c57 100644
--- a/sci-biology/flexbar/Manifest
+++ b/sci-biology/flexbar/Manifest
@@ -1 +1 @@
-DIST flexbar_v2.4_src.tgz 30269 SHA256 241aeda8bb0a40ee583ec58e54a3872441ecd570fa2ada61f1e3435a790d1946 SHA512 c95b1f96d35d14cca43018916cc11df2376ccd13ab60e01c2cb0e9ee09b585d6d4305dd02b2afbf2c6875ac89c08a83f2efc520165549ada80c28d01d339adef WHIRLPOOL 5a2a58edb6d4800c369914ceaf2c1df6ec850167fcda90c2489dfede37147f6e855e5dcdfc7f4b35922bcd3c748f6b07b3d10a9f5a825370d84209ae518950c2
+DIST flexbar-2.7.0.tar.gz 30033 SHA256 8b44a16594e8a2f68d33acbcfdbfb0a017d2a6dc69cc65259b199ad94ea0f0e6 SHA512 38dc40476dadd769977dd2428941928e839e107e719e9b595c2ba57e1d8764fb394c5960b809da99dc939a66cae9350ea607e393b9467e98d464d0e49bcdac47 WHIRLPOOL da45d9bb8080ef7913324875dd0f8ac4a6f182337da1c217eaf9894ced407f78ff10637b62981466ad0cc2c4dde25d6d1d5235480112ebe67e7a21053b699247
diff --git a/sci-biology/flexbar/flexbar-2.4.ebuild b/sci-biology/flexbar/flexbar-2.4.ebuild
deleted file mode 100644
index 515dabcfc..000000000
--- a/sci-biology/flexbar/flexbar-2.4.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Barcode, MID tag and adapter sequence removal"
-HOMEPAGE="https://sourceforge.net/p/flexbar/wiki/Manual"
-SRC_URI="http://sourceforge.net/projects/flexbar/files/2.4/flexbar_v2.4_src.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-CDEPEND="
- dev-cpp/tbb
- >=sci-biology/seqan-1.4.1:0"
-DEPEND="${CDEPEND}"
-RDEPEND="${CDEPEND}"
-
-S="${WORKDIR}"/"${PN}"_v"${PV}"_src
diff --git a/sci-biology/flexbar/flexbar-2.7.0.ebuild b/sci-biology/flexbar/flexbar-2.7.0.ebuild
new file mode 100644
index 000000000..5fbee3998
--- /dev/null
+++ b/sci-biology/flexbar/flexbar-2.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Barcode, MID tag and adapter sequence removal"
+HOMEPAGE="https://github.com/seqan/flexbar"
+SRC_URI="https://github.com/seqan/flexbar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND="
+ dev-cpp/tbb
+ >=sci-biology/seqan-2.1.1:0"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+# TODO: need to call 'pkg-config --cflags seqan-2.2' and pass it down
+src_configure() {
+ local CPPFLAGS=${CPPFLAGS}
+ append-cppflags `pkg-config --cflags seqan-2.2`
+ local CXXFLAGS="${CXXFLAGS}"
+ append-cxxflags "-std=c++14"
+ cmake-utils_src_configure
+}
+
+# SeqAn requires C++14! You must compile your application with -std=c++14, -std=gnu++14 or -std=c++1y
+# https://github.com/seqan/flexbar/issues/8