aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-02-28 20:40:16 +0000
committerJustin Lecher <jlec@gentoo.org>2017-02-28 20:55:03 +0000
commit30ef613f07c738781efbc195e8b78dccf7c721b3 (patch)
treee94e9da504a6966c2aaef108bc3adcb87aba19a2
parentdev-libs/libcuda: QA fixes (diff)
downloadsci-30ef613f07c738781efbc195e8b78dccf7c721b3.tar.gz
sci-30ef613f07c738781efbc195e8b78dccf7c721b3.tar.bz2
sci-30ef613f07c738781efbc195e8b78dccf7c721b3.zip
dev-libs/libflatarray: QA fixes
Bump to EAPI=6 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-libs/libflatarray/libflatarray-9999.ebuild35
1 files changed, 8 insertions, 27 deletions
diff --git a/dev-libs/libflatarray/libflatarray-9999.ebuild b/dev-libs/libflatarray/libflatarray-9999.ebuild
index 12c4aa7cf..e4689baf5 100644
--- a/dev-libs/libflatarray/libflatarray-9999.ebuild
+++ b/dev-libs/libflatarray/libflatarray-9999.ebuild
@@ -1,27 +1,18 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-if [ ${PV} == "9999" ] ; then
- _SCM=mercurial
- EHG_REPO_URI="http://bitbucket.org/gentryx/libflatarray"
- SRC_URI=""
- KEYWORDS=""
- CMAKE_USE_DIR="${S}"
-else
- SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
- KEYWORDS="~amd64 ~ppc ~x86"
- S="${WORKDIR}/${P}"
-fi
-
-inherit cmake-utils cuda ${_SCM}
+inherit cmake-utils cuda mercurial
DESCRIPTION="Struct of arrays library with object oriented interface for C++"
HOMEPAGE="http://www.libgeodecomp.org/libflatarray.html"
+SRC_URI=""
+EHG_REPO_URI="http://bitbucket.org/gentryx/libflatarray"
SLOT="0"
LICENSE="Boost-1.0"
+KEYWORDS=""
IUSE="cuda doc"
RDEPEND="
@@ -30,22 +21,12 @@ RDEPEND="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+CMAKE_USE_DIR="${S}"
+DOCS=( README )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with cuda CUDA)
)
cmake-utils_src_configure
}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS=( README )
- cmake-utils_src_install
-}
-
-src_test() {
- cmake-utils_src_make test
-}