aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-02-02 20:54:56 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-02-02 20:54:56 -0600
commit4f5313ae510454f6cea2008d1319f192d6d9a4c9 (patch)
tree0e3a190dff98ec01ca7d8bbe517581b715558d4a
parentsci-libs/cblas-reference: Drop unsupported keywords (diff)
downloadsci-4f5313ae510454f6cea2008d1319f192d6d9a4c9.tar.gz
sci-4f5313ae510454f6cea2008d1319f192d6d9a4c9.tar.bz2
sci-4f5313ae510454f6cea2008d1319f192d6d9a4c9.zip
sci-libs/cblas-reference: version bump to 20161223 (3.7.0)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-libs/cblas-reference/Manifest1
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20161223-r100.ebuild125
-rw-r--r--sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch56
3 files changed, 182 insertions, 0 deletions
diff --git a/sci-libs/cblas-reference/Manifest b/sci-libs/cblas-reference/Manifest
index 354387050..15ab1adbd 100644
--- a/sci-libs/cblas-reference/Manifest
+++ b/sci-libs/cblas-reference/Manifest
@@ -1,2 +1,3 @@
DIST cblas-reference-20110218.tgz 197468 SHA256 0f6354fd67fabd909baf57ced2ef84e962db58fae126e4f41b21dd4fec60a2a3 SHA512 1c64e6814529cd716890504d213e8cd90150348b9105e8da030718383241a5660d145a14f26e20d27b2aea72c87a9d46b754c6e48935e168d62842c04ba56401 WHIRLPOOL 95dff08c41c35aa769fccfda220950d18adf69393bf7866191121473857f6ac7af5344e7ec93131f29afb8323be1a1f9b720122c9c52cc6064c783a04f8a95a1
DIST lapack-3.6.0.tgz 6792324 SHA256 a9a0082c918fe14e377bbd570057616768dca76cbdc713457d8199aaa233ffc3 SHA512 bc50441d415ef8896dd7626d77c6104184b996e758704366288089f03d4c99d068e33153b0d13305310886017e5d2e716130f812a95cfcad36ef37fe20417ab8 WHIRLPOOL 5576d0a81b2645fe95ef7011cc398f31142b8dcd01cdf5945e3db0e73ae1768766ea54254b40f4c6a581a6fb77b911595fccd597be0536833118af5877bb0c64
+DIST lapack-3.7.0.tgz 7359812 SHA256 ed967e4307e986474ab02eb810eed1d1adc73f5e1e3bc78fb009f6fe766db3be SHA512 e4f4c7d0ba8a096eeb813160c6dbcdd535647df6b2ad5beac9181908158956b31d1a9554ec9b9836fd44fe7404c1f377b297cbb20d744f20d70e357fd246c91b WHIRLPOOL d536508015e081395bda83b84bf4e5b1d6e8e517ea38f6afcaf40e96d892b26b8b1034954d5cd79cce5033d6653e178b5d27a46deecfa7466cd0bdaafcf9f18f
diff --git a/sci-libs/cblas-reference/cblas-reference-20161223-r100.ebuild b/sci-libs/cblas-reference/cblas-reference-20161223-r100.ebuild
new file mode 100644
index 000000000..ba874d895
--- /dev/null
+++ b/sci-libs/cblas-reference/cblas-reference-20161223-r100.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+NUMERIC_MODULE_NAME="refcblas"
+
+inherit alternatives-2 cmake-utils eutils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs
+
+LPN=lapack
+LPV=3.7.0
+
+DESCRIPTION="C wrapper interface to the F77 reference BLAS implementation"
+HOMEPAGE="http://www.netlib.org/cblas/"
+SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
+
+LICENSE="BSD"
+SLOT="0/${LPV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="virtual/blas"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${LPN}-${LPV}"
+PATCHES=( "${FILESDIR}/lapack-reference-${LPV}-fix-build-system.patch" )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/cblas/cblas.h
+)
+src_prepare() {
+ default
+
+ # rename library to avoid collision with other blas implementations
+ # ${LIBNAME} and ${PROFNAME} are not defined here, they are in single
+ # quotes in the following seds. They are later set by defining cmake
+ # variables with -DPROFNAME etc in src_configure
+ sed -i \
+ -e 's:\([^xc]\)blas:\1${LIBNAME}:g' \
+ -e '/ALL_TARGETS/s:cblas):${LIBNAME}):' \
+ -e '/_librar/s:cblas:${LIBNAME}:' \
+ CMakeLists.txt \
+ CBLAS/src/CMakeLists.txt || die
+ sed -i \
+ -e 's:/CMAKE/:/cmake/:g' \
+ CBLAS/CMakeLists.txt || die
+ sed -i \
+ -e '/Name: /s:cblas:@PROFNAME@:' \
+ -e 's:-lcblas:-l@LIBNAME@:g' \
+ CBLAS/cblas.pc.in || die
+ sed -i \
+ -e 's:cblas):${LIBNAME}):' \
+ CBLAS/testing/CMakeLists.txt || die
+ sed -i \
+ -e 's:BINARY_DIR}/cblas:BINARY_DIR}/${PROFNAME}:' \
+ -e '/CBLAS_INCLUDE/s:include ):include/${PROFNAME} ):g' \
+ CBLAS/CMakeLists.txt || die
+}
+
+src_configure() {
+ cblas_configure() {
+ local FCFLAGS="${FCFLAGS}"
+ append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
+ append-fflags $(get_abi_CFLAGS)
+ append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
+
+ local blas_profname=$(numeric-int64_get_blas_alternative)
+ local profname=$(numeric-int64_get_module_name)
+ local libname="${profname//-/_}"
+
+ local mycmakeargs=(
+ -Wno-dev
+ -DCBLAS=ON
+ -DPROFNAME="${profname}"
+ -DLIBNAME="${libname}"
+ -DUSE_OPTIMIZED_BLAS=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${blas_profname})"
+ -DCMAKE_C_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CFLAGS}"
+ -DCMAKE_CXX_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CXXFLAGS}"
+ -DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(numeric-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"
+ -DLAPACK_PKGCONFIG_FFLAGS="$(numeric-int64_get_fortran_int64_abi_fflags)"
+ -DBUILD_TESTING=$(usex test)
+ )
+ if $(numeric-int64_is_static_build); then
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_STATIC_LIBS=ON
+ )
+ else
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS=OFF
+ )
+ fi
+ cmake-utils_src_configure
+ }
+ numeric-int64-multibuild_foreach_all_abi_variants cblas_configure
+}
+
+src_compile() {
+ local each target_dirs=( CBLAS )
+ use test && target_dirs+=( testing )
+ for each in ${target_dirs[@]}; do
+ numeric-int64-multibuild_foreach_all_abi_variants \
+ cmake-utils_src_compile -C ${each}
+ done
+
+}
+
+src_test() {
+ numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_test
+}
+
+src_install() {
+ numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_install -C CBLAS
+ numeric-int64-multibuild_install_alternative cblas reference /usr/include/cblas.h refcblas/cblas.h
+ multilib_install_wrappers
+}
diff --git a/sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch b/sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch
new file mode 100644
index 000000000..70f7cb0ee
--- /dev/null
+++ b/sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch
@@ -0,0 +1,56 @@
+diff --git a/BLAS/blas.pc.in b/BLAS/blas.pc.in
+index 7fd6f1e..e52f3ad 100644
+--- a/BLAS/blas.pc.in
++++ b/BLAS/blas.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: BLAS
+ Description: FORTRAN reference implementation of BLAS Basic Linear Algebra Subprograms
+diff --git a/CBLAS/cblas.pc.in b/CBLAS/cblas.pc.in
+index 4a938fe..311aed9 100644
+--- a/CBLAS/cblas.pc.in
++++ b/CBLAS/cblas.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: CBLAS
+ Description: C Standard Interface to BLAS Basic Linear Algebra Subprograms
+diff --git a/LAPACKE/lapacke.pc.in b/LAPACKE/lapacke.pc.in
+index 028f8da..dc092b1 100644
+--- a/LAPACKE/lapacke.pc.in
++++ b/LAPACKE/lapacke.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: LAPACKE
+ Description: C Standard Interface to LAPACK Linear Algebra PACKage
+diff --git a/lapack.pc.in b/lapack.pc.in
+index 878efc2..2cca4c2 100644
+--- a/lapack.pc.in
++++ b/lapack.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: LAPACK
+ Description: FORTRAN reference implementation of LAPACK Linear Algebra PACKage