aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-18 23:41:56 +0100
committerJustin Lecher <jlec@gentoo.org>2017-03-18 21:06:59 +0000
commit797e2040d20285291ff21a88b870c0442ed0fd9f (patch)
tree911da6a03f800dbfebee5cb30ef9fcbfab2f3405
parentsci-biology/phusion: respect EPREFIX (diff)
downloadsci-797e2040d20285291ff21a88b870c0442ed0fd9f.tar.gz
sci-797e2040d20285291ff21a88b870c0442ed0fd9f.tar.bz2
sci-797e2040d20285291ff21a88b870c0442ed0fd9f.zip
sci-biology/phusion: allmost corrected build process
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-biology/phusion/phusion-2.1c.ebuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/sci-biology/phusion/phusion-2.1c.ebuild b/sci-biology/phusion/phusion-2.1c.ebuild
index 83b3f546b..35bd43425 100644
--- a/sci-biology/phusion/phusion-2.1c.ebuild
+++ b/sci-biology/phusion/phusion-2.1c.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Whole genome shotgun assembler using phrap (for Sanger-based reads)"
HOMEPAGE="http://www.sanger.ac.uk/resources/software/phusion/"
@@ -15,7 +15,13 @@ LICENSE="all-rights-reserved" # temporarily placed value
# Availability
# Phusion is undergoing a rewrite of the code to make this a portable package. It will be made available free of charge to academic sites, but requires licensing for commercial use. For more information please contact the authors.
SLOT="0"
-KEYWORDS=""
+KEYWORDS="" # compile process does not exit upon errors
+# one file does not compile
+# x86_64-pc-linux-gnu-gcc -O2 -pipe -maes -mpclmul -mpopcnt -mavx -march=native -o contigoverlap contigoverlap.o -lm
+# contigoverlap.o: In function `HashFasta':
+# contigoverlap.c:(.text+0xbb1): relocation truncated to fit: R_X86_64_PC32 against symbol `n_Entry' defined in COMMON section in contigoverlap.o
+# contigoverlap.o: In function `Reads_Overlap':
+# contigoverlap.c:(.text+0x2637): relocation truncated to fit: R_X86_64_32S against symbol `qinfo' defined in COMMON section in contigoverlap.o
IUSE=""
DEPEND="app-shells/tcsh"
@@ -30,6 +36,18 @@ S="${WORKDIR}"/"phusion_pipeline_v2.1c"
src_prepare(){
cp -pf "${EPREFIX}"/usr/bin/phrap src/phrap/phrap.manylong || die
+ # prevent file collision with sci-biology/shrimp-2.2.3 and sci-biology/phusion2-3.0
+ sed -e "s#fasta2fastq#fasta2fastq_"${PN}"#" -i src/fasta2fastq/fasta2fastq.c \
+ src/fasta2fastq/Makefile || die
+ sed -e "s#ctgreads.pl#ctgreads_"${PN}".pl#" -i src/Tcsh_scripts/*.csh || die
+ mv src/fasta2fastq/fasta2fastq.c src/fasta2fastq/fasta2fastq_"${PN}".c || die
+ mv src/Perl_scripts/ctgreads.pl src/Perl_scripts/ctgreads_"${PN}".pl || die
+ find . -name Makefile | while read f; do
+ sed -e "s/^CC =/CC = $(tc-getCC) #/" -i "$f" || die
+ sed -e "s/^ CFLAGS2 =/ CFLAGS2 = ${CFLAGS} #/" -i "$f" || die
+ sed -e "s/^CFLAGS =/CFLAGS = ${CFLAGS} #/" -i "$f" || die
+ sed -e "s/^ CFLAGS =/ CFLAGS = ${CFLAGS} #/" -i "$f" || die
+ done
}
src_compile(){