aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-09 15:05:53 +0200
committerChristoph Junghans <ottxor@gentoo.org>2012-10-09 15:05:53 +0200
commit51983e42327255f26e9d4a32e52b2dee132ba86b (patch)
treed2a7672338ba0f3dcf1e59600795d6f7054811a7
parentpackage.mask: added sci-physics/espresso++ (diff)
downloadsci-51983e42327255f26e9d4a32e52b2dee132ba86b.tar.gz
sci-51983e42327255f26e9d4a32e52b2dee132ba86b.tar.bz2
sci-51983e42327255f26e9d4a32e52b2dee132ba86b.zip
initial commit (thx to Torsten Stuehn)
(Portage version: 2.2.0_alpha136/git/Linux i686)
-rw-r--r--sci-physics/espresso++/ChangeLog9
-rw-r--r--sci-physics/espresso++/espresso++-9999.ebuild43
-rw-r--r--sci-physics/espresso++/metadata.xml12
3 files changed, 64 insertions, 0 deletions
diff --git a/sci-physics/espresso++/ChangeLog b/sci-physics/espresso++/ChangeLog
new file mode 100644
index 000000000..2602ad68d
--- /dev/null
+++ b/sci-physics/espresso++/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-physics/espresso++
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*espresso++-9999 (09 Oct 2012)
+
+ 09 Oct 2012; Christoph Junghans <ottxor@gentoo.org> +espresso++-9999.ebuild,
+ +metadata.xml:
+ initial commit (thx to Torsten Stuehn)
diff --git a/sci-physics/espresso++/espresso++-9999.ebuild b/sci-physics/espresso++/espresso++-9999.ebuild
new file mode 100644
index 000000000..41eda0d61
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.1.0.ebuild,v 1.5 2012/05/06 23:08:00 ottxor Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python
+
+DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
+HOMEPAGE="https://www.espresso-pp.de"
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://hg.berlios.de/repos/espressopp"
+ EHG_REVISION="default"
+ inherit mercurial
+else
+ SRC_URI="https://www.espresso-pp.de/Download/${PN%++}pp_${PV//./_}.tgz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+IUSE="-system-boost"
+
+RDEPEND="
+ system-boost? ( dev-libs/boost[python,mpi] )
+ virtual/mpi
+ "
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN%++}pp"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-physics/espresso++/metadata.xml b/sci-physics/espresso++/metadata.xml
new file mode 100644
index 000000000..14341e73e
--- /dev/null
+++ b/sci-physics/espresso++/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name='system-boost'>Use system boost (<pkg>dev-libs/boost</pkg>) instead of bundled one</flag>
+ </use>
+</pkgmetadata>