aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-02-08 14:21:55 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-02-08 14:21:55 +0100
commitbcb77272ceec70b0e26afe6f50ac87b464d66d09 (patch)
tree3cf7a94fdf0bebec98b3f6486070df41182ecbda
parentdev-python/hdf5storage: Add new package, ebuild written by me (diff)
downloadsci-bcb77272ceec70b0e26afe6f50ac87b464d66d09.tar.gz
sci-bcb77272ceec70b0e26afe6f50ac87b464d66d09.tar.bz2
sci-bcb77272ceec70b0e26afe6f50ac87b464d66d09.zip
dev-python/arrayfire-python: Bump to EAPI=6, cleanup ebuilds
Package-Manager: portage-2.2.26
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.1.20151111.ebuild21
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.2.20151214.ebuild4
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.2.20151224.ebuild4
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-9999.ebuild18
4 files changed, 16 insertions, 31 deletions
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.1.20151111.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.1.20151111.ebuild
index 659b7bbe9..ee1d0672b 100644
--- a/dev-python/arrayfire-python/arrayfire-python-3.1.20151111.ebuild
+++ b/dev-python/arrayfire-python/arrayfire-python-3.1.20151111.ebuild
@@ -1,28 +1,23 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
-DESCRIPTION="Python bindings for ArrayFire"
-HOMEPAGE="http://www.arrayfire.com"
-
MY_PN="arrayfire"
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/arrayfire/${PN}.git git://github.com/arrayfire/${PN}.git"
-else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
+DESCRIPTION="Python bindings for ArrayFire"
+HOMEPAGE="http://www.arrayfire.com"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
RDEPEND="
>=sci-libs/arrayfire-3.0.0
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.2.20151214.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.2.20151214.ebuild
index 0a6ea8350..643456201 100644
--- a/dev-python/arrayfire-python/arrayfire-python-3.2.20151214.ebuild
+++ b/dev-python/arrayfire-python/arrayfire-python-3.2.20151214.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.2.20151224.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.2.20151224.ebuild
index 0a6ea8350..643456201 100644
--- a/dev-python/arrayfire-python/arrayfire-python-3.2.20151224.ebuild
+++ b/dev-python/arrayfire-python/arrayfire-python-3.2.20151224.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
diff --git a/dev-python/arrayfire-python/arrayfire-python-9999.ebuild b/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
index 659b7bbe9..f725dca5d 100644
--- a/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
+++ b/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
@@ -1,25 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-inherit distutils-r1
+inherit distutils-r1 git-r3
DESCRIPTION="Python bindings for ArrayFire"
HOMEPAGE="http://www.arrayfire.com"
-
-MY_PN="arrayfire"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/arrayfire/${PN}.git git://github.com/arrayfire/${PN}.git"
-else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
+EGIT_REPO_URI="https://github.com/arrayfire/${PN}.git git://github.com/arrayfire/${PN}.git"
LICENSE="BSD"
SLOT="0"