aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-18 13:12:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-02-18 13:12:55 +0100
commit01e2330f4f7deb37f0bc8383363b610837341666 (patch)
tree9ccf8be35bb384543554f760102825b82c272d18
parentnet-ftp/bbftp-server: fix SLOT operators (diff)
downloadsci-01e2330f4f7deb37f0bc8383363b610837341666.tar.gz
sci-01e2330f4f7deb37f0bc8383363b610837341666.tar.bz2
sci-01e2330f4f7deb37f0bc8383363b610837341666.zip
sci-astronomy/astrometry: fix SLOT operators; fix usage of die
Package-Manager: portage-2.2.17
-rw-r--r--sci-astronomy/astrometry/ChangeLog6
-rw-r--r--sci-astronomy/astrometry/astrometry-0.43.ebuild22
-rw-r--r--sci-astronomy/astrometry/metadata.xml10
3 files changed, 21 insertions, 17 deletions
diff --git a/sci-astronomy/astrometry/ChangeLog b/sci-astronomy/astrometry/ChangeLog
index dfd71da12..1f543a3ce 100644
--- a/sci-astronomy/astrometry/ChangeLog
+++ b/sci-astronomy/astrometry/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-astronomy/astrometry
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 18 Feb 2015; Justin Lecher <jlec@gentoo.org> astrometry-0.43.ebuild,
+ metadata.xml:
+ sci-astronomy/astrometry: fix SLOT operators; fix usage of die
+
17 Mar 2014; Joseph Jon Booker <joe@neoturbine.net> astrometry-0.43.ebuild:
Use python-single-r1 and fix typo for USE=extra
diff --git a/sci-astronomy/astrometry/astrometry-0.43.ebuild b/sci-astronomy/astrometry/astrometry-0.43.ebuild
index 4db5cfb1d..843543a65 100644
--- a/sci-astronomy/astrometry/astrometry-0.43.ebuild
+++ b/sci-astronomy/astrometry/astrometry-0.43.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_COMPAT=( python2_7 )
+
inherit eutils toolchain-funcs python-single-r1
MYP=${PN}.net-${PV}
@@ -15,7 +16,6 @@ SRC_URI="${HOMEPAGE}/downloads/${MYP}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples extra python"
@@ -27,12 +27,12 @@ RDEPEND="
sys-libs/zlib
virtual/pyfits[${PYTHON_USEDEP}]
extra? (
- media-libs/libpng
+ media-libs/libpng:0
media-libs/netpbm
- virtual/jpeg
+ virtual/jpeg:0
x11-libs/cairo )"
DEPEND="${RDEPEND}
- dev-lang/swig
+ dev-lang/swig:0
virtual/pkgconfig"
S="${WORKDIR}/${MYP}"
@@ -44,11 +44,11 @@ src_prepare() {
"${FILESDIR}"/0.43-system-libs.patch
python_fix_shebang "${S}"
- sed "s|python setup-util.py|${EPYTHON} setup-util.py|" "${S}"/util/Makefile -i
- sed "s|python setup.py|${EPYTHON} setup.py|" "${S}"/{libkd,sdss,blind}/Makefile -i
- sed "s|python -c|${EPYTHON} -c|" "${S}"/blind/Makefile -i
- sed "s|python <<EOF|${EPYTHON} <<EOF|" "${S}"/blind/simplexy.c -i
- sed "s|python -V|${EPYTHON} -V|" "${S}"/Makefile -i
+ sed "s|python setup-util.py|${EPYTHON} setup-util.py|" "${S}"/util/Makefile -i || die
+ sed "s|python setup.py|${EPYTHON} setup.py|" "${S}"/{libkd,sdss,blind}/Makefile -i || die
+ sed "s|python -c|${EPYTHON} -c|" "${S}"/blind/Makefile -i || die
+ sed "s|python <<EOF|${EPYTHON} <<EOF|" "${S}"/blind/simplexy.c -i || die
+ sed "s|python -V|${EPYTHON} -V|" "${S}"/Makefile -i || die
}
src_compile() {
diff --git a/sci-astronomy/astrometry/metadata.xml b/sci-astronomy/astrometry/metadata.xml
index 664a74cf3..3de66c743 100644
--- a/sci-astronomy/astrometry/metadata.xml
+++ b/sci-astronomy/astrometry/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-astronomy</herd>
-<longdescription lang="en">
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
If you have astronomical imaging of the sky with celestial
coordinates you do not know—or do not trust—then Astrometry.net is
for you. Input an image and we'll give you back astrometric
calibration meta-data, plus lists of known objects falling inside
the field of view.
</longdescription>
-<use>
- <flag name="extra">Add extra tools, specifically for plots</flag>
-</use>
+ <use>
+ <flag name="extra">Add extra tools, specifically for plots</flag>
+ </use>
</pkgmetadata>